summaryrefslogtreecommitdiff
path: root/dev-util/cgdb/cgdb-0.7.0.ebuild
diff options
context:
space:
mode:
authorNado <nado@troglodyte.be>2017-08-10 19:26:32 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-08-11 05:54:28 +0200
commit718d38d052a1c9afcd67b3c0afe085af465c7217 (patch)
tree3feafde814a99ffd66d88daa6c116d8c51c45c4c /dev-util/cgdb/cgdb-0.7.0.ebuild
parent5913e9c6d6798fd69afcc7d51a5711981f09fc1f (diff)
downloadgentoo-718d38d052a1c9afcd67b3c0afe085af465c7217.tar.gz
gentoo-718d38d052a1c9afcd67b3c0afe085af465c7217.tar.xz
dev-util/cgdb: version bump to 0.7.0.
Package-Manager: Portage-2.3.6, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/5382
Diffstat (limited to 'dev-util/cgdb/cgdb-0.7.0.ebuild')
-rw-r--r--dev-util/cgdb/cgdb-0.7.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-util/cgdb/cgdb-0.7.0.ebuild b/dev-util/cgdb/cgdb-0.7.0.ebuild
new file mode 100644
index 00000000000..f1e40470f22
--- /dev/null
+++ b/dev-util/cgdb/cgdb-0.7.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="
+ https://github.com/cgdb/cgdb.git
+ git@github.com:cgdb/cgdb.git"
+else
+ SRC_URI="https://github.com/cgdb/cgdb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+fi
+inherit multilib-minimal
+
+DESCRIPTION="A curses front-end for GDB, the GNU debugger"
+HOMEPAGE="http://cgdb.github.io/"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+
+COMMONDEPEND="
+ sys-libs/ncurses:0=
+ sys-libs/readline:0="
+
+DEPEND="${COMMONDEPEND}
+ test? ( dev-util/dejagnu )"
+
+RDEPEND="
+ ${COMMONDEPEND}
+ sys-devel/gdb"
+
+DOCS=( AUTHORS ChangeLog FAQ INSTALL NEWS README.md )
+
+src_prepare() {
+ default
+ ./autogen.sh || die
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf
+}