summaryrefslogtreecommitdiff
path: root/dev-util/cmt
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/cmt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/cmt')
-rw-r--r--dev-util/cmt/Manifest1
-rw-r--r--dev-util/cmt/cmt-1.26.ebuild91
-rw-r--r--dev-util/cmt/files/80cmt-mode-gentoo.el6
-rw-r--r--dev-util/cmt/files/cmt-1.22-limits.patch10
-rw-r--r--dev-util/cmt/metadata.xml16
5 files changed, 124 insertions, 0 deletions
diff --git a/dev-util/cmt/Manifest b/dev-util/cmt/Manifest
new file mode 100644
index 00000000000..09ef870f56c
--- /dev/null
+++ b/dev-util/cmt/Manifest
@@ -0,0 +1 @@
+DIST CMTv1r26.tar.gz 2194291 SHA256 1f4edd814aae018707325aed893d04a82e5e609ec8f082dd511373e33e987e34 SHA512 412366dbf4aaef9f092f9472792e314c6d8f3e0360ddfa6d135e2bea9a167b627ddc78ad5a2d4f5139b4835abb68c06166abf3204bf5ba3969089923782e817e WHIRLPOOL 049f511c85ff1cf0a0cefec6cca7020f44fd2e86b76e649bc5bc583b2ac60f5ea3d683b52d630712ac1d729cd0fd92364b4192937130ef84ff66f5d9ef8940e0
diff --git a/dev-util/cmt/cmt-1.26.ebuild b/dev-util/cmt/cmt-1.26.ebuild
new file mode 100644
index 00000000000..508853a705d
--- /dev/null
+++ b/dev-util/cmt/cmt-1.26.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils elisp-common multilib toolchain-funcs versionator
+
+CPV=($(get_version_components ${PV}))
+CMT_PV=v${CPV[0]}r${CPV[1]}
+
+DESCRIPTION="Cross platform configuration management environment"
+HOMEPAGE="http://www.cmtsite.net/"
+SRC_URI="http://www.cmtsite.net/${CMT_PV}/CMT${CMT_PV}.tar.gz"
+
+LICENSE="CeCILL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="emacs java doc"
+
+DEPEND="emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}
+ java? ( virtual/jdk )"
+
+S="${WORKDIR}/CMT/${CMT_PV}"
+
+src_configure() {
+ cd "${S}"/mgr || die
+ ./INSTALL || die
+ source setup.sh
+}
+
+src_compile() {
+ cd "${S}"/mgr || die
+ emake \
+ cpp="$(tc-getCXX)" \
+ cppflags="${CXXFLAGS}" \
+ cpplink="$(tc-getCXX) ${LDFLAGS}"
+
+ sed -i -e "s:${WORKDIR}:${EPREFIX}/usr/$(get_libdir):g" setup.*sh || die
+ cd "${S}" || die
+ mv src/demo . || die
+ rm ${CMTBIN}/*.o || die
+
+ use emacs && elisp-compile doc/cmt-mode.el
+}
+
+src_install() {
+ CMTDIR=/usr/$(get_libdir)/CMT/${CMT_PV}
+ dodir ${CMTDIR}
+ cp -pPR mgr src ${CMTBIN} "${ED}"/${CMTDIR} || die
+ dodir /usr/bin
+ dosym ${CMTDIR}/${CMTBIN}/cmt.exe /usr/bin/cmt
+
+ cat > 99cmt <<-EOF
+ CMTROOT="${EROOT%/}${CMTDIR}"
+ CMTBIN="$(uname)-$(uname -m | sed -e 's# ##g')"
+ CMTCONFIG="$(${CMTROOT}/mgr/cmt_system.sh)"
+ EOF
+ if use java; then
+ cp -pPR java "${ED}"/${CMTDIR}
+ echo "#!${EPREFIX}/bin/sh" > jcmt
+ echo "java cmt_parser" >> jcmt
+ dobin jcmt
+ echo "CLASSPATH=\"${CMTDIR}/java/cmt.jar\"" >> 99cmt
+ fi
+
+ doenvd 99cmt
+ dodoc ChangeLog doc/*.txt
+ dohtml doc/{ChangeLog,ReleaseNotes}.html
+
+ if use doc; then
+ emake -C mgr gendoc
+ insinto /usr/share/doc/${PF}
+ doins -r doc/{CMTDoc,CMTFAQ}.{html,pdf} doc/Images
+ doins -r demo
+ fi
+
+ if use emacs; then
+ elisp-install ${PN} doc/cmt-mode.{el,elc} || die
+ elisp-site-file-install "${FILESDIR}"/80cmt-mode-gentoo.el || die
+ fi
+}
+
+pkg_postinst () {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/cmt/files/80cmt-mode-gentoo.el b/dev-util/cmt/files/80cmt-mode-gentoo.el
new file mode 100644
index 00000000000..91be98ebc61
--- /dev/null
+++ b/dev-util/cmt/files/80cmt-mode-gentoo.el
@@ -0,0 +1,6 @@
+
+;;; cmt site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'cmt-mode "cmt-mode" "CMT requirements file editing mode." t)
+(add-to-list 'auto-mode-alist '("requirements\\'" . cmt-mode))
diff --git a/dev-util/cmt/files/cmt-1.22-limits.patch b/dev-util/cmt/files/cmt-1.22-limits.patch
new file mode 100644
index 00000000000..99ce621fc27
--- /dev/null
+++ b/dev-util/cmt/files/cmt-1.22-limits.patch
@@ -0,0 +1,10 @@
+--- source/cmt_awk.cxx.orig 2011-03-23 19:03:17.000000000 +0000
++++ source/cmt_awk.cxx 2011-03-23 19:03:48.000000000 +0000
+@@ -12,6 +12,7 @@
+ #define PATH_MAX _MAX_PATH
+ #endif
+
++#include <climits>
+ #include "cmt_awk.h"
+ #include "cmt_system.h"
+ #include "cmt_log.h"
diff --git a/dev-util/cmt/metadata.xml b/dev-util/cmt/metadata.xml
new file mode 100644
index 00000000000..53d37b8a512
--- /dev/null
+++ b/dev-util/cmt/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>bicatali@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ CMT is a configuration management environment, based on some
+ management conventions and comprises several shell-based
+ utilities. It is an attempt to formalize software production and
+ especially configuration management around a package-oriented
+ principle. Used in High Energy Physics large experiments, where
+ tailored packages are developped and they do not know the existence
+ of portage and overlays.
+</longdescription>
+</pkgmetadata>