summaryrefslogtreecommitdiff
path: root/dev-util/coccinelle
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/coccinelle
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/coccinelle')
-rw-r--r--dev-util/coccinelle/Manifest2
-rw-r--r--dev-util/coccinelle/coccinelle-1.0.0.ebuild139
-rw-r--r--dev-util/coccinelle/coccinelle-1.0.1.ebuild139
-rw-r--r--dev-util/coccinelle/files/50coccinelle-gentoo.el6
-rw-r--r--dev-util/coccinelle/files/coccinelle-1.0.0_rc16-findtool.patch11
-rw-r--r--dev-util/coccinelle/metadata.xml9
6 files changed, 306 insertions, 0 deletions
diff --git a/dev-util/coccinelle/Manifest b/dev-util/coccinelle/Manifest
new file mode 100644
index 00000000000..9a217321114
--- /dev/null
+++ b/dev-util/coccinelle/Manifest
@@ -0,0 +1,2 @@
+DIST coccinelle-1.0.0.tgz 3427246 SHA256 e18b4c77964c6f623c385dc8b2fcb46beacd9811927617144620b12d93289e74 SHA512 0c59918dff3d33035f5c928b54de9cbe32f9146d9e4b82545d168140d1395ff5b3e446faff47f39dbb6fceb74f432b419e9c7322e834c11bb50b5fb5d4e4dd46 WHIRLPOOL 8714327d7156bd1ada0c6b0776fefcc4e46b9885354ca686d4de8b35c2dd1cf6372e91dfa3a04645295f411b40d57eee94d81cbd8dfe2c18f3dc3b15ff8e1926
+DIST coccinelle-1.0.1.tgz 2772730 SHA256 39caac46c1f80cbe5de21164c5b31a794e3befdb9cd7ef1d080d455ac171b526 SHA512 5a69476941a9582ca6e0663c468a87aba15b6e38243cbb532c517b75066c8fafe37cbe6d398d6183cc7a315c5680efdf425f0bc8cb2184dbf94e446879514a89 WHIRLPOOL 8b38b982b8d19c10c7e3ed77629b6883c4d6455da4da4d68251b492ce36490c5236573bf7c44a34e21887b8be0ca83b4efb39cf13b1c4c6db7db58979ee6a7bc
diff --git a/dev-util/coccinelle/coccinelle-1.0.0.ebuild b/dev-util/coccinelle/coccinelle-1.0.0.ebuild
new file mode 100644
index 00000000000..f7b42921a36
--- /dev/null
+++ b/dev-util/coccinelle/coccinelle-1.0.0.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit multilib eutils python-single-r1 bash-completion-r1 elisp-common autotools
+
+MY_P="${P/_/-}"
+DESCRIPTION="Program matching and transformation engine"
+HOMEPAGE="http://coccinelle.lip6.fr/"
+SRC_URI="http://coccinelle.lip6.fr/distrib/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc emacs ocaml +ocamlopt pcre python test vim-syntax"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# ocaml enables ocaml scripting (uses findlib)
+CDEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]
+ dev-ml/sexplib:=[ocamlopt?]
+ dev-ml/menhir:=[ocamlopt?]
+ || ( dev-ml/camlp4:=[ocamlopt?] <dev-lang/ocaml-4.02.0 )
+ dev-ml/parmap:=[ocamlopt?]
+ emacs? ( virtual/emacs )
+ ocaml? ( dev-ml/findlib:= )
+ pcre? ( dev-ml/pcre-ocaml:=[ocamlopt?] )
+ python? ( ${PYTHON_DEPS} )"
+
+RDEPEND="${CDEPEND}
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
+
+# dev-texlive/texlive-fontsextra contains 'ifsym.sty'
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ doc? (
+ virtual/latex-base
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-fontsextra
+ )"
+
+REQUIRED_USE="test? ( ocaml python )"
+
+DOCS=( authors.txt bugs.txt changes.txt credits.txt readme.txt )
+
+S=${WORKDIR}/${MY_P}
+
+SITEFILE=50coccinelle-gentoo.el
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ if use python ; then
+ # fix python install location
+ sed -e "s:\$(SHAREDIR)/python:$(python_get_sitedir):" \
+ -e "s:PYTHON_TARGET:PYTHON_INSTALL_TARGET:" \
+ -i Makefile || die
+ fi
+
+ sed -i "s:^SHAREDIR=.*:SHAREDIR=/usr/$(get_libdir)/ocaml/${PN}/:" scripts/spatch.sh.in || die
+
+ # This is regenerated by menhir, bundled version does not build with latest
+ # one...
+ rm -f parsing_cocci/parser_cocci_menhir.ml
+
+ epatch "${FILESDIR}"/${PN}-1.0.0_rc16-findtool.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable python) \
+ $(use_enable ocaml) \
+ $(use_enable pcre) \
+ $(use_enable pcre pcre-syntax)
+
+ sed -e "s:^LIBDIR=.*:LIBDIR=/usr/$(get_libdir)/ocaml/stublibs/:" \
+ -e "s:^SHAREDIR=.*:SHAREDIR=/usr/$(get_libdir)/ocaml/${PN}/:" \
+ -i Makefile.config || die
+}
+
+src_compile() {
+ emake depend
+ emake
+
+ use ocamlopt && emake opt
+
+ if use doc ; then
+ VARTEXFONTS="${T}"/fonts emake docs
+ fi
+
+ if use emacs ; then
+ elisp-compile editors/emacs/cocci.el || die
+ fi
+}
+
+src_test() {
+ source env.sh # needed for built in-place python plugin
+ ./spatch standard.h -parse_c -dir tests/ || die
+ yes | ./spatch -iso_file standard.iso -macro_file_builtins standard.h -testall || die
+ if use ocamlopt ; then
+ ./spatch.opt -iso_file standard.iso -macro_file_builtins standard.h -testall || die
+ fi
+}
+
+src_install() {
+ default
+
+ use doc && dodoc docs/manual/*.pdf
+ newbashcomp scripts/spatch.bash_completion spatch
+
+ if use emacs ; then
+ elisp-install ${PN} editors/emacs/*
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ fi
+
+ if use vim-syntax ; then
+ newdoc editors/vim/README README-vim
+ rm editors/vim/README || die
+ insinto /usr/share/vim/vimfiles
+ doins -r editors/vim/*
+ fi
+
+ use python && python_optimize
+
+ export STRIP_MASK='*/coccinelle/spatch'
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/coccinelle/coccinelle-1.0.1.ebuild b/dev-util/coccinelle/coccinelle-1.0.1.ebuild
new file mode 100644
index 00000000000..2a9f559c0a6
--- /dev/null
+++ b/dev-util/coccinelle/coccinelle-1.0.1.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit multilib eutils python-single-r1 bash-completion-r1 elisp-common autotools
+
+MY_P="${P/_/-}"
+DESCRIPTION="Program matching and transformation engine"
+HOMEPAGE="http://coccinelle.lip6.fr/"
+SRC_URI="http://coccinelle.lip6.fr/distrib/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc emacs ocaml +ocamlopt pcre python test vim-syntax"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# ocaml enables ocaml scripting (uses findlib)
+CDEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]
+ dev-ml/sexplib:=[ocamlopt?]
+ dev-ml/menhir:=[ocamlopt?]
+ || ( dev-ml/camlp4:=[ocamlopt?] <dev-lang/ocaml-4.02.0 )
+ dev-ml/parmap:=[ocamlopt?]
+ emacs? ( virtual/emacs )
+ ocaml? ( dev-ml/findlib:= )
+ pcre? ( dev-ml/pcre-ocaml:=[ocamlopt?] )
+ python? ( ${PYTHON_DEPS} )"
+
+RDEPEND="${CDEPEND}
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
+
+# dev-texlive/texlive-fontsextra contains 'ifsym.sty'
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ doc? (
+ virtual/latex-base
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-fontsextra
+ )"
+
+REQUIRED_USE="test? ( ocaml python )"
+
+DOCS=( authors.txt bugs.txt changes.txt credits.txt readme.txt )
+
+S=${WORKDIR}/${MY_P}
+
+SITEFILE=50coccinelle-gentoo.el
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ if use python ; then
+ # fix python install location
+ sed -e "s:\$(SHAREDIR)/python:$(python_get_sitedir):" \
+ -e "s:PYTHON_TARGET:PYTHON_INSTALL_TARGET:" \
+ -i Makefile || die
+ fi
+
+ sed -i "s:^SHAREDIR=.*:SHAREDIR=/usr/$(get_libdir)/ocaml/${PN}/:" scripts/spatch.sh.in || die
+
+ # This is regenerated by menhir, bundled version does not build with latest
+ # one...
+ rm -f parsing_cocci/parser_cocci_menhir.ml
+
+ epatch "${FILESDIR}"/${PN}-1.0.0_rc16-findtool.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable python) \
+ $(use_enable ocaml) \
+ $(use_enable pcre) \
+ $(use_enable pcre pcre-syntax)
+
+ sed -e "s:^LIBDIR=.*:LIBDIR=/usr/$(get_libdir)/ocaml/stublibs/:" \
+ -e "s:^SHAREDIR=.*:SHAREDIR=/usr/$(get_libdir)/ocaml/${PN}/:" \
+ -i Makefile.config || die
+}
+
+src_compile() {
+ emake depend
+ emake
+
+ use ocamlopt && emake opt
+
+ if use doc ; then
+ VARTEXFONTS="${T}"/fonts emake docs
+ fi
+
+ if use emacs ; then
+ elisp-compile editors/emacs/cocci.el || die
+ fi
+}
+
+src_test() {
+ source env.sh # needed for built in-place python plugin
+ ./spatch standard.h -parse_c -dir tests/ || die
+ yes | ./spatch -iso_file standard.iso -macro_file_builtins standard.h -testall || die
+ if use ocamlopt ; then
+ ./spatch.opt -iso_file standard.iso -macro_file_builtins standard.h -testall || die
+ fi
+}
+
+src_install() {
+ default
+
+ use doc && dodoc docs/manual/*.pdf
+ newbashcomp scripts/spatch.bash_completion spatch
+
+ if use emacs ; then
+ elisp-install ${PN} editors/emacs/*
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ fi
+
+ if use vim-syntax ; then
+ newdoc editors/vim/README README-vim
+ rm editors/vim/README || die
+ insinto /usr/share/vim/vimfiles
+ doins -r editors/vim/*
+ fi
+
+ use python && python_optimize
+
+ export STRIP_MASK='*/coccinelle/spatch'
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/coccinelle/files/50coccinelle-gentoo.el b/dev-util/coccinelle/files/50coccinelle-gentoo.el
new file mode 100644
index 00000000000..6721b3c5e5a
--- /dev/null
+++ b/dev-util/coccinelle/files/50coccinelle-gentoo.el
@@ -0,0 +1,6 @@
+
+;;; site-lisp configuration for coccinelle
+
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'cocci-mode "cocci" "Major mode for editing cocci code." t)
diff --git a/dev-util/coccinelle/files/coccinelle-1.0.0_rc16-findtool.patch b/dev-util/coccinelle/files/coccinelle-1.0.0_rc16-findtool.patch
new file mode 100644
index 00000000000..bc0dd97ddcf
--- /dev/null
+++ b/dev-util/coccinelle/files/coccinelle-1.0.0_rc16-findtool.patch
@@ -0,0 +1,11 @@
+--- coccinelle-1.0.0-rc16/setup/cocci.m4
++++ coccinelle-1.0.0-rc16/setup/cocci.m4
+@@ -285,7 +285,7 @@
+ AC_SUBST([$1], [no])
+ ],
+ [dnl find the tool
+- AC_COCCI_FINDTOOL([$1],[[$]$1])
++ AC_COCCI_FINDTOOL([$1],[$2])
+ ])
+
+ AS_IF([test -z "[$]$1" -o "x[$]$1" = xno],
diff --git a/dev-util/coccinelle/metadata.xml b/dev-util/coccinelle/metadata.xml
new file mode 100644
index 00000000000..06d54062e2f
--- /dev/null
+++ b/dev-util/coccinelle/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+<maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+</maintainer>
+</pkgmetadata>