summaryrefslogtreecommitdiff
path: root/dev-util/comparator
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/comparator
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/comparator')
-rw-r--r--dev-util/comparator/Manifest3
-rw-r--r--dev-util/comparator/comparator-2.10.ebuild40
-rw-r--r--dev-util/comparator/comparator-2.5.ebuild52
-rw-r--r--dev-util/comparator/comparator-2.9.ebuild52
-rw-r--r--dev-util/comparator/metadata.xml9
5 files changed, 156 insertions, 0 deletions
diff --git a/dev-util/comparator/Manifest b/dev-util/comparator/Manifest
new file mode 100644
index 00000000000..e2041ba4594
--- /dev/null
+++ b/dev-util/comparator/Manifest
@@ -0,0 +1,3 @@
+DIST comparator-2.10.tar.gz 1463175 SHA256 9fcada1a38d376351f67cd6b6aa4907b4fd835cbdadaa48d87a6ddf86545fa98 SHA512 b880f7a4a0fbfad44c53606c6d97509305d8485f0ab76b62bb0d1d1d6d4be9fb81e7a08326e78cabd1a9314e6efbf3a966eb6393e424f59dc657975a63ce2988 WHIRLPOOL 85e853f381f5f384e87cf5b0140f23b8511ae30d5c7b7124c6f875c0a5b30ae3a72dfaf70acdeee4e6e099fb81062c10cbe5da371344e0bdddcfdb433a4e3169
+DIST comparator-2.5.tar.gz 1469060 SHA256 d6151d72a3517470292b405fc4e7b0f518ed335377464228677e2416cae52c25 SHA512 aceaabf7bbcce961def9acfdcce3595685d958b330a82dfe48bf3c72cdc672705542f77d27d726c91aa51a6f3a7b3f0909084f4aed8e480d4e1bce55574b3df8 WHIRLPOOL 67339d3e323cfb025502499a45f967762698ec9782bb72eda3b68028ab0b9869e1c3b61004edcf133c49c4dab532c9107d09ff4b76a694508f6c85321a3bef46
+DIST comparator-2.9.tar.gz 1463064 SHA256 3fd8b3a8e36e7633950f333f23c60c35ed9a1ac78e9b6f69950908919043d682 SHA512 039c2edead2366f9c067a279b0449a6c5e7872acbe1c06ed5ad31bd3c76eee3c514abe6dd53a4921c2ad382a82c53fcff2db73338532594621327b5bb440d442 WHIRLPOOL 4c608a3627b0e309521f441d088f89f6768e466fa660d75da10e15dd18bba027070a65826a92d5b27254db3b7df76e9164cb1456c3bd4e2b27d5c39ce2027016
diff --git a/dev-util/comparator/comparator-2.10.ebuild b/dev-util/comparator/comparator-2.10.ebuild
new file mode 100644
index 00000000000..561ac8914c0
--- /dev/null
+++ b/dev-util/comparator/comparator-2.10.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="ESR's utility for making fast comparisons among large source trees"
+HOMEPAGE="http://www.catb.org/~esr/comparator/"
+SRC_URI="http://www.catb.org/~esr/comparator/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm ~mips ppc ppc64 ~sparc x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="=app-text/docbook-xml-dtd-4.1.2*
+ app-text/xmlto"
+
+src_prepare() {
+ sed \
+ -e '/python setup.py install/d' \
+ -i Makefile || die "sed failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+ emake comparator.html scf-standard.html
+ distutils-r1_src_compile
+}
+
+src_install() {
+ emake ROOT="${D}" install
+ distutils-r1_src_install
+ docinto html
+ dodoc *.html
+}
diff --git a/dev-util/comparator/comparator-2.5.ebuild b/dev-util/comparator/comparator-2.5.ebuild
new file mode 100644
index 00000000000..bb1b700e918
--- /dev/null
+++ b/dev-util/comparator/comparator-2.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils toolchain-funcs
+
+DESCRIPTION="ESR's utility for making fast comparisons among large source trees"
+HOMEPAGE="http://www.catb.org/~esr/comparator/"
+SRC_URI="http://www.catb.org/~esr/comparator/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="sparc"
+IUSE=""
+
+RDEPEND=""
+DEPEND="=app-text/docbook-xml-dtd-4.1.2*
+ app-text/xmlto"
+
+PYTHON_MODNAME="comparator.py"
+
+src_prepare() {
+ sed \
+ -e '/install -m 755 -o 0 -g 0 filterator/d' \
+ -e '/python setup.py install/d' \
+ -i Makefile || die "sed failed"
+}
+
+src_compile() {
+ distutils_src_compile
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die "emake failed"
+ emake comparator.html scf-standard.html || die "emake html failed"
+}
+
+src_install() {
+ distutils_src_install
+ emake ROOT="${D}" install || die "emake install failed"
+
+ install_filterator() {
+ newbin filterator filterator-${PYTHON_ABI} || return 1
+ python_convert_shebangs ${PYTHON_ABI} "${ED}usr/bin/filterator-${PYTHON_ABI}"
+ }
+ python_execute_function -q install_filterator
+ python_generate_wrapper_scripts "${ED}usr/bin/filterator"
+
+ dohtml *.html || die "dohtml failed"
+}
diff --git a/dev-util/comparator/comparator-2.9.ebuild b/dev-util/comparator/comparator-2.9.ebuild
new file mode 100644
index 00000000000..e0a0e61ffc4
--- /dev/null
+++ b/dev-util/comparator/comparator-2.9.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils toolchain-funcs
+
+DESCRIPTION="ESR's utility for making fast comparisons among large source trees"
+HOMEPAGE="http://www.catb.org/~esr/comparator/"
+SRC_URI="http://www.catb.org/~esr/comparator/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm ~mips ppc ppc64 ~sparc x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="=app-text/docbook-xml-dtd-4.1.2*
+ app-text/xmlto"
+
+PYTHON_MODNAME="comparator.py"
+
+src_prepare() {
+ sed \
+ -e '/install -m 755 -o 0 -g 0 filterator/d' \
+ -e '/python setup.py install/d' \
+ -i Makefile || die "sed failed"
+}
+
+src_compile() {
+ distutils_src_compile
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+ emake comparator.html scf-standard.html
+}
+
+src_install() {
+ distutils_src_install
+ emake ROOT="${D}" install
+
+ install_filterator() {
+ newbin filterator filterator-${PYTHON_ABI} || return 1
+ python_convert_shebangs ${PYTHON_ABI} "${ED}usr/bin/filterator-${PYTHON_ABI}"
+ }
+ python_execute_function -q install_filterator
+ python_generate_wrapper_scripts "${ED}usr/bin/filterator"
+
+ dohtml *.html
+}
diff --git a/dev-util/comparator/metadata.xml b/dev-util/comparator/metadata.xml
new file mode 100644
index 00000000000..eb3a223072c
--- /dev/null
+++ b/dev-util/comparator/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <longdescription>ESR's utility for making fast comparisons among large source trees</longdescription>
+</pkgmetadata>