summaryrefslogtreecommitdiff
path: root/dev-util/cutils
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/cutils
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/cutils')
-rw-r--r--dev-util/cutils/Manifest1
-rw-r--r--dev-util/cutils/cutils-1.6-r4.ebuild53
-rw-r--r--dev-util/cutils/files/cutils-1.6-case-insensitive.patch14
-rw-r--r--dev-util/cutils/files/cutils-infopage.patch16
-rw-r--r--dev-util/cutils/metadata.xml7
5 files changed, 91 insertions, 0 deletions
diff --git a/dev-util/cutils/Manifest b/dev-util/cutils/Manifest
new file mode 100644
index 00000000000..c284c06428c
--- /dev/null
+++ b/dev-util/cutils/Manifest
@@ -0,0 +1 @@
+DIST cutils-1.6.tar.gz 128722 SHA256 b26c22f2ca3905579273e132708094e95b4fe2a0576ce4bea8a7cbfc7a0084b8 SHA512 49a0f6ed210be01eec335903dee7ac6000bfa9d9c05a31b9a9fd6ae8534c8058d774f884d55b2b9fa029abc30beeca1866d8a74389b76158ebb216fb3dfad6eb WHIRLPOOL 37285efc69c8be9075fed1d11147d1dc2955f08e7a1449afca5355916566298fa71b9e7d48156860c52dfaa782b06d604c3481ed4c75b4205aae0897c4da9ac3
diff --git a/dev-util/cutils/cutils-1.6-r4.ebuild b/dev-util/cutils/cutils-1.6-r4.ebuild
new file mode 100644
index 00000000000..bcd27c82a79
--- /dev/null
+++ b/dev-util/cutils/cutils-1.6-r4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="C language utilities"
+HOMEPAGE="http://www.sigala.it/sandro/software.php#cutils"
+SRC_URI="http://www.sigala.it/sandro/files/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+RDEPEND=""
+DEPEND="sys-devel/flex"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-infopage.patch
+
+ epatch "${FILESDIR}"/${P}-case-insensitive.patch
+
+ mv "${S}"/src/cdecl/cdecl.1 \
+ "${S}"/src/cdecl/cutils-cdecl.1 || die
+ # Force rebuild of cutils.info
+ rm -f "${S}"/doc/cutils.info || die
+
+ sed -e "s/cdecl/cutils-cdecl/g" \
+ -i "${S}"/doc/cutils.texi || die
+ sed -e "/PROG/s/cdecl/cutils-cdecl/" \
+ -i "${S}"/src/cdecl/Makefile.in || die
+ sed -e "/Xr/s/cdecl/cutils-cdecl/" \
+ -i "${S}"/src/cundecl/cundecl.1 || die
+ sed -i "/Nm/s/cdecl/cutils-cdecl/" \
+ "${S}"/src/cdecl/cutils-cdecl.1 || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" -j1
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+ dodoc CREDITS HISTORY NEWS README
+}
+
+pkg_postinst () {
+ elog "cdecl was installed as cutils-cdecl because of a naming conflict"
+ elog "with dev-util/cdecl."
+}
diff --git a/dev-util/cutils/files/cutils-1.6-case-insensitive.patch b/dev-util/cutils/files/cutils-1.6-case-insensitive.patch
new file mode 100644
index 00000000000..67318d0f55d
--- /dev/null
+++ b/dev-util/cutils/files/cutils-1.6-case-insensitive.patch
@@ -0,0 +1,14 @@
+* On case insensitive filesystems, INSTALL is seen as the target install,
+ resulting in no installation at all.
+
+--- cutils-1.6/Makefile.in
++++ cutils-1.6/Makefile.in
+@@ -8,6 +8,8 @@
+ (cd $$f && $(MAKE) $@); \
+ done
+
++.PHONY : install
++
+ distclean:
+ @for f in $(subdirs); do \
+ (cd $$f && $(MAKE) $@); \
diff --git a/dev-util/cutils/files/cutils-infopage.patch b/dev-util/cutils/files/cutils-infopage.patch
new file mode 100644
index 00000000000..2b19aeee2d6
--- /dev/null
+++ b/dev-util/cutils/files/cutils-infopage.patch
@@ -0,0 +1,16 @@
+# Add category, and entry to the texinfo document.
+
+--- cutils-1.6/doc/cutils.texi.orig 2008-11-24 23:18:41.732038120 +0000
++++ cutils-1.6/doc/cutils.texi 2008-11-24 23:18:27.907038555 +0000
+@@ -7,6 +7,11 @@
+ @c unwise to comment it out when running a master in case there are
+ @c overfulls which are deemed okay.
+
++@dircategory Programming
++@direntry
++* cutils: (cutils). C language utilities.
++@end direntry
++
+ @iftex
+ @c @finalout
+ @end iftex
diff --git a/dev-util/cutils/metadata.xml b/dev-util/cutils/metadata.xml
new file mode 100644
index 00000000000..91f4e72fb54
--- /dev/null
+++ b/dev-util/cutils/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>