summaryrefslogtreecommitdiff
path: root/dev-util/fhist
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/fhist
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/fhist')
-rw-r--r--dev-util/fhist/Manifest2
-rw-r--r--dev-util/fhist/fhist-1.16.ebuild44
-rw-r--r--dev-util/fhist/fhist-1.19.ebuild30
-rw-r--r--dev-util/fhist/files/1.19-ldflags.patch43
-rw-r--r--dev-util/fhist/metadata.xml5
5 files changed, 124 insertions, 0 deletions
diff --git a/dev-util/fhist/Manifest b/dev-util/fhist/Manifest
new file mode 100644
index 00000000000..efecc0b1bae
--- /dev/null
+++ b/dev-util/fhist/Manifest
@@ -0,0 +1,2 @@
+DIST fhist-1.16.tar.gz 383180 SHA256 3f71c86939694755e456a9c82156f779063e74240d21da2251f33ae3c25ea336 SHA512 919fc4d424e1f878404ec2d305dbcd66a4697c88c38af54033bdb178704cf08997c816d75db93ddbfc5248f29b997c4b8aaa3fd98ee790c32582124fc332bc1d WHIRLPOOL 6469fc9a4a5ed9f82af0dca8f1f167b9c56385283328d0c24bcd88b7e38fbf9912eeb71a37a64687f9bf1c58e0996ec7ae71649ae6fa4b0622b83f65bfc8526a
+DIST fhist-1.19.tar.gz 409083 SHA256 e18d97f6ff5c44593f82775eb82540d870409ed80712eead8fd41684f194f62c SHA512 d93f0ce1b29e527af5de3f49d44ebc11567f53bb0b428322daa42b0a4a14ae75333ffcb9a65ba14b2a6240d57be7bdf7632e6b4eccd071d4e9b6e90c14c317a9 WHIRLPOOL 072a3231c3994310396f00dfab0b7214e23c5e59bfa511ba0987ff89b686e3d4a33bf6f10e77fad3f1e80857f337a47a77204d3dd14aa62f42932b48d088afeb
diff --git a/dev-util/fhist/fhist-1.16.ebuild b/dev-util/fhist/fhist-1.16.ebuild
new file mode 100644
index 00000000000..7a565ba2c3f
--- /dev/null
+++ b/dev-util/fhist/fhist-1.16.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="File history and comparison tools"
+HOMEPAGE="http://fhist.sourceforge.net/fhist.html"
+SRC_URI="http://fhist.sourceforge.net/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~ppc x86"
+IUSE="test"
+
+RDEPEND="sys-devel/gettext
+ sys-apps/groff"
+DEPEND="${RDEPEND}
+ test? ( app-arch/sharutils )
+ sys-devel/bison"
+
+MAKEOPTS+=" -j1"
+
+src_compile() {
+ econf
+ emake || die "emake failed"
+}
+
+src_test() {
+ emake sure || die "src_test failed"
+}
+
+src_install () {
+ emake \
+ RPM_BUILD_ROOT="${D}" \
+ NLSDIR="${D}/usr/share/locale" \
+ install || die "make install failed"
+
+ dodoc lib/en/*.txt || die
+ dodoc lib/en/*.ps || die
+
+ # remove duplicate docs etc.
+ rm -r "${D}"/usr/share/fhist
+
+ dodoc MANIFEST README || die
+}
diff --git a/dev-util/fhist/fhist-1.19.ebuild b/dev-util/fhist/fhist-1.19.ebuild
new file mode 100644
index 00000000000..7e50006d988
--- /dev/null
+++ b/dev-util/fhist/fhist-1.19.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="File history and comparison tools"
+HOMEPAGE="http://fhist.sourceforge.net/fhist.html"
+SRC_URI="http://fhist.sourceforge.net/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-libs/libexplain
+ sys-devel/gettext
+ sys-apps/groff"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ test? ( app-arch/sharutils )"
+
+MAKEOPTS+=" -j1"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-ldflags.patch
+}
diff --git a/dev-util/fhist/files/1.19-ldflags.patch b/dev-util/fhist/files/1.19-ldflags.patch
new file mode 100644
index 00000000000..c0fa0e825a9
--- /dev/null
+++ b/dev-util/fhist/files/1.19-ldflags.patch
@@ -0,0 +1,43 @@
+diff --git a/Makefile.in b/Makefile.in
+index 8aa8408..2c39b28 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -500,8 +500,9 @@ common/sub/expr.$(OBJEXT): common/sub/expr.c common/ac/stdarg.h \
+ $(CC) $(CPPFLAGS) $(CFLAGS) -I. -c common/sub/expr.c
+ mv expr.$(OBJEXT) common/sub/expr.$(OBJEXT)
+
+-common/sub/expr_gram.yacc.c common/sub/expr_gram.yacc.h: \
+- common/sub/expr_gram.y
++common/sub/expr_gram.yacc.c: common/sub/expr_gram.yacc.h
++
++common/sub/expr_gram.yacc.h: common/sub/expr_gram.y
+ $(YACC) -d common/sub/expr_gram.y
+ sed -e 's/[yY][yY]/sub_expr_gram_/g' y.tab.c > \
+ common/sub/expr_gram.yacc.c
+@@ -961,7 +962,7 @@ common/libcommon.a: $(lib_obj)
+ fcomp_obj = fcomp/main.$(OBJEXT)
+
+ bin/fcomp$(EXEEXT): $(fcomp_obj) common/libcommon.a .bin
+- $(CC) $(CPPFLAGS) $(CFLAGS) -o $@ $(fcomp_obj) \
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $(fcomp_obj) \
+ common/libcommon.a $(LIBS)
+
+ $(bindir)/fcomp$(EXEEXT): bin/fcomp$(EXEEXT) .bindir
+@@ -974,7 +975,7 @@ fhist_obj = fhist/breaks.$(OBJEXT) fhist/diff.$(OBJEXT) \
+ fhist/subroutine.$(OBJEXT) fhist/update.$(OBJEXT)
+
+ bin/fhist$(EXEEXT): $(fhist_obj) common/libcommon.a .bin
+- $(CC) $(CPPFLAGS) $(CFLAGS) -o $@ $(fhist_obj) \
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $(fhist_obj) \
+ common/libcommon.a $(LIBS)
+
+ $(bindir)/fhist$(EXEEXT): bin/fhist$(EXEEXT) .bindir
+@@ -983,7 +984,7 @@ $(bindir)/fhist$(EXEEXT): bin/fhist$(EXEEXT) .bindir
+ fmerge_obj = fmerge/main.$(OBJEXT) fmerge/work.$(OBJEXT)
+
+ bin/fmerge$(EXEEXT): $(fmerge_obj) common/libcommon.a .bin
+- $(CC) $(CPPFLAGS) $(CFLAGS) -o $@ $(fmerge_obj) \
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $(fmerge_obj) \
+ common/libcommon.a $(LIBS)
+
+ $(bindir)/fmerge$(EXEEXT): bin/fmerge$(EXEEXT) .bindir
diff --git a/dev-util/fhist/metadata.xml b/dev-util/fhist/metadata.xml
new file mode 100644
index 00000000000..40149c99556
--- /dev/null
+++ b/dev-util/fhist/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>shell-tools</herd>
+</pkgmetadata>