summaryrefslogtreecommitdiff
path: root/dev-util/filepp
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/filepp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/filepp')
-rw-r--r--dev-util/filepp/Manifest2
-rw-r--r--dev-util/filepp/filepp-1.6.0.ebuild24
-rw-r--r--dev-util/filepp/filepp-1.8.0.ebuild26
-rw-r--r--dev-util/filepp/metadata.xml7
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-util/filepp/Manifest b/dev-util/filepp/Manifest
new file mode 100644
index 00000000000..03b5342a517
--- /dev/null
+++ b/dev-util/filepp/Manifest
@@ -0,0 +1,2 @@
+DIST filepp-1.6.0.tar.gz 117650 SHA256 2a272c2004e1f0a8453b9e5b00c6c0fe53cbbf8e6805fa1916aee950bf02a68c SHA512 197b3a36468c35a983683186929edb9f4ece83f36b2b7dd48edd1944d75e4b66664a8e22b3185c2c11aba70538125ba244e83f31e1072759d60a352ec907a6cb WHIRLPOOL 30d8fdda94123e07cc89738f802d3042ac65a7030103f99c07d73113e3f9f8b1c6ed6d51ff0940a27c070a44aa47c2d75a713d7897706da9130ae0c67080d01c
+DIST filepp-1.8.0.tar.gz 142875 SHA256 12bd2297184ac3a9a38df9e8d0c76083eef2d5d561661b4fd93c426e76dab956 SHA512 9d5c37391afbe4cd5e3f07db4806aaa49844eeef228321c5909e3b393e204a7f6cbc795f6b9495ff81a1416a913fc7da80ad58b3ba467860dae8daf5ddd2395a WHIRLPOOL 200780cbe548b9d9e4a5a7162d0ae229b7bbb6c623a5b14e67bb73ee0079b47a2e5cf4d0c49fa3b07eac81be673145846b38d2b2422e82ada1fac585cd94dd57
diff --git a/dev-util/filepp/filepp-1.6.0.ebuild b/dev-util/filepp/filepp-1.6.0.ebuild
new file mode 100644
index 00000000000..f1c639110e7
--- /dev/null
+++ b/dev-util/filepp/filepp-1.6.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Generic file-preprocessor with a CPP-like syntax"
+HOMEPAGE="http://www.cabaret.demon.co.uk/filepp/"
+SRC_URI="http://www.cabaret.demon.co.uk/filepp/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~mips ppc s390 sparc x86"
+IUSE=""
+
+moduledir="/usr/share/${P}/modules"
+
+src_compile() {
+ econf --with-moduledir=${moduledir} || die "econf failed"
+}
+
+src_install() {
+ einstall moduledir="${D}/${moduledir}"
+ dodoc ChangeLog README
+ dohtml filepp.html
+}
diff --git a/dev-util/filepp/filepp-1.8.0.ebuild b/dev-util/filepp/filepp-1.8.0.ebuild
new file mode 100644
index 00000000000..b42605d77e2
--- /dev/null
+++ b/dev-util/filepp/filepp-1.8.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+DESCRIPTION="a generic file preprocessor with a CPP-like syntax"
+HOMEPAGE="http://www.cabaret.demon.co.uk/filepp"
+SRC_URI="http://www.cabaret.demon.co.uk/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+moduledir="${EPREFIX}/usr/share/${P}/modules"
+
+src_configure() {
+ econf --with-moduledir=${moduledir}
+}
+
+src_install() {
+ einstall moduledir="${D}"/${moduledir} || die "einstall failed."
+ dodoc ChangeLog README
+ dohtml *.html
+}
diff --git a/dev-util/filepp/metadata.xml b/dev-util/filepp/metadata.xml
new file mode 100644
index 00000000000..91f4e72fb54
--- /dev/null
+++ b/dev-util/filepp/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>