summaryrefslogtreecommitdiff
path: root/dev-util/jay/jay-1.1.1-r2.ebuild
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/jay/jay-1.1.1-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/jay/jay-1.1.1-r2.ebuild')
-rw-r--r--dev-util/jay/jay-1.1.1-r2.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/dev-util/jay/jay-1.1.1-r2.ebuild b/dev-util/jay/jay-1.1.1-r2.ebuild
new file mode 100644
index 00000000000..fce84e00b67
--- /dev/null
+++ b/dev-util/jay/jay-1.1.1-r2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit mono java-pkg-opt-2 toolchain-funcs
+
+DESCRIPTION="A LALR(1) parser generator: Berkeley yacc retargeted to C# and Java"
+HOMEPAGE="http://www.cs.rit.edu/~ats/projects/lp/doc/jay/package-summary.html"
+SRC_URI="http://www.cs.rit.edu/~ats/projects/lp/doc/jay/doc-files/src.zip -> ${P}.zip
+ http://dev.gentoo.org/~ssuominen/${P}-mono.snk.bz2"
+
+LICENSE="public-domain BSD"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="java mono"
+
+COMMON_DEPEND="!<=dev-lang/mono-2.4
+ mono? ( >dev-lang/mono-2.4 )"
+RDEPEND="${COMMOND_DEPEND}
+ java? ( >=virtual/jre-1.4 )"
+DEPEND="${COMMON_DEPEND}
+ java? ( >=virtual/jdk-1.4 )
+ app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+RESTRICT="test"
+
+java_prepare() {
+ sed -i -r \
+ -e 's:^v4\s*=.*:v4 = ${JAVA_HOME}/bin:' \
+ -e 's:JAVAC\s*=.*:\0 ${JAVACFLAGS}:' \
+ yydebug/makefile || die
+}
+
+src_prepare() {
+ sed -i -r \
+ -e "s:^CC\s*=.*:CC = `tc-getCC`:" \
+ -e 's/^jay:.* \$e /\0$(LDFLAGS) /' \
+ -e '/^CFLAGS\s*=/d' \
+ src/makefile || die
+
+ java-utils-2_src_prepare
+}
+
+src_compile() {
+ emake -C src jay
+ use java && emake -C yydebug yydebug.jar
+
+ if use mono; then
+ pushd cs >/dev/null
+ "${EPREFIX}"/usr/bin/gmcs /target:library /out:yydebug.dll /keyfile:"${WORKDIR}"/${P}-mono.snk yyDebug.cs || die
+ popd >/dev/null
+ fi
+}
+
+src_install() {
+ dobin src/jay
+
+ doman jay.1
+ dodoc README
+
+ if use java; then
+ java-pkg_dojar yydebug/yydebug.jar
+ insinto /usr/share/jay
+ doins java/skeleton.{java,tables}
+ fi
+
+ if use mono; then
+ egacinstall cs/yydebug.dll
+ insinto /usr/share/jay
+ doins cs/skeleton.cs
+ fi
+}