summaryrefslogtreecommitdiff
path: root/dev-util/kdevelop-pg-qt
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/kdevelop-pg-qt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/kdevelop-pg-qt')
-rw-r--r--dev-util/kdevelop-pg-qt/Manifest2
-rw-r--r--dev-util/kdevelop-pg-qt/files/kdevelop-pg-qt-1.0.0-bison3.patch45
-rw-r--r--dev-util/kdevelop-pg-qt/kdevelop-pg-qt-1.0.0-r2.ebuild28
-rw-r--r--dev-util/kdevelop-pg-qt/kdevelop-pg-qt-1.1.0.ebuild27
-rw-r--r--dev-util/kdevelop-pg-qt/metadata.xml5
5 files changed, 107 insertions, 0 deletions
diff --git a/dev-util/kdevelop-pg-qt/Manifest b/dev-util/kdevelop-pg-qt/Manifest
new file mode 100644
index 00000000000..f7761fa3aa0
--- /dev/null
+++ b/dev-util/kdevelop-pg-qt/Manifest
@@ -0,0 +1,2 @@
+DIST kdevelop-pg-qt-1.0.0.tar.bz2 830040 SHA256 49b395f5b45bc0aa094d6a283627bc53581a5eaae7892fd850df2f97d68bcdcc SHA512 1e3a41cd5570a2bdba98ebdf55b89cc2992ddd4859bd672ea1b8215d47db2203ec685717787f90cf382168495b4b53cc42a9089c4a92e17286eca6cf17c1bb27 WHIRLPOOL 04ee7d992535713d99b77da888207ce5924f6409fafc363d6b00bd695fe39e3896dc8eb9433c71b60c4a45137593896b6eebbec2dde1386866c5c87223bda056
+DIST kdevelop-pg-qt-1.1.0.tar.gz 1091846 SHA256 30f78dcf08e9da88bb0643629e17dd8e360afea40370b8772afff197cb2f1685 SHA512 e43f7be38ba50ced6c15988266ee6163cfdcf1fe1b26b02a1c4586394378234eb7a76d7fbc84fc9e395121e916515e4950de672959c9e1ebc72332a0ecdaf364 WHIRLPOOL 3830ce0e3b3ad27a9613efe07d7d4a19d88100cef393ca74af4bce54261e7f52a71dee0351f415e4ca26f7e95a0281ecc26713c02313732887272adcd0e4aa18
diff --git a/dev-util/kdevelop-pg-qt/files/kdevelop-pg-qt-1.0.0-bison3.patch b/dev-util/kdevelop-pg-qt/files/kdevelop-pg-qt-1.0.0-bison3.patch
new file mode 100644
index 00000000000..3651ec47160
--- /dev/null
+++ b/dev-util/kdevelop-pg-qt/files/kdevelop-pg-qt-1.0.0-bison3.patch
@@ -0,0 +1,45 @@
+commit ac587957cd0cabbc668604507e2cfebb6810ed09
+Author: Milian Wolff <mail@milianw.de>
+Date: Thu Nov 29 15:56:40 2012 +0100
+
+ fix some warnings
+
+diff --git a/kdev-pg/kdev-pg-code-gen.cpp b/kdev-pg/kdev-pg-code-gen.cpp
+index e06c6be..badb461 100644
+--- a/kdev-pg/kdev-pg-code-gen.cpp
++++ b/kdev-pg/kdev-pg-code-gen.cpp
+@@ -51,7 +51,7 @@ namespace KDevPG
+
+ void generateCondition(const World::NodeSet& s, QTextStream& out)
+ {
+- if(s.size() == 0 || s.size() == 1 && nodeCast<Model::ZeroItem*>(*s.begin()) != 0)
++ if(s.size() == 0 || (s.size() == 1 && nodeCast<Model::ZeroItem*>(*s.begin()) != 0))
+ {
+ out << "true /*epsilon*/";
+ return;
+diff --git a/kdev-pg/kdev-pg-lexer.ll b/kdev-pg/kdev-pg-lexer.ll
+index a0864af..9261d71 100644
+--- a/kdev-pg/kdev-pg-lexer.ll
++++ b/kdev-pg/kdev-pg-lexer.ll
+@@ -425,7 +425,7 @@ void appendLineBuffer()
+ strcpy(yyTextLine+currentOffset, yytext + (yymoreFlag ? lastTextLeng : 0)); /* append current */
+ /* strcpy is faster than strcat */
+
+- Q_ASSERT(strlen(yyTextLine) < yyTextLineLeng);
++ Q_ASSERT(strlen(yyTextLine) < size_t(yyTextLineLeng));
+
+ lastTextLeng = strlen(yytext);
+ yymoreFlag = false;
+diff --git a/kdev-pg/kdev-pg-parser.yy b/kdev-pg/kdev-pg-parser.yy
+index d5a25f5..8f8d604 100644
+--- a/kdev-pg/kdev-pg-parser.yy
++++ b/kdev-pg/kdev-pg-parser.yy
+@@ -309,7 +309,7 @@ opt_lexer_action
+ | T_CONTINUE {
+ r = "\nlxCONTINUE;\n";
+ }
+- | /* empty */ { r = "\nlxSKIP\n" }
++ | /* empty */ { r = "\nlxSKIP\n"; }
+ ;
+
+ regexp
diff --git a/dev-util/kdevelop-pg-qt/kdevelop-pg-qt-1.0.0-r2.ebuild b/dev-util/kdevelop-pg-qt/kdevelop-pg-qt-1.0.0-r2.ebuild
new file mode 100644
index 00000000000..a0a2a19da3e
--- /dev/null
+++ b/dev-util/kdevelop-pg-qt/kdevelop-pg-qt-1.0.0-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit kde4-base
+
+if [[ $PV == *9999* ]]; then
+ KEYWORDS=""
+else
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.bz2"
+ KEYWORDS="amd64 x86"
+fi
+
+DESCRIPTION="A LL(1) parser generator used mainly by KDevelop language plugins"
+HOMEPAGE="http://www.kdevelop.org"
+LICENSE="LGPL-2"
+SLOT="4"
+IUSE="debug"
+
+RDEPEND=""
+DEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+PATCHES=( "${FILESDIR}/${P}-bison3.patch" )
diff --git a/dev-util/kdevelop-pg-qt/kdevelop-pg-qt-1.1.0.ebuild b/dev-util/kdevelop-pg-qt/kdevelop-pg-qt-1.1.0.ebuild
new file mode 100644
index 00000000000..ad3e8cb1f2d
--- /dev/null
+++ b/dev-util/kdevelop-pg-qt/kdevelop-pg-qt-1.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDEBASE="kdevelop"
+inherit kde4-base
+
+if [[ $PV == *9999* ]]; then
+ KEYWORDS=""
+else
+ SRC_URI="http://quickgit.kde.org/?p=${PN}.git&a=snapshot&h=${PV%%.0} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A LL(1) parser generator used mainly by KDevelop language plugins"
+LICENSE="LGPL-2"
+IUSE="debug"
+
+DEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+RDEPEND="dev-util/kdevelop:4"
+
+S="${WORKDIR}/${PN}"
diff --git a/dev-util/kdevelop-pg-qt/metadata.xml b/dev-util/kdevelop-pg-qt/metadata.xml
new file mode 100644
index 00000000000..a23f444b67d
--- /dev/null
+++ b/dev-util/kdevelop-pg-qt/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+</pkgmetadata>