summaryrefslogtreecommitdiff
path: root/dev-util/kdevplatform/kdevplatform-1.7.1.ebuild
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/kdevplatform/kdevplatform-1.7.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/kdevplatform/kdevplatform-1.7.1.ebuild')
-rw-r--r--dev-util/kdevplatform/kdevplatform-1.7.1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-util/kdevplatform/kdevplatform-1.7.1.ebuild b/dev-util/kdevplatform/kdevplatform-1.7.1.ebuild
new file mode 100644
index 00000000000..4e4b48df76e
--- /dev/null
+++ b/dev-util/kdevplatform/kdevplatform-1.7.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DECLARATIVE_REQUIRED="always"
+KMNAME="kdevelop"
+KDE_LINGUAS="bs ca ca@valencia da de el en_GB es et fi fr gl it kk nb nl pl pt
+pt_BR ru sk sl sv th tr uk zh_CN zh_TW"
+VIRTUALDBUS_TEST="true"
+VIRTUALX_REQUIRED="test"
+EGIT_REPONAME="${PN}"
+EGIT_BRANCH="1.7"
+inherit kde4-base
+
+DESCRIPTION="KDE development support libraries and apps"
+LICENSE="GPL-2 LGPL-2"
+IUSE="+classbrowser cvs debug +konsole reviewboard subversion"
+
+if [[ $PV == *9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="amd64 ~ppc ~x86"
+fi
+
+RESTRICT="test"
+
+COMMON_DEPEND="
+ dev-libs/grantlee:0
+ reviewboard? ( dev-libs/qjson )
+ subversion? (
+ dev-libs/apr
+ dev-libs/apr-util
+ dev-vcs/subversion
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ classbrowser? ( dev-libs/boost )
+"
+RDEPEND="${COMMON_DEPEND}
+ konsole? ( $(add_kdeapps_dep konsole) )
+ cvs? ( dev-vcs/cvs )
+ !<dev-util/kdevelop-${KDEVELOP_VERSION}:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_build classbrowser)
+ $(cmake-utils_use_build cvs)
+ $(cmake-utils_use_build konsole)
+ $(cmake-utils_use_find_package reviewboard QJSON)
+ $(cmake-utils_use_build subversion)
+ )
+
+ kde4-base_src_configure
+}