summaryrefslogtreecommitdiff
path: root/dev-util/nemiver/nemiver-0.9.6.ebuild
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-10-04 12:47:39 +0200
committerPacho Ramos <pacho@gentoo.org>2015-10-04 12:49:20 +0200
commit183209d2e849ed0d19210fe835d3af7aa6585841 (patch)
treeea8de35e78bdd3998f22d9504cdb5f295f9052b6 /dev-util/nemiver/nemiver-0.9.6.ebuild
parente486339cfcda1ae1e9426262a59efb6dcdad1f18 (diff)
downloadgentoo-183209d2e849ed0d19210fe835d3af7aa6585841.tar.gz
gentoo-183209d2e849ed0d19210fe835d3af7aa6585841.tar.xz
dev-util/nemiver: Version bump
Package-Manager: portage-2.2.22
Diffstat (limited to 'dev-util/nemiver/nemiver-0.9.6.ebuild')
-rw-r--r--dev-util/nemiver/nemiver-0.9.6.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-util/nemiver/nemiver-0.9.6.ebuild b/dev-util/nemiver/nemiver-0.9.6.ebuild
new file mode 100644
index 00000000000..1628a58d699
--- /dev/null
+++ b/dev-util/nemiver/nemiver-0.9.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2
+
+DESCRIPTION="A gtkmm front end to the GNU Debugger (gdb)"
+HOMEPAGE="https://wiki.gnome.org/Apps/Nemiver"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="memoryview"
+
+RDEPEND="
+ >=dev-libs/glib-2.16:2
+ >=dev-cpp/glibmm-2.30:2
+ >=dev-cpp/gtkmm-3:3.0
+ >=dev-cpp/gtksourceviewmm-3:3.0
+ >=gnome-base/gsettings-desktop-schemas-0.0.1
+ >=gnome-base/libgtop-2.19
+ x11-libs/vte:2.91
+ >=dev-db/sqlite-3:3
+ sys-devel/gdb
+ dev-libs/boost
+ memoryview? ( >=app-editors/ghex-2.90:2 )
+"
+# FIXME: dynamiclayout needs unreleased stable gdlmm:3
+# dynamiclayout? ( >=dev-cpp/gdlmm-3.0:3 )
+DEPEND="${RDEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/intltool-0.40
+ dev-util/itstool
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-dynamiclayout \
+ --disable-static \
+ --disable-symsvis \
+ --enable-gsettings \
+ $(use_enable memoryview)
+}