summaryrefslogtreecommitdiff
path: root/dev-util/nemiver
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-07-30 21:23:09 +0200
committerPacho Ramos <pacho@gentoo.org>2016-07-30 22:36:40 +0200
commit79fa8d8e323486d947edf672fbe364153a362137 (patch)
tree3ec4229160ba7c7184e026e29bd1c96061b4101e /dev-util/nemiver
parentb7108d3e0859011d7291da15bffc287809dca6ab (diff)
downloadgentoo-79fa8d8e323486d947edf672fbe364153a362137.tar.gz
gentoo-79fa8d8e323486d947edf672fbe364153a362137.tar.xz
dev-util/nemiver: Upstream patches to fix build failures (#587958 by Kobboi)
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-util/nemiver')
-rw-r--r--dev-util/nemiver/files/nemiver-0.9.6-bool-build.patch36
-rw-r--r--dev-util/nemiver/files/nemiver-0.9.6-fix-build.patch39
-rw-r--r--dev-util/nemiver/nemiver-0.9.6.ebuild19
3 files changed, 89 insertions, 5 deletions
diff --git a/dev-util/nemiver/files/nemiver-0.9.6-bool-build.patch b/dev-util/nemiver/files/nemiver-0.9.6-bool-build.patch
new file mode 100644
index 00000000000..dac65a8a4cc
--- /dev/null
+++ b/dev-util/nemiver/files/nemiver-0.9.6-bool-build.patch
@@ -0,0 +1,36 @@
+From 262cf9657f9c2727a816972b348692adcc666008 Mon Sep 17 00:00:00 2001
+From: Marcin Kolny <marcin.kolny@gmail.com>
+Date: Fri, 1 Jul 2016 19:45:05 +0200
+Subject: Use RefPtr::bool() operator in the conditions
+
+Since bool() operator in RefPtr class is explicit,
+comparision with integer doesn't compile.
+---
+ src/persp/dbgperspective/nmv-dbg-perspective.cc | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/persp/dbgperspective/nmv-dbg-perspective.cc b/src/persp/dbgperspective/nmv-dbg-perspective.cc
+index be652db..ac207e4 100644
+--- a/src/persp/dbgperspective/nmv-dbg-perspective.cc
++++ b/src/persp/dbgperspective/nmv-dbg-perspective.cc
+@@ -5672,7 +5672,7 @@ DBGPerspective::switch_to_asm (const common::DisassembleInfo &a_info,
+ a_source_editor->clear_decorations ();
+
+ Glib::RefPtr<Gsv::Buffer> asm_buf;
+- if ((asm_buf = a_source_editor->get_assembly_source_buffer ()) == 0) {
++ if (!(asm_buf = a_source_editor->get_assembly_source_buffer ())) {
+ SourceEditor::setup_buffer_mime_and_lang (asm_buf, "text/x-asm");
+ a_source_editor->register_assembly_source_buffer (asm_buf);
+ asm_buf = a_source_editor->get_assembly_source_buffer ();
+@@ -5720,7 +5720,7 @@ DBGPerspective::switch_to_source_code ()
+
+ Glib::RefPtr<Gsv::Buffer> source_buf;
+ UString source_path;
+- if ((source_buf = source_editor->get_non_assembly_source_buffer ()) == 0) {
++ if (!(source_buf = source_editor->get_non_assembly_source_buffer ())) {
+ // Woops!
+ // We don't have any source code buffer. Let's try hard to get
+ // the source code corresponding to the current frame. For that,
+--
+cgit v0.12
+
diff --git a/dev-util/nemiver/files/nemiver-0.9.6-fix-build.patch b/dev-util/nemiver/files/nemiver-0.9.6-fix-build.patch
new file mode 100644
index 00000000000..59a893ad003
--- /dev/null
+++ b/dev-util/nemiver/files/nemiver-0.9.6-fix-build.patch
@@ -0,0 +1,39 @@
+From e0e42221ceb77d88be64fac1c09792dc5c9e2f43 Mon Sep 17 00:00:00 2001
+From: Ben Iofel <iofelben@gmail.com>
+Date: Thu, 17 Mar 2016 18:28:02 -0400
+Subject: Fix compiliation warnings & errors
+
+---
+ src/dbgengine/nmv-dbg-common.h | 2 +-
+ src/dbgengine/nmv-i-var-list-walker.h | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/dbgengine/nmv-dbg-common.h b/src/dbgengine/nmv-dbg-common.h
+index ad3cc00..0edac7c 100644
+--- a/src/dbgengine/nmv-dbg-common.h
++++ b/src/dbgengine/nmv-dbg-common.h
+@@ -171,7 +171,7 @@ public:
+
+ bool has_slot () const
+ {
+- return m_slot;
++ return static_cast<bool> (m_slot);
+ }
+
+ template<class T>
+diff --git a/src/dbgengine/nmv-i-var-list-walker.h b/src/dbgengine/nmv-i-var-list-walker.h
+index b719c0d..f2f3229 100644
+--- a/src/dbgengine/nmv-i-var-list-walker.h
++++ b/src/dbgengine/nmv-i-var-list-walker.h
+@@ -22,7 +22,7 @@
+ *
+ *See COPYRIGHT file copyright information.
+ */
+-#ifndef __NMV_VAR_LIST_WALKER_H__
++#ifndef __NMV_I_VAR_LIST_WALKER_H__
+ #define __NMV_I_VAR_LIST_WALKER_H__
+
+ #include "nmv-i-var-walker.h"
+--
+cgit v0.12
+
diff --git a/dev-util/nemiver/nemiver-0.9.6.ebuild b/dev-util/nemiver/nemiver-0.9.6.ebuild
index 684b996779a..e0b09424ca0 100644
--- a/dev-util/nemiver/nemiver-0.9.6.ebuild
+++ b/dev-util/nemiver/nemiver-0.9.6.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
-GCONF_DEBUG="yes"
+EAPI=6
GNOME2_LA_PUNT="yes"
inherit eutils gnome2
@@ -14,10 +13,10 @@ HOMEPAGE="https://wiki.gnome.org/Apps/Nemiver"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="memoryview"
+IUSE="debug memoryview"
RDEPEND="
- >=dev-libs/glib-2.16:2
+ >=dev-libs/glib-2.16:2[dbus]
>=dev-cpp/glibmm-2.30:2
>=dev-cpp/gtkmm-3:3.0
>=dev-cpp/gtksourceviewmm-3:3.0
@@ -39,11 +38,21 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
"
+PATCHES=(
+ # Use RefPtr::bool() operator in the conditions, fixed in next
+ # version
+ "${FILESDIR}/${P}-bool-build.patch"
+
+ # Fix compiliation warnings & errors, fixed in next version
+ "${FILESDIR}/${P}-fix-build.patch"
+)
+
src_configure() {
gnome2_src_configure \
--disable-dynamiclayout \
--disable-static \
--disable-symsvis \
--enable-gsettings \
+ $(use_enable debug) \
$(use_enable memoryview)
}