summaryrefslogtreecommitdiff
path: root/dev-util/ninja
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/ninja
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/ninja')
-rw-r--r--dev-util/ninja/Manifest3
-rw-r--r--dev-util/ninja/metadata.xml8
-rw-r--r--dev-util/ninja/ninja-1.5.1.ebuild129
-rw-r--r--dev-util/ninja/ninja-1.5.3.ebuild123
-rw-r--r--dev-util/ninja/ninja-1.6.0.ebuild123
-rw-r--r--dev-util/ninja/ninja-9999.ebuild128
6 files changed, 514 insertions, 0 deletions
diff --git a/dev-util/ninja/Manifest b/dev-util/ninja/Manifest
new file mode 100644
index 00000000000..25b5d30313d
--- /dev/null
+++ b/dev-util/ninja/Manifest
@@ -0,0 +1,3 @@
+DIST ninja-1.5.1.tar.gz 163437 SHA256 fba77b9ed4b4dd0e86c4513776938dc64bd4508dc2055b04c0c6df68bcfa397d SHA512 ab82389ee88bd68ec57e720dabb47494371990dca581cf9bb35650177164f04bf41c81ab3e5019a370eeacc7f5f49ae81d41d8b21e1b07cc8abedce37e00da61 WHIRLPOOL 3fdd76505aa39a3960c8d47fc04e7fb12f613561ecf8f29d88329c06b78a0ef47fda02226d6ebb12718676c2ea9dc6bf7352564150de8b92f1b0c189bcf21e3a
+DIST ninja-1.5.3.tar.gz 168829 SHA256 7c953b5a7c26cfcd082882e3f3e2cd08fee8848ad228bb47223b18ea18777ec0 SHA512 6d8cba5838d796bf50a17ca760498309477342422d1ad971e8fd030d4dd06aa9095ce27c2a02f89504cdf3aa5a8ba5af395a2c805b5c45e266a8250985212eea WHIRLPOOL 6b6116e4bf8a2c622559cee7f2f9c48f4f896e878eacb880d9bad483eaa2f18fe9b6a11210ca396679177850b0df5377de52110c47ac22e6fd8641cbd7ccabe3
+DIST ninja-1.6.0.tar.gz 174501 SHA256 b43e88fb068fe4d92a3dfd9eb4d19755dae5c33415db2e9b7b61b4659009cde7 SHA512 551a9e14b95c2d2ddad6bee0f939a45614cce86719748dc580192dd122f3671e3d95fd6a6fb3facb2d314ba100d61a004af4df77f59df119b1b95c6fe8c38875 WHIRLPOOL 74d10df3d112c6cbd524f802978f1a56d2643767d947cff33a276a29f89485576f7d6b40597f9eac1db1446ae22c7f2c73c9d1f7795132e0254fa970df37063b
diff --git a/dev-util/ninja/metadata.xml b/dev-util/ninja/metadata.xml
new file mode 100644
index 00000000000..d0d2e6d9f0f
--- /dev/null
+++ b/dev-util/ninja/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>chromium</herd>
+ <upstream>
+ <remote-id type="github">martine/ninja</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/ninja/ninja-1.5.1.ebuild b/dev-util/ninja/ninja-1.5.1.ebuild
new file mode 100644
index 00000000000..008fa7a01fa
--- /dev/null
+++ b/dev-util/ninja/ninja-1.5.1.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit bash-completion-r1 elisp-common python-any-r1 toolchain-funcs
+
+if [ "${PV}" = "999999" ]; then
+ EGIT_REPO_URI="git://github.com/martine/ninja.git http://github.com/martine/ninja.git"
+ inherit git-2
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/martine/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="alpha amd64 arm ~arm64 ~m68k ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+fi
+
+DESCRIPTION="A small build system similar to make"
+HOMEPAGE="http://github.com/martine/ninja"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+IUSE="doc emacs test vim-syntax zsh-completion"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-util/re2c
+ doc? (
+ app-text/asciidoc
+ app-doc/doxygen
+ dev-libs/libxslt
+ )
+ test? ( dev-cpp/gtest )
+"
+RDEPEND="
+ emacs? ( virtual/emacs )
+ vim-syntax? (
+ || (
+ app-editors/vim
+ app-editors/gvim
+ )
+ )
+ zsh-completion? ( app-shells/zsh )
+ !<net-irc/ninja-1.5.9_pre14-r1" #436804
+
+run_for_build() {
+ if tc-is-cross-compiler; then
+ local -x AR=$(tc-getBUILD_AR)
+ local -x CXX=$(tc-getBUILD_CXX)
+ local -x CFLAGS=${BUILD_CXXFLAGS}
+ local -x LDFLAGS=${BUILD_LDFLAGS}
+ fi
+ "$@"
+}
+
+src_compile() {
+ tc-export AR CXX
+
+ # configure.py uses CFLAGS instead of CXXFLAGS
+ export CFLAGS=${CXXFLAGS}
+
+ run_for_build "${PYTHON}" bootstrap.py --verbose || die
+
+ if tc-is-cross-compiler; then
+ mv ninja ninja-build || die
+ "${PYTHON}" configure.py || die
+ ./ninja-build -v ninja || die
+ else
+ ln ninja ninja-build || die
+ fi
+
+ if use doc; then
+ ./ninja-build -v doxygen manual || die
+ fi
+
+ if use emacs; then
+ elisp-compile misc/ninja-mode.el || die
+ fi
+}
+
+src_test() {
+ if ! tc-is-cross-compiler; then
+ # Bug 485772
+ ulimit -n 2048
+ ./ninja-build -v ninja_test || die
+ ./ninja_test || die
+ fi
+}
+
+src_install() {
+ dodoc README HACKING.md
+ if use doc; then
+ dohtml -r doc/doxygen/html/*
+ dohtml doc/manual.html
+ fi
+ dobin ninja
+
+ newbashcomp misc/bash-completion "${PN}"
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax/
+ doins misc/"${PN}".vim
+
+ echo 'au BufNewFile,BufRead *.ninja set ft=ninja' > "${T}/${PN}.vim"
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${T}/${PN}.vim"
+ fi
+
+ if use zsh-completion; then
+ insinto /usr/share/zsh/site-functions
+ newins misc/zsh-completion _ninja
+ fi
+
+ if use emacs; then
+ cd misc || die
+ elisp-install ${PN} ninja-mode.el* || die
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/ninja/ninja-1.5.3.ebuild b/dev-util/ninja/ninja-1.5.3.ebuild
new file mode 100644
index 00000000000..dc1a2dd0203
--- /dev/null
+++ b/dev-util/ninja/ninja-1.5.3.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit bash-completion-r1 elisp-common python-any-r1 toolchain-funcs
+
+SRC_URI="https://github.com/martine/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="alpha amd64 arm arm64 ia64 m68k ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+DESCRIPTION="A small build system similar to make"
+HOMEPAGE="http://github.com/martine/ninja"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+IUSE="doc emacs test vim-syntax zsh-completion"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-util/re2c
+ doc? (
+ app-text/asciidoc
+ app-doc/doxygen
+ dev-libs/libxslt
+ )
+ test? ( dev-cpp/gtest )
+"
+RDEPEND="
+ emacs? ( virtual/emacs )
+ vim-syntax? (
+ || (
+ app-editors/vim
+ app-editors/gvim
+ )
+ )
+ zsh-completion? ( app-shells/zsh )
+ !<net-irc/ninja-1.5.9_pre14-r1" #436804
+
+run_for_build() {
+ if tc-is-cross-compiler; then
+ local -x AR=$(tc-getBUILD_AR)
+ local -x CXX=$(tc-getBUILD_CXX)
+ local -x CFLAGS=${BUILD_CXXFLAGS}
+ local -x LDFLAGS=${BUILD_LDFLAGS}
+ fi
+ "$@"
+}
+
+src_compile() {
+ tc-export AR CXX
+
+ # configure.py uses CFLAGS instead of CXXFLAGS
+ export CFLAGS=${CXXFLAGS}
+
+ run_for_build "${PYTHON}" bootstrap.py --verbose || die
+
+ if tc-is-cross-compiler; then
+ mv ninja ninja-build || die
+ "${PYTHON}" configure.py || die
+ ./ninja-build -v ninja || die
+ else
+ ln ninja ninja-build || die
+ fi
+
+ if use doc; then
+ ./ninja-build -v doxygen manual || die
+ fi
+
+ if use emacs; then
+ elisp-compile misc/ninja-mode.el || die
+ fi
+}
+
+src_test() {
+ if ! tc-is-cross-compiler; then
+ # Bug 485772
+ ulimit -n 2048
+ ./ninja-build -v ninja_test || die
+ ./ninja_test || die
+ fi
+}
+
+src_install() {
+ dodoc README HACKING.md
+ if use doc; then
+ dohtml -r doc/doxygen/html/*
+ dohtml doc/manual.html
+ fi
+ dobin ninja
+
+ newbashcomp misc/bash-completion "${PN}"
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax/
+ doins misc/"${PN}".vim
+
+ echo 'au BufNewFile,BufRead *.ninja set ft=ninja' > "${T}/${PN}.vim"
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${T}/${PN}.vim"
+ fi
+
+ if use zsh-completion; then
+ insinto /usr/share/zsh/site-functions
+ newins misc/zsh-completion _ninja
+ fi
+
+ if use emacs; then
+ cd misc || die
+ elisp-install ${PN} ninja-mode.el* || die
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/ninja/ninja-1.6.0.ebuild b/dev-util/ninja/ninja-1.6.0.ebuild
new file mode 100644
index 00000000000..1df91aa7c83
--- /dev/null
+++ b/dev-util/ninja/ninja-1.6.0.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit bash-completion-r1 elisp-common python-any-r1 toolchain-funcs
+
+SRC_URI="https://github.com/martine/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+DESCRIPTION="A small build system similar to make"
+HOMEPAGE="http://github.com/martine/ninja"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+IUSE="doc emacs test vim-syntax zsh-completion"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-util/re2c
+ doc? (
+ app-text/asciidoc
+ app-doc/doxygen
+ dev-libs/libxslt
+ )
+ test? ( dev-cpp/gtest )
+"
+RDEPEND="
+ emacs? ( virtual/emacs )
+ vim-syntax? (
+ || (
+ app-editors/vim
+ app-editors/gvim
+ )
+ )
+ zsh-completion? ( app-shells/zsh )
+ !<net-irc/ninja-1.5.9_pre14-r1" #436804
+
+run_for_build() {
+ if tc-is-cross-compiler; then
+ local -x AR=$(tc-getBUILD_AR)
+ local -x CXX=$(tc-getBUILD_CXX)
+ local -x CFLAGS=${BUILD_CXXFLAGS}
+ local -x LDFLAGS=${BUILD_LDFLAGS}
+ fi
+ "$@"
+}
+
+src_compile() {
+ tc-export AR CXX
+
+ # configure.py uses CFLAGS instead of CXXFLAGS
+ export CFLAGS=${CXXFLAGS}
+
+ run_for_build "${PYTHON}" bootstrap.py --verbose || die
+
+ if tc-is-cross-compiler; then
+ mv ninja ninja-build || die
+ "${PYTHON}" configure.py || die
+ ./ninja-build -v ninja || die
+ else
+ ln ninja ninja-build || die
+ fi
+
+ if use doc; then
+ ./ninja-build -v doxygen manual || die
+ fi
+
+ if use emacs; then
+ elisp-compile misc/ninja-mode.el || die
+ fi
+}
+
+src_test() {
+ if ! tc-is-cross-compiler; then
+ # Bug 485772
+ ulimit -n 2048
+ ./ninja-build -v ninja_test || die
+ ./ninja_test || die
+ fi
+}
+
+src_install() {
+ dodoc README HACKING.md
+ if use doc; then
+ dohtml -r doc/doxygen/html/*
+ dohtml doc/manual.html
+ fi
+ dobin ninja
+
+ newbashcomp misc/bash-completion "${PN}"
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax/
+ doins misc/"${PN}".vim
+
+ echo 'au BufNewFile,BufRead *.ninja set ft=ninja' > "${T}/${PN}.vim"
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${T}/${PN}.vim"
+ fi
+
+ if use zsh-completion; then
+ insinto /usr/share/zsh/site-functions
+ newins misc/zsh-completion _ninja
+ fi
+
+ if use emacs; then
+ cd misc || die
+ elisp-install ${PN} ninja-mode.el* || die
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/ninja/ninja-9999.ebuild b/dev-util/ninja/ninja-9999.ebuild
new file mode 100644
index 00000000000..fa0d563643d
--- /dev/null
+++ b/dev-util/ninja/ninja-9999.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit bash-completion-r1 elisp-common python-any-r1 toolchain-funcs
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/martine/ninja.git"
+else
+ SRC_URI="https://github.com/martine/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+fi
+
+DESCRIPTION="A small build system similar to make"
+HOMEPAGE="http://github.com/martine/ninja"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+IUSE="doc emacs test vim-syntax zsh-completion"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-util/re2c
+ doc? (
+ app-text/asciidoc
+ app-doc/doxygen
+ dev-libs/libxslt
+ )
+ test? ( dev-cpp/gtest )
+"
+RDEPEND="
+ emacs? ( virtual/emacs )
+ vim-syntax? (
+ || (
+ app-editors/vim
+ app-editors/gvim
+ )
+ )
+ zsh-completion? ( app-shells/zsh )
+ !<net-irc/ninja-1.5.9_pre14-r1" #436804
+
+run_for_build() {
+ if tc-is-cross-compiler; then
+ local -x AR=$(tc-getBUILD_AR)
+ local -x CXX=$(tc-getBUILD_CXX)
+ local -x CFLAGS=${BUILD_CXXFLAGS}
+ local -x LDFLAGS=${BUILD_LDFLAGS}
+ fi
+ "$@"
+}
+
+src_compile() {
+ tc-export AR CXX
+
+ # configure.py uses CFLAGS instead of CXXFLAGS
+ export CFLAGS=${CXXFLAGS}
+
+ run_for_build "${PYTHON}" configure.py --bootstrap --verbose || die
+
+ if tc-is-cross-compiler; then
+ mv ninja ninja-build || die
+ "${PYTHON}" configure.py || die
+ ./ninja-build -v ninja || die
+ else
+ ln ninja ninja-build || die
+ fi
+
+ if use doc; then
+ ./ninja-build -v doxygen manual || die
+ fi
+
+ if use emacs; then
+ elisp-compile misc/ninja-mode.el || die
+ fi
+}
+
+src_test() {
+ if ! tc-is-cross-compiler; then
+ # Bug 485772
+ ulimit -n 2048
+ ./ninja-build -v ninja_test || die
+ ./ninja_test || die
+ fi
+}
+
+src_install() {
+ dodoc README HACKING.md
+ if use doc; then
+ dohtml -r doc/doxygen/html/*
+ dohtml doc/manual.html
+ fi
+ dobin ninja
+
+ newbashcomp misc/bash-completion "${PN}"
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax/
+ doins misc/"${PN}".vim
+
+ echo 'au BufNewFile,BufRead *.ninja set ft=ninja' > "${T}/${PN}.vim"
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${T}/${PN}.vim"
+ fi
+
+ if use zsh-completion; then
+ insinto /usr/share/zsh/site-functions
+ newins misc/zsh-completion _ninja
+ fi
+
+ if use emacs; then
+ cd misc || die
+ elisp-install ${PN} ninja-mode.el* || die
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}