summaryrefslogtreecommitdiff
path: root/dev-util/par
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/par
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/par')
-rw-r--r--dev-util/par/Manifest1
-rw-r--r--dev-util/par/metadata.xml7
-rw-r--r--dev-util/par/par-00.05.01.ebuild37
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-util/par/Manifest b/dev-util/par/Manifest
new file mode 100644
index 00000000000..4070c99db14
--- /dev/null
+++ b/dev-util/par/Manifest
@@ -0,0 +1 @@
+DIST prc.tgz 62143 SHA256 00fe6faf5e34e65ab6ee7b44e1948523e7bf4ef304652fb04b53b314ed2c3f49 SHA512 f971af42a1a6a60d7b05c375db9a0ecd463a7801543a9ab96413170a807e68e4f9524180899c73fb93224bdcf510eeaaadcf1028d3f0a625207086215c572cef WHIRLPOOL 3cc15580aa67d33ead4ab4d230bac3a7f629dee34601b00b35f295ce478e4b71c1fd1127ffecd3646fa5d68f654ac3a32b4c31cfb1fca5890fedde9440f1b50e
diff --git a/dev-util/par/metadata.xml b/dev-util/par/metadata.xml
new file mode 100644
index 00000000000..ff62877c67a
--- /dev/null
+++ b/dev-util/par/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-util/par/par-00.05.01.ebuild b/dev-util/par/par-00.05.01.ebuild
new file mode 100644
index 00000000000..4fbedb5b164
--- /dev/null
+++ b/dev-util/par/par-00.05.01.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="par manipulates PalmOS database files"
+HOMEPAGE="http://www.djw.org/product/palm/par/"
+SRC_URI="http://www.djw.org/product/palm/par/prc.tgz"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+
+DEPEND="!app-text/par
+ !app-arch/par"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/prc"
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ || die 'Failed to compile!'
+ emake par.man || die 'Failed to make man page!'
+}
+
+src_install () {
+ dobin par || die 'dobin failed'
+ dolib *.a || die 'dolib *.a failed'
+
+ newman par.man par.1 || die 'newman failed'
+}