summaryrefslogtreecommitdiff
path: root/dev-util/shunit2
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/shunit2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/shunit2')
-rw-r--r--dev-util/shunit2/Manifest1
-rw-r--r--dev-util/shunit2/metadata.xml15
-rw-r--r--dev-util/shunit2/shunit2-2.1.6.ebuild32
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-util/shunit2/Manifest b/dev-util/shunit2/Manifest
new file mode 100644
index 00000000000..1d203f94332
--- /dev/null
+++ b/dev-util/shunit2/Manifest
@@ -0,0 +1 @@
+DIST shunit2-2.1.6.tgz 61558 SHA256 65a313a76fd5cc1c58c9e19fbc80fc0e418a4cbfbd46d54b35ed5b6e0025d4ee SHA512 c78cf349d72a9048e4932108a62b2d1873019b9b1909c3fb1bd7e873e7bb62df58c1941d916508dc60ef6ba0261a2bc6ee9e25d654eefdcce997682f2bc748d7 WHIRLPOOL f20154214fa08db98ad6ffaef39b555079f1dd17cc04b3c15f206a4ae690b55a8dbff582c5440c232920dbb4013c0b292f9fe15aa7dcc64fb1a99e51189ddd92
diff --git a/dev-util/shunit2/metadata.xml b/dev-util/shunit2/metadata.xml
new file mode 100644
index 00000000000..800122e2b70
--- /dev/null
+++ b/dev-util/shunit2/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>dberkholz@gentoo.org</email>
+ <name>Donnie Berkholz</name>
+ </maintainer>
+ <longdescription>shUnit2 is a xUnit unit test framework for Bourne based shell scripts, and
+ it is designed to work in a similar manner to JUnit, PyUnit, etc. If you
+ have ever had the desire to write a unit test for a shell script, shUnit2
+ can do the job.</longdescription>
+ <upstream>
+ <remote-id type="google-code">shunit2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/shunit2/shunit2-2.1.6.ebuild b/dev-util/shunit2/shunit2-2.1.6.ebuild
new file mode 100644
index 00000000000..9b1eb16653f
--- /dev/null
+++ b/dev-util/shunit2/shunit2-2.1.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="Unit-test framework for Bourne-based shell scripts"
+HOMEPAGE="http://code.google.com/p/shunit2/wiki/ProjectInfo"
+SRC_URI="http://shunit2.googlecode.com/files/${P}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ net-misc/curl"
+
+src_install() {
+ dobin src/shunit2 || die
+
+ # For backwards compat to <=2.1.5
+ dosym /usr/bin/shunit2 /usr/share/shunit2/shunit2 || die
+
+ dodoc -r examples || die
+ dodoc doc/*.txt || die
+ dohtml doc/*.{html,css} || die
+}