summaryrefslogtreecommitdiff
path: root/dev-util/valgrind/files/valgrind-3.10.1-non-exec-stack.patch
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/valgrind/files/valgrind-3.10.1-non-exec-stack.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/valgrind/files/valgrind-3.10.1-non-exec-stack.patch')
-rw-r--r--dev-util/valgrind/files/valgrind-3.10.1-non-exec-stack.patch148
1 files changed, 148 insertions, 0 deletions
diff --git a/dev-util/valgrind/files/valgrind-3.10.1-non-exec-stack.patch b/dev-util/valgrind/files/valgrind-3.10.1-non-exec-stack.patch
new file mode 100644
index 00000000000..e25de99e790
--- /dev/null
+++ b/dev-util/valgrind/files/valgrind-3.10.1-non-exec-stack.patch
@@ -0,0 +1,148 @@
+diff -Naur valgrind-3.10.1.orig/coregrind/Makefile.am valgrind-3.10.1/coregrind/Makefile.am
+--- valgrind-3.10.1.orig/coregrind/Makefile.am 2014-11-25 14:41:19.000000000 -0500
++++ valgrind-3.10.1/coregrind/Makefile.am 2014-11-26 13:36:44.113678744 -0500
+@@ -333,18 +333,6 @@
+ m_demangle/demangle.c \
+ m_demangle/dyn-string.c \
+ m_demangle/safe-ctype.c \
+- m_dispatch/dispatch-x86-linux.S \
+- m_dispatch/dispatch-amd64-linux.S \
+- m_dispatch/dispatch-ppc32-linux.S \
+- m_dispatch/dispatch-ppc64be-linux.S \
+- m_dispatch/dispatch-ppc64le-linux.S \
+- m_dispatch/dispatch-arm-linux.S \
+- m_dispatch/dispatch-arm64-linux.S \
+- m_dispatch/dispatch-s390x-linux.S \
+- m_dispatch/dispatch-mips32-linux.S \
+- m_dispatch/dispatch-mips64-linux.S \
+- m_dispatch/dispatch-x86-darwin.S \
+- m_dispatch/dispatch-amd64-darwin.S \
+ m_gdbserver/inferiors.c \
+ m_gdbserver/m_gdbserver.c \
+ m_gdbserver/regcache.c \
+@@ -368,8 +356,6 @@
+ m_initimg/initimg-pathscan.c \
+ m_mach/mach_basics.c \
+ m_mach/mach_msg.c \
+- m_mach/mach_traps-x86-darwin.S \
+- m_mach/mach_traps-amd64-darwin.S \
+ m_replacemalloc/replacemalloc_core.c \
+ m_scheduler/scheduler.c \
+ m_scheduler/sema.c \
+@@ -386,18 +372,6 @@
+ m_sigframe/sigframe-mips64-linux.c \
+ m_sigframe/sigframe-x86-darwin.c \
+ m_sigframe/sigframe-amd64-darwin.c \
+- m_syswrap/syscall-x86-linux.S \
+- m_syswrap/syscall-amd64-linux.S \
+- m_syswrap/syscall-ppc32-linux.S \
+- m_syswrap/syscall-ppc64be-linux.S \
+- m_syswrap/syscall-ppc64le-linux.S \
+- m_syswrap/syscall-arm-linux.S \
+- m_syswrap/syscall-arm64-linux.S \
+- m_syswrap/syscall-s390x-linux.S \
+- m_syswrap/syscall-mips32-linux.S \
+- m_syswrap/syscall-mips64-linux.S \
+- m_syswrap/syscall-x86-darwin.S \
+- m_syswrap/syscall-amd64-darwin.S \
+ m_syswrap/syswrap-main.c \
+ m_syswrap/syswrap-generic.c \
+ m_syswrap/syswrap-linux.c \
+@@ -420,6 +394,29 @@
+ m_ume/main.c \
+ m_ume/script.c
+
++COREGRIND_SOURCES_COMMON += \
++ m_dispatch/dispatch-@VGCONF_ARCH_PRI@-@VGCONF_OS@.S \
++ m_syswrap/syscall-@VGCONF_ARCH_PRI@-@VGCONF_OS@.S
++
++if VGCONF_HAVE_PLATFORM_SEC
++COREGRIND_SOURCES_COMMON += \
++ m_dispatch/dispatch-@VGCONF_ARCH_SEC@-@VGCONF_OS@.S \
++ m_syswrap/syscall-@VGCONF_ARCH_SEC@-@VGCONF_OS@.S
++endif
++
++if VGCONF_OS_IS_DARWIN
++COREGRIND_SOURCES_COMMON += \
++ m_dispatch/dispatch-@VGCONF_ARCH_PRI@-darwin.S \
++ m_syswrap/syscall-@VGCONF_ARCH_PRI@-darwin.S \
++ m_mach/mach_traps-@VGCONF_ARCH_PRI@-darwin.S
++if VGCONF_HAVE_PLATFORM_SEC
++COREGRIND_SOURCES_COMMON += \
++ m_dispatch/dispatch-@VGCONF_ARCH_SEC@-darwin.S \
++ m_syswrap/syscall-@VGCONF_ARCH_SEC@-darwin.S \
++ m_mach/mach_traps-@VGCONF_ARCH_SEC@-darwin.S
++endif
++endif
++
+ libcoregrind_@VGCONF_ARCH_PRI@_@VGCONF_OS@_a_SOURCES = \
+ $(COREGRIND_SOURCES_COMMON)
+ nodist_libcoregrind_@VGCONF_ARCH_PRI@_@VGCONF_OS@_a_SOURCES = \
+diff -Naur valgrind-3.10.1.orig/coregrind/m_dispatch/dispatch-amd64-linux.S valgrind-3.10.1/coregrind/m_dispatch/dispatch-amd64-linux.S
+--- valgrind-3.10.1.orig/coregrind/m_dispatch/dispatch-amd64-linux.S 2014-11-25 14:41:20.000000000 -0500
++++ valgrind-3.10.1/coregrind/m_dispatch/dispatch-amd64-linux.S 2014-11-26 13:30:11.840660890 -0500
+@@ -249,11 +249,11 @@
+
+ .size VG_(disp_run_translations), .-VG_(disp_run_translations)
+
++#endif // defined(VGP_amd64_linux)
++
+ /* Let the linker know we don't need an executable stack */
+ .section .note.GNU-stack,"",@progbits
+
+-#endif // defined(VGP_amd64_linux)
+-
+ /*--------------------------------------------------------------------*/
+ /*--- end ---*/
+ /*--------------------------------------------------------------------*/
+diff -Naur valgrind-3.10.1.orig/coregrind/m_dispatch/dispatch-x86-linux.S valgrind-3.10.1/coregrind/m_dispatch/dispatch-x86-linux.S
+--- valgrind-3.10.1.orig/coregrind/m_dispatch/dispatch-x86-linux.S 2014-11-25 14:41:20.000000000 -0500
++++ valgrind-3.10.1/coregrind/m_dispatch/dispatch-x86-linux.S 2014-11-26 13:30:11.840660890 -0500
+@@ -240,11 +240,11 @@
+
+ .size VG_(disp_run_translations), .-VG_(disp_run_translations)
+
++#endif // defined(VGP_x86_linux)
++
+ /* Let the linker know we don't need an executable stack */
+ .section .note.GNU-stack,"",@progbits
+
+-#endif // defined(VGP_x86_linux)
+-
+ /*--------------------------------------------------------------------*/
+ /*--- end ---*/
+ /*--------------------------------------------------------------------*/
+diff -Naur valgrind-3.10.1.orig/coregrind/m_syswrap/syscall-amd64-linux.S valgrind-3.10.1/coregrind/m_syswrap/syscall-amd64-linux.S
+--- valgrind-3.10.1.orig/coregrind/m_syswrap/syscall-amd64-linux.S 2014-11-25 14:41:20.000000000 -0500
++++ valgrind-3.10.1/coregrind/m_syswrap/syscall-amd64-linux.S 2014-11-26 13:30:11.840660890 -0500
+@@ -205,11 +205,11 @@
+ ML_(blksys_finished): .quad 5b
+ .previous
+
++#endif // defined(VGP_amd64_linux)
++
+ /* Let the linker know we don't need an executable stack */
+ .section .note.GNU-stack,"",@progbits
+
+-#endif // defined(VGP_amd64_linux)
+-
+ /*--------------------------------------------------------------------*/
+ /*--- end ---*/
+ /*--------------------------------------------------------------------*/
+diff -Naur valgrind-3.10.1.orig/coregrind/m_syswrap/syscall-x86-linux.S valgrind-3.10.1/coregrind/m_syswrap/syscall-x86-linux.S
+--- valgrind-3.10.1.orig/coregrind/m_syswrap/syscall-x86-linux.S 2014-11-25 14:41:20.000000000 -0500
++++ valgrind-3.10.1/coregrind/m_syswrap/syscall-x86-linux.S 2014-11-26 13:30:11.840660890 -0500
+@@ -165,11 +165,11 @@
+ ML_(blksys_finished): .long 5b
+ .previous
+
++#endif // defined(VGP_x86_linux)
++
+ /* Let the linker know we don't need an executable stack */
+ .section .note.GNU-stack,"",@progbits
+
+-#endif // defined(VGP_x86_linux)
+-
+ /*--------------------------------------------------------------------*/
+ /*--- end ---*/
+ /*--------------------------------------------------------------------*/