summaryrefslogtreecommitdiff
path: root/dev-util/webcpp
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/webcpp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/webcpp')
-rw-r--r--dev-util/webcpp/Manifest1
-rw-r--r--dev-util/webcpp/files/webcpp-0.8.4-gcc.patch15
-rw-r--r--dev-util/webcpp/files/webcpp-0.8.4-gcc43.patch10
-rw-r--r--dev-util/webcpp/metadata.xml10
-rw-r--r--dev-util/webcpp/webcpp-0.8.4.ebuild29
5 files changed, 65 insertions, 0 deletions
diff --git a/dev-util/webcpp/Manifest b/dev-util/webcpp/Manifest
new file mode 100644
index 00000000000..97d166ad8f0
--- /dev/null
+++ b/dev-util/webcpp/Manifest
@@ -0,0 +1 @@
+DIST webcpp-0.8.4-src.tar.gz 430757 SHA256 f6cdb047d36a24a4d0e2aad8c54f45c78ad5058a756d86a358a00fec24a91275 SHA512 12e5cd7487f34de16ea32b21d53006f7b0c1416213da2a4af15aadf1af582ba52944bc188df8f13e8fd9b19091acc18f173a4be48bb0a28739130b35659fb663 WHIRLPOOL c2a2b880da08bcd037c7d45b0b2f0eb30c237cd2365fd2094e51c3f04d0f4d04ecf62b7135930a0c148c930a64c76a9bf73bd93615e8e081acf8de405f2dd31b
diff --git a/dev-util/webcpp/files/webcpp-0.8.4-gcc.patch b/dev-util/webcpp/files/webcpp-0.8.4-gcc.patch
new file mode 100644
index 00000000000..b7c0cbe4886
--- /dev/null
+++ b/dev-util/webcpp/files/webcpp-0.8.4-gcc.patch
@@ -0,0 +1,15 @@
+scrub stray \
+
+http://bugs.gentoo.org/202210
+
+--- webcpp/engine.cpp
++++ webcpp/engine.cpp
+@@ -1005,7 +1005,7 @@
+ </tr><tr><td colspan=6>\n\
+ <a href=\"http://webcpp.sf.net\"><center><b>\
+ <font color=#ffffff>web c plus plus</font></b></center>\n\
+-</a></td></tr>\n\</table>\n<br>\n</center>";
++</a></td></tr>\n</table>\n<br>\n</center>";
+
+ *IO << made;
+ }
diff --git a/dev-util/webcpp/files/webcpp-0.8.4-gcc43.patch b/dev-util/webcpp/files/webcpp-0.8.4-gcc43.patch
new file mode 100644
index 00000000000..47ffb5515a0
--- /dev/null
+++ b/dev-util/webcpp/files/webcpp-0.8.4-gcc43.patch
@@ -0,0 +1,10 @@
+--- webcpp/main.cpp.orig 2008-06-17 19:03:37.000000000 -0500
++++ webcpp/main.cpp 2008-06-17 19:03:50.000000000 -0500
+@@ -24,6 +24,7 @@
+
+ #include "driver.h"
+ #include <fstream>
++#include <cstdlib>
+ using namespace std;
+
+ int main(int argc, char **argv) {
diff --git a/dev-util/webcpp/metadata.xml b/dev-util/webcpp/metadata.xml
new file mode 100644
index 00000000000..99516485b36
--- /dev/null
+++ b/dev-util/webcpp/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">webcpp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/webcpp/webcpp-0.8.4.ebuild b/dev-util/webcpp/webcpp-0.8.4.ebuild
new file mode 100644
index 00000000000..651d93970c8
--- /dev/null
+++ b/dev-util/webcpp/webcpp-0.8.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="converts source code into HTML using a customizable syntax highlight engine and colour schemes"
+HOMEPAGE="http://webcpp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/webcpp/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~hppa ~mips ppc sparc x86"
+IUSE=""
+
+S=${WORKDIR}/${P}-src
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc.patch
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS CREDITS ChangeLog README TODO
+ fperms a+x /usr/bin/webc++ /usr/bin/scs2scs2.pl
+}