summaryrefslogtreecommitdiff
path: root/dev-util/xdelta/files/xdelta-1.1.4-pkgconfig.patch
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/xdelta/files/xdelta-1.1.4-pkgconfig.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/xdelta/files/xdelta-1.1.4-pkgconfig.patch')
-rw-r--r--dev-util/xdelta/files/xdelta-1.1.4-pkgconfig.patch113
1 files changed, 113 insertions, 0 deletions
diff --git a/dev-util/xdelta/files/xdelta-1.1.4-pkgconfig.patch b/dev-util/xdelta/files/xdelta-1.1.4-pkgconfig.patch
new file mode 100644
index 00000000000..bb509b8d435
--- /dev/null
+++ b/dev-util/xdelta/files/xdelta-1.1.4-pkgconfig.patch
@@ -0,0 +1,113 @@
+Nicked from http://cvs.fedoraproject.org/viewvc/devel/xdelta/xdelta-1.1.3-pkgconfig.patch
+
+--- /dev/null 2006-05-17 14:47:01.398050000 +0200
++++ xdelta-1.1.3/xdelta.pc.in 2006-05-30 16:00:55.000000000 +0200
+@@ -0,0 +1,13 @@
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++pkgdatadir=@pkgdatadir@
++
++Name: xdelta
++Description: A binary file delta generator and an RCS replacement library.
++Version: @VERSION@
++Requires: glib-2.0
++Libs: -L${libdir} -lxdelta -ledsio
++Cflags: -I${includedir}
++
+--- /dev/null 2006-05-17 14:47:01.398050000 +0200
++++ xdelta-1.1.3/xdelta-config 2006-05-30 16:04:22.000000000 +0200
+@@ -0,0 +1,60 @@
++#!/bin/bash
++#
++# Simple wrapper around pkg-config to replace /usr/bin/<foo>-config scripts
++#
++# Copyright 2006 Red Hat, Inc.
++# Jeremy Katz <katzj@redhat.com>
++
++CFGPATH=$(basename $0)
++MODULE=${CFGPATH%-config}
++
++usage() {
++ pkg-config --help
++ exit 1
++}
++
++if [ $# -lt 1 ]; then
++ usage 1>&2
++fi
++
++ARGS=""
++
++while test $# -gt 0; do
++ case $1 in
++ --version)
++ ARGS="$ARGS --modversion"
++ ;;
++ --cflags)
++ ARGS="$ARGS --cflags"
++ ;;
++ --libs)
++ ARGS="$ARGS --libs"
++ ;;
++ --libdir*)
++ ARGS="$ARGS --libs-only-L"
++ ;;
++ --includedir*)
++ ARGS="$ARGS --cflags-only-I"
++ ;;
++ --prefix*)
++ ARGS="$ARGS --variable=prefix"
++ ;;
++ --exec-prefix*)
++ ARGS="$ARGS --variable=exec_prefix"
++ ;;
++ --module*)
++ if echo $1 | grep -q '=' ; then
++ MODULE=`echo $1 | sed 's/^--module=//'`
++ else
++ MODULE=$2
++ shift
++ fi
++ ;;
++ *)
++ usage 1>&2
++ ;;
++ esac
++ shift
++done
++
++pkg-config $ARGS $MODULE
+--- xdelta-1.1.3/Makefile.am.pkgconfig 2006-05-30 16:00:55.000000000 +0200
++++ xdelta-1.1.3/Makefile.am 2006-05-30 16:00:55.000000000 +0200
+@@ -27,6 +27,9 @@
+ m4datadir = $(datadir)/aclocal
+ m4data_DATA = xdelta.m4
+
++pkgconfigdir = $(libdir)/pkgconfig
++pkgconfig_DATA = xdelta.pc
++
+ ## $Format: "libxdelta_la_LDFLAGS = -version-info $LibCurrent$:$LibRevision$:$LibAge$" $
+ libxdelta_la_LDFLAGS = -version-info 2:0:0
+
+--- xdelta-1.1.3/configure.in.pkgconfig 2006-05-30 16:00:55.000000000 +0200
++++ xdelta-1.1.3/configure.in 2006-05-30 16:00:55.000000000 +0200
+@@ -63,6 +63,8 @@
+ AC_HEADER_STDC
+ AC_PROG_MAKE_SET
+
++PKG_PROG_PKG_CONFIG
++
+ AC_CHECK_FUNCS(gettimeofday)
+ AC_HEADER_TIME
+
+@@ -83,7 +85,7 @@
+ doc/Makefile
+ test/Makefile
+ djgpp/Makefile
+- xdelta-config
++ xdelta.pc
+ libedsio/Makefile
+ libedsio/edsio-comp,
+