summaryrefslogtreecommitdiff
path: root/dev-util
diff options
context:
space:
mode:
authorEttore Di Giacinto <mudler@gentoo.org>2016-11-09 16:17:13 +0100
committerEttore Di Giacinto <mudler@gentoo.org>2016-11-09 16:19:03 +0100
commit24b04f5e4e1ef9d16d1437802655dbc124ba5d54 (patch)
tree47bbba9604e1bdbb023234245c57342c42fb18f8 /dev-util
parent6499b88a47670480bc641bf7ab56cbd9332adc42 (diff)
downloadgentoo-24b04f5e4e1ef9d16d1437802655dbc124ba5d54.tar.gz
gentoo-24b04f5e4e1ef9d16d1437802655dbc124ba5d54.tar.xz
dev-util/molecule-core: revision bump
* migrate to python-r1 eclass and EAPI=6 Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=599308 Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/molecule-core/molecule-core-1.0.2-r1.ebuild (renamed from dev-util/molecule-core/molecule-core-1.0.2.ebuild)19
1 files changed, 5 insertions, 14 deletions
diff --git a/dev-util/molecule-core/molecule-core-1.0.2.ebuild b/dev-util/molecule-core/molecule-core-1.0.2-r1.ebuild
index bbef4ea9578..0ac7754415a 100644
--- a/dev-util/molecule-core/molecule-core-1.0.2.ebuild
+++ b/dev-util/molecule-core/molecule-core-1.0.2-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
-PYTHON_DEPEND="*"
+EAPI="6"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-inherit python
+inherit python-r1
DESCRIPTION="Sabayon distro-agnostic images build tool"
HOMEPAGE="http://www.sabayon.org"
@@ -23,14 +23,5 @@ RDEPEND="!<dev-util/molecule-1
src_install() {
emake DESTDIR="${D}" LIBDIR="/usr/lib" \
- PREFIX="/usr" SYSCONFDIR="/etc" install \
- || die "emake install failed"
-}
-
-pkg_postinst() {
- python_mod_optimize "/usr/lib/molecule"
-}
-
-pkg_postrm() {
- python_mod_cleanup "/usr/lib/molecule"
+ PREFIX="/usr" SYSCONFDIR="/etc" install
}