summaryrefslogtreecommitdiff
path: root/dev-util
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-12-22 12:04:18 +0100
committerLars Wendler <polynomial-c@gentoo.org>2015-12-22 12:04:35 +0100
commit2a42dbe63d402b5492a04e4e84d172acbe031c61 (patch)
tree33b54f166572577717949b886d09bc42db979c62 /dev-util
parentae97ca5b4facf38ebea8b82d922be80ee633bc1c (diff)
downloadgentoo-2a42dbe63d402b5492a04e4e84d172acbe031c61.tar.gz
gentoo-2a42dbe63d402b5492a04e4e84d172acbe031c61.tar.xz
dev-util/strace: Bump to version 4.11
Package-Manager: portage-2.2.26 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/strace/Manifest1
-rw-r--r--dev-util/strace/strace-4.11.ebuild57
-rw-r--r--dev-util/strace/strace-9999.ebuild2
3 files changed, 59 insertions, 1 deletions
diff --git a/dev-util/strace/Manifest b/dev-util/strace/Manifest
index d968a8e548e..172d1aaf430 100644
--- a/dev-util/strace/Manifest
+++ b/dev-util/strace/Manifest
@@ -1,2 +1,3 @@
DIST strace-4.10.tar.xz 601856 SHA256 e6180d866ef9e76586b96e2ece2bfeeb3aa23f5cc88153f76e9caedd65e40ee2 SHA512 53d55b749224927cfcc9783db57eb8a057fc1329b2f5da2f54299dab17d530f5d1359480f03bea307fb72f6f372e50a0dbf0bd25d36a57a77632d9c1f690fc1d WHIRLPOOL f177d980248892a99b2ed4c5d0275bc735200a597e9b6edf3bb68b8839b2bf090628f2760ffad1a4d1f862b83602cf587a63f3af288978ca2fa54cc221da4e6f
+DIST strace-4.11.tar.xz 679924 SHA256 e86a5f6cd8f941f67f3e4b28f4e60f3d9185c951cf266404533210a2e5cd8152 SHA512 e1e07ed427f504f53bcd117b61bb96a780b0f531010856ed157e4d8c2090371bf320ab59a02b88e67bf2afd443fba67e12f90e53afeab795188c89c6496daecd WHIRLPOOL eee2ae13670dc6f52c45e8275e54655216bd63f1bba2b056a31cb2ee1431f3f15060112a4807eb552a36429bee5d358a5ac3290d25f8875ffd818bb6fcb21a2f
DIST strace-4.9.tar.xz 521728 SHA256 095bfea5c540b91d297ccac73b21b92fd54a24599fd70395db87ff9eb7fd6f65 SHA512 70d03b74067ad03940cda72dc057a44a8a33fc55790a8a3bfffb1c4d7442c2de7f3e975a01dc7c7b0430342e492579b2f3a007242d13c8a0feba1a1989f42b7b WHIRLPOOL cbe2a859f6dfb82c3df652ed1fbe8982348f9c6ab61491153ce735e857275904639c003853a02188f8bc567d2eae7a710683b09d9cff67c3a4b8d7a0eb9a082e
diff --git a/dev-util/strace/strace-4.11.ebuild b/dev-util/strace/strace-4.11.ebuild
new file mode 100644
index 00000000000..9b27983762f
--- /dev/null
+++ b/dev-util/strace/strace-4.11.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic eutils
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://strace.git.sourceforge.net/gitroot/strace/strace"
+ inherit git-2 autotools
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux"
+fi
+
+DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
+HOMEPAGE="http://sourceforge.net/projects/strace/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="aio perl static unwind"
+
+LIB_DEPEND="unwind? ( sys-libs/libunwind[static-libs(+)] )"
+# strace only uses the header from libaio to decode structs
+DEPEND="static? ( ${LIB_DEPEND} )
+ aio? ( >=dev-libs/libaio-0.3.106 )
+ sys-kernel/linux-headers"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
+ perl? ( dev-lang/perl )"
+
+src_prepare() {
+ if epatch_user || [[ ! -e configure ]] ; then
+ # git generation
+ ./xlat/gen.sh
+ eautoreconf
+ [[ ! -e CREDITS ]] && cp CREDITS{.in,}
+ fi
+
+ filter-lfs-flags # configure handles this sanely
+ use static && append-ldflags -static
+
+ export ac_cv_header_libaio_h=$(usex aio)
+
+ # Stub out the -k test since it's known to be flaky. #545812
+ sed -i '1iexit 77' tests*/strace-k.test || die
+}
+
+src_configure() {
+ econf $(use_with unwind libunwind)
+}
+
+src_install() {
+ default
+ use perl || rm "${ED}"/usr/bin/strace-graph
+ dodoc CREDITS
+}
diff --git a/dev-util/strace/strace-9999.ebuild b/dev-util/strace/strace-9999.ebuild
index 9a701506480..a5fd46ddd98 100644
--- a/dev-util/strace/strace-9999.ebuild
+++ b/dev-util/strace/strace-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI=5
inherit flag-o-matic eutils