summaryrefslogtreecommitdiff
path: root/dev-util
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-04-08 18:17:48 -0400
committerMike Gilbert <floppym@gentoo.org>2017-04-08 18:24:15 -0400
commit6c1d8ef2e327b3b694124e52b8c2677bc1734cac (patch)
tree099c1a3e58a1d1e1f2b04bf4b1be8d4d859e862d /dev-util
parente586bf75cb8ab0ec05a41e8d03f3490fff292e80 (diff)
downloadgentoo-6c1d8ef2e327b3b694124e52b8c2677bc1734cac.tar.gz
gentoo-6c1d8ef2e327b3b694124e52b8c2677bc1734cac.tar.xz
dev-util/meson: add basic python_test function and RESTRICT=test
The tests do not pass at the moment. Package-Manager: Portage-2.3.5_p19, Repoman-2.3.2_p49
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/meson/meson-0.39.1.ebuild5
-rw-r--r--dev-util/meson/meson-9999.ebuild5
2 files changed, 10 insertions, 0 deletions
diff --git a/dev-util/meson/meson-0.39.1.ebuild b/dev-util/meson/meson-0.39.1.ebuild
index 4a98372fa7d..d2899b6e689 100644
--- a/dev-util/meson/meson-0.39.1.ebuild
+++ b/dev-util/meson/meson-0.39.1.ebuild
@@ -20,6 +20,7 @@ HOMEPAGE="http://mesonbuild.com/"
LICENSE="Apache-2.0"
SLOT="0"
IUSE=""
+RESTRICT="test"
DEPEND="${PYTHON_DEPS}
>=dev-util/ninja-1.6.0
@@ -27,3 +28,7 @@ DEPEND="${PYTHON_DEPS}
RDEPEND="${DEPEND}"
DOCS=( authors.txt contributing.txt )
+
+python_test() {
+ ${EPYTHON} run_tests.py || die
+}
diff --git a/dev-util/meson/meson-9999.ebuild b/dev-util/meson/meson-9999.ebuild
index 898271b1e2c..e9199b92640 100644
--- a/dev-util/meson/meson-9999.ebuild
+++ b/dev-util/meson/meson-9999.ebuild
@@ -20,6 +20,7 @@ HOMEPAGE="http://mesonbuild.com/"
LICENSE="Apache-2.0"
SLOT="0"
IUSE=""
+RESTRICT="test"
DEPEND="${PYTHON_DEPS}
>=dev-util/ninja-1.6.0
@@ -27,3 +28,7 @@ DEPEND="${PYTHON_DEPS}
RDEPEND="${DEPEND}"
DOCS=( authors.txt contributing.txt )
+
+python_test() {
+ ${EPYTHON} run_tests.py || die
+}