summaryrefslogtreecommitdiff
path: root/dev-util
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2016-11-11 12:00:37 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2016-11-11 13:46:30 +0100
commit9259943e64f1efbf6b2a6f968a6575459e0865dc (patch)
tree8dcee13928aa97c05dc2a10dbd87710ae446a03a /dev-util
parentb71f67555f36575ff83e410a88c4112107fe8072 (diff)
downloadgentoo-9259943e64f1efbf6b2a6f968a6575459e0865dc.tar.gz
gentoo-9259943e64f1efbf6b2a6f968a6575459e0865dc.tar.xz
dev-util/gdbus-codegen: version bump 2.50.1 → 2.50.2
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/gdbus-codegen/Manifest1
-rw-r--r--dev-util/gdbus-codegen/gdbus-codegen-2.50.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-util/gdbus-codegen/Manifest b/dev-util/gdbus-codegen/Manifest
index 6a7f5fa03c8..ffc801b6546 100644
--- a/dev-util/gdbus-codegen/Manifest
+++ b/dev-util/gdbus-codegen/Manifest
@@ -5,3 +5,4 @@ DIST glib-2.48.1.tar.xz 7441032 SHA256 74411bff489cb2a3527bac743a51018841a56a4d8
DIST glib-2.48.2.tar.xz 6408644 SHA256 f25e751589cb1a58826eac24fbd4186cda4518af772806b666a3f91f66e6d3f4 SHA512 2eac104eb2207d0a6488992e48069a34b417f51e141364f281ab7b0953a6de88be177b1c694dd9464a856c9a5d8021e3cf0193a8d9c5aaf6ea11f1f9ff743c43 WHIRLPOOL cba211000d5597e93d01113e5f2b6736e47f4daa00935a53af182b3304fef9a1ac25f78995c7a53cc1234261433a1bbd1ec751c87b556845a15da720af5b971b
DIST glib-2.50.0.tar.xz 7513808 SHA256 830b551fa626bda06e12729205b3c5bb0d82b924a8cf64d948945878f01b7d70 SHA512 ad711cac11bb4e3a2c5cfa315f67ea252f2f91249bb00daf708653ad50895f0ebe874d491e6052b67c8e13bd153910105358964d0b7f86463b512a3ee2967b3c WHIRLPOOL a7a0010b8949744b2410a5ea47b7975e960246294c6947d4804dc504c0509aefa0fb883e20f889d08a238c39ab1e2626e2d71bc5947f9bebfefe42bf1d00d61e
DIST glib-2.50.1.tar.xz 7521832 SHA256 2ef87a78f37c1eb5b95f4cc95efd5b66f69afad9c9c0899918d04659cf6df7dd SHA512 68c327179a786eb50f6f2c036dd71415143604bc12787be992e0b25bd691cd480aca4b2c284802bbcf94865ccef8776b03f98a45db3463b008adb602c208c090 WHIRLPOOL 818f76ba2ad58ff9a8e3b78ce4a2ea15e94e65518704729f1b425da6a465331e1b4f82136883455ae54cab1b48c9536566d281d0e74e27bc2d2bd431d31a6aa1
+DIST glib-2.50.2.tar.xz 7582312 SHA256 be68737c1f268c05493e503b3b654d2b7f43d7d0b8c5556f7e4651b870acfbf5 SHA512 63d7b5ece8d7d15b10e06ef10a8e0a4446f30a8d9c97daa3352ec00dfef622728bd42ed24cbf67e553166a0f9e29a3e3d024d1d085b9804fd67608db438b6771 WHIRLPOOL f7a005c0ad0edd0a9010aec60c4df907f79c45948b7bb583d70c378557c2a2f63383ebbaded9074b319a669bdf0532d78ce41a4f98d80d53a3a151a4a69be2a2
diff --git a/dev-util/gdbus-codegen/gdbus-codegen-2.50.2.ebuild b/dev-util/gdbus-codegen/gdbus-codegen-2.50.2.ebuild
new file mode 100644
index 00000000000..1eb55336256
--- /dev/null
+++ b/dev-util/gdbus-codegen/gdbus-codegen-2.50.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GNOME_ORG_MODULE="glib"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_REQ_USE="xml"
+
+inherit eutils gnome.org distutils-r1
+
+DESCRIPTION="GDBus code and documentation generator"
+HOMEPAGE="http://www.gtk.org/"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+# To prevent circular dependencies with glib[test]
+PDEPEND=">=dev-libs/glib-${PV}:2"
+
+S="${WORKDIR}/glib-${PV}/gio/gdbus-2.0/codegen"
+
+python_prepare_all() {
+ PATCHES=(
+ "${FILESDIR}/${PN}-2.40.0-sitedir.patch"
+ )
+ distutils-r1_python_prepare_all
+
+ sed -e 's:#!@PYTHON@:#!/usr/bin/env python:' gdbus-codegen.in > gdbus-codegen || die
+ cp "${FILESDIR}/setup.py-2.32.4" setup.py || die "cp failed"
+ sed -e "s/@PV@/${PV}/" -i setup.py || die "sed setup.py failed"
+}
+
+src_test() {
+ einfo "Skipping tests. This package is tested by dev-libs/glib"
+ einfo "when merged with FEATURES=test"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all # no-op, but prevents QA warning
+ doman "${WORKDIR}/glib-${PV}/docs/reference/gio/gdbus-codegen.1"
+}