summaryrefslogtreecommitdiff
path: root/dev-util
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-21 13:38:35 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-21 13:38:35 +0100
commitb1a257f4a5459b0962dc72867aee2c39a893a6fb (patch)
tree229ff7118866b58c7e5ff4bbd2595bf0f6816749 /dev-util
parent1ee208eda5cff0fa670961122d80f944e11f039d (diff)
downloadgentoo-b1a257f4a5459b0962dc72867aee2c39a893a6fb.tar.gz
gentoo-b1a257f4a5459b0962dc72867aee2c39a893a6fb.tar.xz
dev-util/fhist: Version Bump and fix build failure with gcc-5
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=568962 Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/fhist/Manifest1
-rw-r--r--dev-util/fhist/fhist-1.19.ebuild8
-rw-r--r--dev-util/fhist/fhist-1.21.ebuild30
-rw-r--r--dev-util/fhist/files/fhist-1.21-ldflags.patch40
-rw-r--r--dev-util/fhist/metadata.xml2
5 files changed, 76 insertions, 5 deletions
diff --git a/dev-util/fhist/Manifest b/dev-util/fhist/Manifest
index efecc0b1bae..367d0984e54 100644
--- a/dev-util/fhist/Manifest
+++ b/dev-util/fhist/Manifest
@@ -1,2 +1,3 @@
DIST fhist-1.16.tar.gz 383180 SHA256 3f71c86939694755e456a9c82156f779063e74240d21da2251f33ae3c25ea336 SHA512 919fc4d424e1f878404ec2d305dbcd66a4697c88c38af54033bdb178704cf08997c816d75db93ddbfc5248f29b997c4b8aaa3fd98ee790c32582124fc332bc1d WHIRLPOOL 6469fc9a4a5ed9f82af0dca8f1f167b9c56385283328d0c24bcd88b7e38fbf9912eeb71a37a64687f9bf1c58e0996ec7ae71649ae6fa4b0622b83f65bfc8526a
DIST fhist-1.19.tar.gz 409083 SHA256 e18d97f6ff5c44593f82775eb82540d870409ed80712eead8fd41684f194f62c SHA512 d93f0ce1b29e527af5de3f49d44ebc11567f53bb0b428322daa42b0a4a14ae75333ffcb9a65ba14b2a6240d57be7bdf7632e6b4eccd071d4e9b6e90c14c317a9 WHIRLPOOL 072a3231c3994310396f00dfab0b7214e23c5e59bfa511ba0987ff89b686e3d4a33bf6f10e77fad3f1e80857f337a47a77204d3dd14aa62f42932b48d088afeb
+DIST fhist-1.21.D001.tar.gz 409961 SHA256 bc8963b142d3686c3848a74ec996cb8619cd7843deb2f99709d81bed30f6843b SHA512 9f69ba29bdd44b4888decdcfb7db49a29a1c9611ae5cd733af2e3ec04afc498674854616335d13ca732a6485cbffafc6a4072d14a9638ead1dea4412a2070f97 WHIRLPOOL 70f070ac04a4648c8575ee6ffd95edc6d5f6ee0a25e5269842f2d41dac1e600c193a72c1138a4267a02bda4137ed216b9f2c6ae5a758cf8270b1699bd6c5466f
diff --git a/dev-util/fhist/fhist-1.19.ebuild b/dev-util/fhist/fhist-1.19.ebuild
index 7e50006d988..f9ee56c2a55 100644
--- a/dev-util/fhist/fhist-1.19.ebuild
+++ b/dev-util/fhist/fhist-1.19.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=4
-inherit eutils
+inherit eutils flag-o-matic
DESCRIPTION="File history and comparison tools"
HOMEPAGE="http://fhist.sourceforge.net/fhist.html"
@@ -23,8 +23,8 @@ DEPEND="${RDEPEND}
sys-devel/bison
test? ( app-arch/sharutils )"
-MAKEOPTS+=" -j1"
-
src_prepare() {
+ MAKEOPTS+=" -j1"
epatch "${FILESDIR}"/${PV}-ldflags.patch
+ append-cflags -fgnu89-inline
}
diff --git a/dev-util/fhist/fhist-1.21.ebuild b/dev-util/fhist/fhist-1.21.ebuild
new file mode 100644
index 00000000000..d3a2b031b68
--- /dev/null
+++ b/dev-util/fhist/fhist-1.21.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="File history and comparison tools"
+HOMEPAGE="http://fhist.sourceforge.net/fhist.html"
+SRC_URI="http://fhist.sourceforge.net/${P}.D001.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-libs/libexplain
+ sys-devel/gettext
+ sys-apps/groff"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ test? ( app-arch/sharutils )"
+
+src_prepare() {
+ MAKEOPTS+=" -j1"
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+ append-cflags -fgnu89-inline
+}
diff --git a/dev-util/fhist/files/fhist-1.21-ldflags.patch b/dev-util/fhist/files/fhist-1.21-ldflags.patch
new file mode 100644
index 00000000000..00aab69d749
--- /dev/null
+++ b/dev-util/fhist/files/fhist-1.21-ldflags.patch
@@ -0,0 +1,40 @@
+ Makefile.in | 12 ++++++------
+ 1 file changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index ba4e4c2..c0e552a 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -916,8 +916,8 @@ common/libcommon.a: $(common_obj)
+ fcomp_obj = fcomp/main.$(OBJEXT)
+
+ bin/fcomp$(EXEEXT): $(fcomp_obj) common/libcommon.a .bin
+- $(CC) $(CPPFLAGS) $(CFLAGS) -o $@ $(fcomp_obj) common/libcommon.a \
+- $(LDFLAGS) $(LIBS)
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $(fcomp_obj) common/libcommon.a \
++ $(LIBS)
+
+ $(bindir)/fcomp$(EXEEXT): bin/fcomp$(EXEEXT) .bindir
+ $(INSTALL_PROGRAM) bin/fcomp$(EXEEXT) $@
+@@ -928,8 +928,8 @@ fhist_obj = fhist/breaks.$(OBJEXT) fhist/diff.$(OBJEXT) fhist/extract.$(OBJEXT)
+ fhist/subroutine.$(OBJEXT) fhist/update.$(OBJEXT)
+
+ bin/fhist$(EXEEXT): $(fhist_obj) common/libcommon.a .bin
+- $(CC) $(CPPFLAGS) $(CFLAGS) -o $@ $(fhist_obj) common/libcommon.a \
+- $(LDFLAGS) $(LIBS)
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $(fhist_obj) common/libcommon.a \
++ $(LIBS)
+
+ $(bindir)/fhist$(EXEEXT): bin/fhist$(EXEEXT) .bindir
+ $(INSTALL_PROGRAM) bin/fhist$(EXEEXT) $@
+@@ -937,8 +937,8 @@ $(bindir)/fhist$(EXEEXT): bin/fhist$(EXEEXT) .bindir
+ fmerge_obj = fmerge/main.$(OBJEXT) fmerge/work.$(OBJEXT)
+
+ bin/fmerge$(EXEEXT): $(fmerge_obj) common/libcommon.a .bin
+- $(CC) $(CPPFLAGS) $(CFLAGS) -o $@ $(fmerge_obj) common/libcommon.a \
+- $(LDFLAGS) $(LIBS)
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -o $@ $(fmerge_obj) common/libcommon.a \
++ $(LIBS)
+
+ $(bindir)/fmerge$(EXEEXT): bin/fmerge$(EXEEXT) .bindir
+ $(INSTALL_PROGRAM) bin/fmerge$(EXEEXT) $@
diff --git a/dev-util/fhist/metadata.xml b/dev-util/fhist/metadata.xml
index f17c90b91e1..d575582d205 100644
--- a/dev-util/fhist/metadata.xml
+++ b/dev-util/fhist/metadata.xml
@@ -1,4 +1,4 @@
-<?xml version='1.0' encoding='UTF-8'?>
+<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>shell-tools</herd>