summaryrefslogtreecommitdiff
path: root/dev-util
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-02-24 21:21:08 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-02-24 21:24:48 +0000
commitc500a839b6d59e1d0dc6880a7e40c99824cf4e52 (patch)
tree4653cb5e838750953201673b34662431d72dff31 /dev-util
parented268c7f9eda60081db5e21d8bfafdcf2a32276e (diff)
parent4042523c74e144578e2e5c675d0d25c11b557356 (diff)
downloadgentoo-c500a839b6d59e1d0dc6880a7e40c99824cf4e52.tar.gz
gentoo-c500a839b6d59e1d0dc6880a7e40c99824cf4e52.tar.xz
Merge github#904: dev-util/shards: Introduce new package.
shards is is a dependency manager for the Crystal language. Pull-Request: https://github.com/gentoo/gentoo/pull/904 Reporter: Lixiao Chen <longlene@gmail.com> Acked-by: Patrice Clement <monsieurp@gentoo.org> Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/shards/Manifest1
-rw-r--r--dev-util/shards/metadata.xml14
-rw-r--r--dev-util/shards/shards-0.6.1.ebuild23
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/shards/Manifest b/dev-util/shards/Manifest
new file mode 100644
index 00000000000..687da2c0a7c
--- /dev/null
+++ b/dev-util/shards/Manifest
@@ -0,0 +1 @@
+DIST shards-0.6.1.tar.gz 26505 SHA256 8e7d179a499a2fca895b534c6204e2e34828e6a645e48f83f08fbefcd6a03951 SHA512 fc1e32cf459a5c448ef780601b9515cd331fc40d3f6f0666e71e218a62e202e0d4f642f5e82660529d24145a5ed5f5cbf2fdc6fc251421850d9c7ac1ebcf4d07 WHIRLPOOL 0bf8ef2de47b6dd6be728c489b7ac9ff8101a51329d956ac2d1ad21ac9322442646d624b5b6e9baee5f1738326e3a5e039b94b5057ce6a2a5223a04db226b5a6
diff --git a/dev-util/shards/metadata.xml b/dev-util/shards/metadata.xml
new file mode 100644
index 00000000000..2bf78bc95a8
--- /dev/null
+++ b/dev-util/shards/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>longlene@gmail.com</email>
+ <name>Lixiao Chen</name>
+ </maintainer>
+ <longdescription lang="en">
+ Dependency manager for the Crystal language
+ </longdescription>
+ <upstream>
+ <remote-id type="github">ysbaddaden/shards</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/shards/shards-0.6.1.ebuild b/dev-util/shards/shards-0.6.1.ebuild
new file mode 100644
index 00000000000..95311f68cb7
--- /dev/null
+++ b/dev-util/shards/shards-0.6.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Dependency manager for the Crystal language"
+HOMEPAGE="https://github.com/ysbaddaden/shards"
+SRC_URI="https://github.com/ysbaddaden/shards/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >dev-lang/crystal-0.11.1[yaml]
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dobin bin/${PN}
+ dodoc README.md
+}