summaryrefslogtreecommitdiff
path: root/dev-util
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2016-11-12 13:21:05 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2016-11-12 13:23:14 +0100
commitf2a8480511e2a9d6f4cf04a0e4f3e1b08796075c (patch)
tree743e6047245939e7450543e1a16fb720de83aaf8 /dev-util
parenta6d84938c50c399280c312988dbd364ce3ab0271 (diff)
downloadgentoo-f2a8480511e2a9d6f4cf04a0e4f3e1b08796075c.tar.gz
gentoo-f2a8480511e2a9d6f4cf04a0e4f3e1b08796075c.tar.xz
dev-util/sysprof: version bump 1.2.0 → 3.22.2
Mostly a rewrite so some bugs might be expected. Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/sysprof/Manifest1
-rw-r--r--dev-util/sysprof/sysprof-3.22.2.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-util/sysprof/Manifest b/dev-util/sysprof/Manifest
index 0520b355f13..afbb790202c 100644
--- a/dev-util/sysprof/Manifest
+++ b/dev-util/sysprof/Manifest
@@ -1 +1,2 @@
DIST sysprof-1.2.0.tar.gz 273409 SHA256 baf03c6fc01a845c705873e6fc7927aa89539dcda6963f9ec4c8eb4c086a64f1 SHA512 76a150ceff5fd1c98dd3e062a20d1fbf686734350809712022ef76c4da87ad573e36a86ccca070f2fb8f45efc03f2d720c4b12a1cc2a3bd8a46ab33443196954 WHIRLPOOL 77a37d93c524caaf3eede00587d37472ce5a625c8888b8c6d4035f8697ba7603e3e1d8da35b4e0f4df574569148d4ae69e11bbe368aa369c007ae3bd51885163
+DIST sysprof-3.22.2.tar.xz 581864 SHA256 d57fb19a3e5d4ad37d5fb554dc93d9a03f332779c3bffd9c2aa8f176e85269d7 SHA512 601e83f8809bfc970b87a8cbecfc868e957d992aa554316e80b44f21c97a58ef0a236e0b0bda6accc01d5d551f7fca76b4882863a9ea498578731b49dc75322c WHIRLPOOL fdb2bcf0ee191bcecdda93fa3bc9d78aae5301e5fb2f0706021e1b2425d93a2d8ae16472a584ed172b864044b096c66f5c3ef714c848af63937d7dfe40736377
diff --git a/dev-util/sysprof/sysprof-3.22.2.ebuild b/dev-util/sysprof/sysprof-3.22.2.ebuild
new file mode 100644
index 00000000000..1cf63bb968d
--- /dev/null
+++ b/dev-util/sysprof/sysprof-3.22.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit gnome2 linux-info systemd
+
+DESCRIPTION="System-wide Linux Profiler"
+HOMEPAGE="http://sysprof.com/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug gtk systemd"
+
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ gtk? ( >=x11-libs/gtk+-3.21.5:3 )
+ systemd? (
+ sys-auth/polkit
+ >=sys-apps/systemd-222 )
+"
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ >=sys-devel/gettext-0.19.6
+ >=sys-kernel/linux-headers-2.6.32
+ virtual/pkgconfig
+"
+
+pkg_pretend() {
+ kernel_is -ge 2 6 31 && return
+ die "Sysprof will not work with a kernel version less than 2.6.31"
+}
+
+src_configure() {
+ # introspection & vala not use in build system
+ gnome2_src_configure \
+ $(use_enable debug) \
+ $(use_enable gtk) \
+ --disable-introspection \
+ --disable-static \
+ --disable-vala \
+ --with-sysprofd=$(usex systemd bundled no) \
+ --with-systemdsystemunitdir=$(systemd_get_systemunitdir)
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ elog "On many systems, especially amd64, it is typical that with a modern"
+ elog "toolchain -fomit-frame-pointer for gcc is the default, because"
+ elog "debugging is still possible thanks to gcc4/gdb location list feature."
+ elog "However sysprof is not able to construct call trees if frame pointers"
+ elog "are not present. Therefore -fno-omit-frame-pointer CFLAGS is suggested"
+ elog "for the libraries and applications involved in the profiling. That"
+ elog "means a CPU register is used for the frame pointer instead of other"
+ elog "purposes, which means a very minimal performance loss when there is"
+ elog "register pressure."
+}