summaryrefslogtreecommitdiff
path: root/dev-vcs/bzr-gtk
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-vcs/bzr-gtk
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-vcs/bzr-gtk')
-rw-r--r--dev-vcs/bzr-gtk/Manifest2
-rw-r--r--dev-vcs/bzr-gtk/bzr-gtk-0.103.0.ebuild50
-rw-r--r--dev-vcs/bzr-gtk/bzr-gtk-0.104.0-r1.ebuild62
-rw-r--r--dev-vcs/bzr-gtk/bzr-gtk-0.104.0.ebuild50
-rw-r--r--dev-vcs/bzr-gtk/files/credits.pickle193
-rw-r--r--dev-vcs/bzr-gtk/metadata.xml18
6 files changed, 375 insertions, 0 deletions
diff --git a/dev-vcs/bzr-gtk/Manifest b/dev-vcs/bzr-gtk/Manifest
new file mode 100644
index 00000000000..7d5a9568e58
--- /dev/null
+++ b/dev-vcs/bzr-gtk/Manifest
@@ -0,0 +1,2 @@
+DIST bzr-gtk-0.103.0.tar.gz 210971 SHA256 5dc8b222d36f1a1d5d9a4c5048b9c5c2febb653e70a9a752dae941f58d34e2fe SHA512 b95496e514b2144ffc70f516360c4f59f885ad2105a8b989ac469313dada9d5ebf05fa5b11f4e6cb16f41f0b5380159ff974f867391387f702dd35ca6dd4fe27 WHIRLPOOL 7d9a2ea8d27ed25e6f2f3a83e0eed292b758dd25942c3f26b99cf2f267b9242c77d4be814dce6d86e226fc710752ff5e1664554fe5c151fd2da051eb69c6a21b
+DIST bzr-gtk-0.104.0.tar.gz 218863 SHA256 c6d378d5111ca3483de7c54ffd9f6c7264407f567c9556e76e802b9c55ff419b SHA512 d39a1303570dd7504cad9211f3b1c86d3e6f022535c262b7b5f7b19899b362ff7b01d9f19e557cb4391d7ccf1470635ebc5d5380d2d5216b6610c4e8e1b7b6a3 WHIRLPOOL 26f611122ba3a08cc281a9d8490ed53dedad5a64d13567518ea1697285fe6f1eaa331847f928b5ac91cb35e7deef0c7bef0f9f38eddb5f3abc8dec67a3f9772d
diff --git a/dev-vcs/bzr-gtk/bzr-gtk-0.103.0.ebuild b/dev-vcs/bzr-gtk/bzr-gtk-0.103.0.ebuild
new file mode 100644
index 00000000000..ba18350706e
--- /dev/null
+++ b/dev-vcs/bzr-gtk/bzr-gtk-0.103.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_P="/${P/_rc/rc}"
+
+DESCRIPTION="A GTK+ interfaces to most Bazaar operations"
+HOMEPAGE="http://bazaar-vcs.org/bzr-gtk"
+SRC_URI="http://launchpad.net/${PN}/gtk3/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="gnome-keyring gpg nautilus"
+
+DEPEND=">=dev-vcs/bzr-1.6_rc1
+ dev-python/pygobject
+ dev-python/notify-python
+ >=dev-python/pycairo-1.0"
+RDEPEND="${DEPEND}
+ nautilus? ( >=dev-python/nautilus-python-1.0 )
+ dev-python/notify-python
+ gnome-keyring? ( dev-python/gnome-keyring-python )
+ gpg? ( app-crypt/seahorse )"
+
+S="${WORKDIR}/${MY_P}"
+
+#TODO: src_test
+
+src_prepare() {
+ cp "${FILESDIR}"/credits.pickle "${S}"/credits.pickle
+}
+
+src_install() {
+ distutils_src_install
+ insinto /etc/xdg/autostart
+ doins bzr-notify.desktop
+ if ! use nautilus
+ then
+ rm -rf "${D}"/usr/$(get_libdir)/nautilus/
+ rm -rf "${D}"$(python_get_libdir --final-ABI)/site-packages/bzrlib/plugins/gtk/nautilus-bzr.py
+ fi
+}
diff --git a/dev-vcs/bzr-gtk/bzr-gtk-0.104.0-r1.ebuild b/dev-vcs/bzr-gtk/bzr-gtk-0.104.0-r1.ebuild
new file mode 100644
index 00000000000..f6339bf9887
--- /dev/null
+++ b/dev-vcs/bzr-gtk/bzr-gtk-0.104.0-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_P="/${P/_rc/rc}"
+
+DESCRIPTION="A GTK+ interfaces to most Bazaar operations"
+HOMEPAGE="http://bazaar-vcs.org/bzr-gtk"
+SRC_URI="http://launchpad.net/${PN}/gtk3/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome-keyring gpg nautilus"
+
+DEPEND=">=dev-vcs/bzr-1.6_rc1[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ dev-python/notify-python[${PYTHON_USEDEP}]
+ >=dev-python/pycairo-1.0[${PYTHON_USEDEP}]
+ nautilus? (
+ >=dev-python/nautilus-python-1.0[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ )"
+RDEPEND="${DEPEND}
+ nautilus? ( >=dev-python/nautilus-python-1.0[${PYTHON_USEDEP}] )
+ dev-python/notify-python[${PYTHON_USEDEP}]
+ gnome-keyring? ( dev-python/gnome-keyring-python[${PYTHON_USEDEP}] )
+ gpg? ( app-crypt/seahorse )"
+
+S="${WORKDIR}/${MY_P}"
+
+#TODO: src_test
+
+python_prepare_all() {
+ cp "${FILESDIR}"/credits.pickle "${S}"/credits.pickle || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ if ! use nautilus; then
+ # automagic dep
+ rm -rf "${D%/}"/usr/$(get_libdir)/nautilus/ || die
+ rm -rf "${D%/}"$(python_get_sitedir)/bzrlib/plugins/gtk/nautilus-bzr.py* || die
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /etc/xdg/autostart
+ doins bzr-notify.desktop
+}
diff --git a/dev-vcs/bzr-gtk/bzr-gtk-0.104.0.ebuild b/dev-vcs/bzr-gtk/bzr-gtk-0.104.0.ebuild
new file mode 100644
index 00000000000..f0a9f29fedd
--- /dev/null
+++ b/dev-vcs/bzr-gtk/bzr-gtk-0.104.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_P="/${P/_rc/rc}"
+
+DESCRIPTION="A GTK+ interfaces to most Bazaar operations"
+HOMEPAGE="http://bazaar-vcs.org/bzr-gtk"
+SRC_URI="http://launchpad.net/${PN}/gtk3/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome-keyring gpg nautilus"
+
+DEPEND=">=dev-vcs/bzr-1.6_rc1
+ dev-python/pygobject
+ dev-python/notify-python
+ >=dev-python/pycairo-1.0"
+RDEPEND="${DEPEND}
+ nautilus? ( >=dev-python/nautilus-python-1.0 )
+ dev-python/notify-python
+ gnome-keyring? ( dev-python/gnome-keyring-python )
+ gpg? ( app-crypt/seahorse )"
+
+S="${WORKDIR}/${MY_P}"
+
+#TODO: src_test
+
+src_prepare() {
+ cp "${FILESDIR}"/credits.pickle "${S}"/credits.pickle
+}
+
+src_install() {
+ distutils_src_install
+ insinto /etc/xdg/autostart
+ doins bzr-notify.desktop
+ if ! use nautilus
+ then
+ rm -rf "${D}"/usr/$(get_libdir)/nautilus/
+ rm -rf "${D}"$(python_get_libdir --final-ABI)/site-packages/bzrlib/plugins/gtk/nautilus-bzr.py
+ fi
+}
diff --git a/dev-vcs/bzr-gtk/files/credits.pickle b/dev-vcs/bzr-gtk/files/credits.pickle
new file mode 100644
index 00000000000..fc0e9deceae
--- /dev/null
+++ b/dev-vcs/bzr-gtk/files/credits.pickle
@@ -0,0 +1,193 @@
+((lp0
+VJelmer Vernooij <jelmer@samba.org>
+p1
+aVDaniel Schierbeck <daniel.schierbeck@gmail.com>
+p2
+aVSzilveszter Farkas (Phanatic) <Szilveszter.Farkas@gmail.com>
+p3
+aVGary van der Merwe <garyvdm@gmail.com>
+p4
+aVJasper Groenewegen <colbrac@xs4all.nl>
+p5
+aVVincent Ladeuil <v.ladeuil+lp@free.fr>
+p6
+aVJohn Arbash Meinel <john@arbash-meinel.com>
+p7
+aVAaron Bentley <abentley@panoramicfeedback.com>
+p8
+aVAaron Bentley <aaron@aaronbentley.com>
+p9
+aVAlexander Belchenko <bialix@ukr.net>
+p10
+aVDavid Allouche <david.allouche@canonical.com>
+p11
+aVDan Loda <danloda@gmail.com>
+p12
+aVAaron Bentley <aaron.bentley@utoronto.ca>
+p13
+aVScott James Remnant <scott@netsplit.com>
+p14
+aVScott Scriven <ubuntu@toykeeper.net>
+p15
+aVMateusz Korniak <matkor@laptop-hp>
+p16
+aVRobert Collins <robertc@robertcollins.net>
+p17
+aVSzilveszter Farkas (Phanatic) <szilveszter.farkas@gmail.com>
+p18
+aVMartin Albisetti <argentina@gmail.com>
+p19
+aVSabin Iacob (m0n5t3r) <iacobs@m0n5t3r.info>
+p20
+aVJavier Derderian <javierder@gmail.com>
+p21
+aVjbailey@ubuntu.com
+p22
+aVGary van der Merwe <garyvdm@garyvdm-desktop>
+p23
+aVRichard Ferguson <ubuntu@fergusnet.com>
+p24
+aVMartin Pool <mbp@canonical.com>
+p25
+aVElliot Murphy <elliot@elliotmurphy.com>
+p26
+aVAdeodato Simó <dato@net.com.org.es>
+p27
+aVv.ladeuil+lp@free.fr
+p28
+aVSzilveszter Farkas <szilveszter.farkas@gmail.com>
+p29
+aVWouter van Heyst <larstiq@larstiq.dyndns.org>
+p30
+aVTorsten Landschoff <torsten@debian.org>
+p31
+aVJamie Wilkinson <jaq@spacepants.org>
+p32
+aVGediminas Paulauskas <menesis@pov.lt>
+p33
+aVAli Sabil <ali.sabil@gmail.com>
+p34
+aVAdrian Wilkins <adrian.wilkins@gmail.com>
+p35
+aVMichael Ellerman <michael@ellerman.id.au>
+p36
+aVMateusz Korniak (matkor@laptop-hp)
+p37
+aVJelmer Vernooij <Jelmer Vernooij@LENOVO-C29B82CD>
+p38
+aVFarkas Szilveszter <szilveszter@szilveszter-desktop>
+p39
+aVDaniel Schömer <daniel.schoemer@gmx.net>
+p40
+aVChris Lamb <chris@chris-lamb.co.uk>
+p41
+aVChad MILLER <chad@mysql.com>
+p42
+aVrodney.dawes@canonical.com
+p43
+aVmatkor <matkor@laptop-hp>
+p44
+aVklight@walkertechnical.com
+p45
+aVklight <klight@X111>
+p46
+aVVincent Geddes <vincent.geddes@gmail.com>
+p47
+aVToshio Kuratomi <toshio@fedoraproject.org>
+p48
+aVTom Badran <tom@badrunner.net>
+p49
+aVSzilveszter Farkas <szilveszter@MacBookPro.local>
+p50
+aVStéphane Raimbault <stephane.raimbault@gmail.com>
+p51
+aVScott James Remnant <scott@ubuntu.com>
+p52
+aVRuss Brown <pickscrape@gmail.com>
+p53
+aVRichard Ferguson <fergus@fergusnet.com>
+p54
+aVRene Huber <rhuber@ubuntu>
+p55
+aVPelle Johansson <pelle@blocket.se>
+p56
+aVMichael Vogt <michael.vogt@ubuntu.com>
+p57
+aVMathias Brodala <info@noctus.net>
+p58
+aVMarkus Korn <thekorn@gmx.de>
+p59
+aVMario Danic <mario.danic@gmail.com>
+p60
+aVLucas Shrewsbury <rollbak@gmail.com>
+p61
+aVKevin Light <klight@walkertechnical.com>
+p62
+aVJohn Szakmeister <john@szakmeister.net>
+p63
+aVJean-François Fortin Tam <jeff@ecchi.ca>
+p64
+aVJasper Groenewegen <colbrac@xs4al.nl>
+p65
+aVJames Westby <jw+debian@jameswestby.net>
+p66
+aVJames Henstridge <james@jamesh.id.au>
+p67
+aVErik Bagfors <erik@bagfors.nu>
+p68
+aVDennis Miller <millerdl@telusplanet.net>
+p69
+aVAndrew Starr-Bochicchio <a.starr.b@gmail.com>
+p70
+aVAndrew Bennetts <andrew@puzzling.org>
+p71
+aVAlexandre Défossez <alexandre.defossez@gmail.com>
+p72
+aVAdrian Room <ingolemo@gmail.com>
+p73
+a(lp74
+g1
+ag3
+ag6
+ag2
+ag12
+ag4
+ag27
+ag50
+ag29
+ag15
+ag14
+ag66
+ag44
+ag22
+ag49
+aVSense Hofstede <qense@ubuntu.com>
+p75
+ag52
+ag53
+ag17
+ag16
+ag25
+ag19
+ag61
+aVKiddo <nekohayo@gmail.com>
+p76
+ag62
+ag63
+ag38
+ag5
+ag23
+ag11
+ag8
+a(lp77
+g3
+ag2
+ag19
+ag61
+ag1
+a(lp78
+g3
+ag18
+ag51
+atp79
+. \ No newline at end of file
diff --git a/dev-vcs/bzr-gtk/metadata.xml b/dev-vcs/bzr-gtk/metadata.xml
new file mode 100644
index 00000000000..a41036fb827
--- /dev/null
+++ b/dev-vcs/bzr-gtk/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>bazaar</herd>
+ <longdescription lang="en">
+ GTK+ Frontends to various Bazaar commands. Currently contains
+ dialogs for almost all common operations, including annotate and
+ visualise (log). Olive, the integrated version control application
+ is also part of bzr-gtk.
+ </longdescription>
+ <use>
+ <flag name="gpg">Support signing with GnuPG.</flag>
+ <flag name="nautilus">Integrate with Nautilus file manager</flag>
+ </use>
+ <upstream>
+ <remote-id type="launchpad">bzr-gtk</remote-id>
+ </upstream>
+</pkgmetadata>