summaryrefslogtreecommitdiff
path: root/dev-vcs/fossil
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-vcs/fossil
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-vcs/fossil')
-rw-r--r--dev-vcs/fossil/Manifest1
-rw-r--r--dev-vcs/fossil/fossil-20150119112900.ebuild48
-rw-r--r--dev-vcs/fossil/metadata.xml20
3 files changed, 69 insertions, 0 deletions
diff --git a/dev-vcs/fossil/Manifest b/dev-vcs/fossil/Manifest
new file mode 100644
index 00000000000..6c1db4998ce
--- /dev/null
+++ b/dev-vcs/fossil/Manifest
@@ -0,0 +1 @@
+DIST fossil-src-20150119112900.tar.gz 3973184 SHA256 37969e5a09c1611199921e3518a4ed736fd637a02f2d5810cd45897a4ceb92dc SHA512 9bee82916d98b5d7d81e200ec6616c1e463540de254464a559254ee117a99492a0080003645a99ef93cc551395e38b93dfb12728abbbdbf468f5c2743f67718e WHIRLPOOL 19175692472913bc94bf993956c1e0b8510ff33d6df2c168acf700e64b6f4e62eed34a4888c38e093eabfe582224edf5b7e03dc652b5f1e8824b9e8e5608d492
diff --git a/dev-vcs/fossil/fossil-20150119112900.ebuild b/dev-vcs/fossil/fossil-20150119112900.ebuild
new file mode 100644
index 00000000000..1bb7ba485d5
--- /dev/null
+++ b/dev-vcs/fossil/fossil-20150119112900.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P=${PN}-src-${PV}
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simple, high-reliability, source control management, and more"
+HOMEPAGE="http://www.fossil-scm.org/"
+SRC_URI="http://www.fossil-scm.org/download/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE="json +lineedit sqlite +ssl tcl"
+
+DEPEND="
+ sys-libs/zlib
+ lineedit? ( || ( sys-libs/readline:0 dev-libs/libedit ) )
+ ssl? ( dev-libs/openssl:0 )
+ sqlite? ( dev-db/sqlite:3 )
+ tcl? ( dev-lang/tcl:0= )
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ # this is not an autotools situation so don't make it seem like one
+ # --with-tcl: works
+ # --without-tcl: dies
+ local myconf='--with-zlib'
+
+ myconf+=" --lineedit=$(usex lineedit 1 0)"
+ myconf+=" --with-openssl=$(usex ssl auto none)"
+ use json && myconf+=' --json'
+ use sqlite && myconf+=' --disable-internal-sqlite'
+ use tcl && myconf+=' --with-tcl --with-tcl-stubs'
+ tc-export CC
+ ./configure ${myconf} || die
+}
+
+src_install() {
+ dobin fossil
+}
diff --git a/dev-vcs/fossil/metadata.xml b/dev-vcs/fossil/metadata.xml
new file mode 100644
index 00000000000..af4a9e3be69
--- /dev/null
+++ b/dev-vcs/fossil/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>rafaelmartins@gentoo.org</email>
+ <name>Rafael G. Martins</name>
+ </maintainer>
+ <maintainer>
+ <email>titanofold@gentoo.org</email>
+ <name>Aaron W. Swenson</name>
+ <description>Co-Maintainer</description>
+ </maintainer>
+ <use>
+ <flag name="json">Enable the JSON API of Fossil's wiki</flag>
+ <flag name="lineedit">Enable line-editing with libedit or readline</flag>
+ <flag name="sqlite">
+ Use the system SQLite instead of the bundled one
+ </flag>
+ </use>
+</pkgmetadata>