summaryrefslogtreecommitdiff
path: root/dev-vcs/giggle
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-vcs/giggle
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-vcs/giggle')
-rw-r--r--dev-vcs/giggle/Manifest1
-rw-r--r--dev-vcs/giggle/files/giggle-0.6.2-gtksourceview-3.8.0.patch24
-rw-r--r--dev-vcs/giggle/giggle-0.7-r1.ebuild46
-rw-r--r--dev-vcs/giggle/metadata.xml12
4 files changed, 83 insertions, 0 deletions
diff --git a/dev-vcs/giggle/Manifest b/dev-vcs/giggle/Manifest
new file mode 100644
index 00000000000..9ebfaf0745f
--- /dev/null
+++ b/dev-vcs/giggle/Manifest
@@ -0,0 +1 @@
+DIST giggle-0.7.tar.xz 2042304 SHA256 ae2e2237fa0d0999d99d0a0ee9b7ec147e80bd2472d59a045b2b01eb02261f59 SHA512 01d3cc0adc610706a97b89487624fe3d09c1347c0b07920e71d2e33761fab4894ebb304113ac7df6cdd03ed6116d09dcce85b35d6169df5a3f3973faaa151cfb WHIRLPOOL 54f721249b1e2bdaafcfd42c800ce4eb80e9b9e1ed312e853a2c30b650db25b98a14af2088849930a7be4ca36628c45021f276f04af13f7e76276a965cfc4c7b
diff --git a/dev-vcs/giggle/files/giggle-0.6.2-gtksourceview-3.8.0.patch b/dev-vcs/giggle/files/giggle-0.6.2-gtksourceview-3.8.0.patch
new file mode 100644
index 00000000000..37648e17123
--- /dev/null
+++ b/dev-vcs/giggle/files/giggle-0.6.2-gtksourceview-3.8.0.patch
@@ -0,0 +1,24 @@
+diff --git a/src/giggle-diff-view.h b/src/giggle-diff-view.h
+index de5fe02..9ef33b5 100644
+--- a/src/giggle-diff-view.h
++++ b/src/giggle-diff-view.h
+@@ -23,6 +23,7 @@
+
+ #include <glib-object.h>
+ #include <gtk/gtk.h>
++#include <gtksourceview/gtksourcebuffer.h>
+ #include <gtksourceview/gtksourceview.h>
+ #include <gtksourceview/gtksourcelanguagemanager.h>
+
+diff --git a/src/giggle-view-file.c b/src/giggle-view-file.c
+index 7746225..7b74c0a 100644
+--- a/src/giggle-view-file.c
++++ b/src/giggle-view-file.c
+@@ -42,6 +42,7 @@
+
+ #include <gtksourceview/gtksourcelanguagemanager.h>
+ #include <gtksourceview/gtksourceview.h>
++#include <gtksourceview/gtksourcebuffer.h>
+
+ #define GIGGLE_TYPE_VIEW_FILE_SNAPSHOT (giggle_view_file_snapshot_get_type ())
+ #define GIGGLE_VIEW_FILE_SNAPSHOT(obj) (G_TYPE_CHECK_INSTANCE_CAST ((obj), GIGGLE_TYPE_VIEW_FILE_SNAPSHOT, GiggleViewFileSnapshot))
diff --git a/dev-vcs/giggle/giggle-0.7-r1.ebuild b/dev-vcs/giggle/giggle-0.7-r1.ebuild
new file mode 100644
index 00000000000..1b5cd5bc37c
--- /dev/null
+++ b/dev-vcs/giggle/giggle-0.7-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 eutils
+
+DESCRIPTION="GTK+ Frontend for GIT"
+HOMEPAGE="https://wiki.gnome.org/Apps/giggle"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="eds"
+
+RDEPEND="
+ >=dev-vcs/git-1.5
+ >=dev-libs/glib-2.30:2
+ >=x11-libs/gtk+-3.3.12:3
+ >=x11-libs/gtksourceview-3.0:3.0
+ >=x11-libs/gdk-pixbuf-2.22.0
+ eds? ( gnome-extra/evolution-data-server )
+ >=x11-libs/vte-0.28:2.90
+"
+DEPEND="${RDEPEND}
+ gnome-base/gnome-common
+ sys-devel/gettext
+ app-text/yelp-tools
+ virtual/pkgconfig
+ >=dev-util/intltool-0.35
+ >=sys-devel/autoconf-2.64
+ >=sys-devel/libtool-2
+"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.6.2-gtksourceview-3.8.0.patch"
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable eds evolution-data-server)
+}
diff --git a/dev-vcs/giggle/metadata.xml b/dev-vcs/giggle/metadata.xml
new file mode 100644
index 00000000000..ff688617b20
--- /dev/null
+++ b/dev-vcs/giggle/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ikelos@gentoo.org</email>
+ <name>Mike Auty</name>
+ </maintainer>
+ <longdescription lang="en">
+ GTK+ based frontend for GIT
+ </longdescription>
+</pkgmetadata>
+