summaryrefslogtreecommitdiff
path: root/dev-vcs/git-mailz
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-vcs/git-mailz
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-vcs/git-mailz')
-rw-r--r--dev-vcs/git-mailz/Manifest2
-rw-r--r--dev-vcs/git-mailz/git-mailz-0.12.ebuild29
-rw-r--r--dev-vcs/git-mailz/git-mailz-0.14.ebuild29
-rw-r--r--dev-vcs/git-mailz/metadata.xml13
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-vcs/git-mailz/Manifest b/dev-vcs/git-mailz/Manifest
new file mode 100644
index 00000000000..e6c4fd00ef5
--- /dev/null
+++ b/dev-vcs/git-mailz/Manifest
@@ -0,0 +1,2 @@
+DIST git-mailz-0.12.tar.gz 7957 SHA256 15608ae026a31f6fc0e89b386edeee5c7b1d2de210d796264eb735f17de3b20c SHA512 811f646e5d89fa3e870fbd59e79e350329097f5533b42e7830409f97bfc35248cf1965591df40300bd6ef5a44c71928504dc0b8aba1037126df3b5bd7a427b51 WHIRLPOOL d6e90451c49a4f81e9422e5e1e09b127f84ee3b905e5678025a410dc0ae2a7de6e96f40ae769be628dabdc23aa8a843ee289282133f3f943db7f7f89ec82e195
+DIST git-mailz-0.14.tar.gz 8204 SHA256 422cd5828d285d595e9ae8657d09b20298cb30561b288a5c8e343b89c8107f31 SHA512 fd6c518de135113482f2f3a4e9d89b41b1797c8219e1ed9f424a5c4ae575400e7ccd9f835b40be5d74a5eb4e1bc7d3dfedd2412a317baea7e20494169399b70c WHIRLPOOL 361c4fa0f6c0ae7e9a9aa3b7fa40904387bf9cee49e095660bd4258d62bfb061573a2272f3b097c2fc87ec2a2970b3dc060fd3d7ce4cafebb976bcf4b257daf1
diff --git a/dev-vcs/git-mailz/git-mailz-0.12.ebuild b/dev-vcs/git-mailz/git-mailz-0.12.ebuild
new file mode 100644
index 00000000000..8e2e6b43376
--- /dev/null
+++ b/dev-vcs/git-mailz/git-mailz-0.12.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Send a collection of patches as emails"
+HOMEPAGE="https://github.com/roman-neuhauser/git-mailz/"
+
+SRC_URI="http://codex.sigpipe.cz/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~x86 ~amd64"
+
+DEPEND=""
+
+RDEPEND="
+ virtual/mta
+ dev-vcs/git
+ app-shells/zsh
+"
+
+src_install(){
+ emake PREFIX="${ED}/usr" install
+}
diff --git a/dev-vcs/git-mailz/git-mailz-0.14.ebuild b/dev-vcs/git-mailz/git-mailz-0.14.ebuild
new file mode 100644
index 00000000000..8e2e6b43376
--- /dev/null
+++ b/dev-vcs/git-mailz/git-mailz-0.14.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Send a collection of patches as emails"
+HOMEPAGE="https://github.com/roman-neuhauser/git-mailz/"
+
+SRC_URI="http://codex.sigpipe.cz/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~x86 ~amd64"
+
+DEPEND=""
+
+RDEPEND="
+ virtual/mta
+ dev-vcs/git
+ app-shells/zsh
+"
+
+src_install(){
+ emake PREFIX="${ED}/usr" install
+}
diff --git a/dev-vcs/git-mailz/metadata.xml b/dev-vcs/git-mailz/metadata.xml
new file mode 100644
index 00000000000..2edcc4239e8
--- /dev/null
+++ b/dev-vcs/git-mailz/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>yac@gentoo.org</email>
+ <name>Jan Matejka</name>
+ </maintainer>
+ <longdescription lang="en">
+</longdescription>
+ <upstream>
+ <remote-id type="github">roman-neuhauser/git-mailz</remote-id>
+ </upstream>
+</pkgmetadata>