summaryrefslogtreecommitdiff
path: root/dev-vcs/git/git-9999.ebuild
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2016-04-09 09:54:41 +0200
committerFabian Groffen <grobian@gentoo.org>2016-04-09 09:57:49 +0200
commit4f4340f877b5bdfd5f35cdcc98696b591a434e95 (patch)
treea1cd85b55f319da812b7e6fb663f7edf942d3641 /dev-vcs/git/git-9999.ebuild
parente1dce766881e06f86ef3ae0e03b04974233f9a04 (diff)
downloadgentoo-4f4340f877b5bdfd5f35cdcc98696b591a434e95.tar.gz
gentoo-4f4340f877b5bdfd5f35cdcc98696b591a434e95.tar.xz
dev-vcs/git: respect CC/CFLAGS while building osxkeychain credential on Darwin
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-vcs/git/git-9999.ebuild')
-rw-r--r--dev-vcs/git/git-9999.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index 5fbd63182f5..596de37ea70 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -330,8 +330,9 @@ src_compile() {
fi
if [[ ${CHOST} == *-darwin* ]]; then
- cd "${S}"/contrib/credential/osxkeychain || die "cd credential/osxkeychain"
- git_emake || die "emake credential-osxkeychain"
+ cd "${S}"/contrib/credential/osxkeychain || die
+ git_emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" \
+ || die "emake credential-osxkeychain"
fi
cd "${S}"/Documentation