summaryrefslogtreecommitdiff
path: root/dev-vcs/hg-git/hg-git-0.8.6.ebuild
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2017-05-24 21:46:59 +0200
committerFabian Groffen <grobian@gentoo.org>2017-05-24 21:47:37 +0200
commit4880e6317031fb143c9ce57e4eb6e7e1fb4d4a91 (patch)
tree5daa8847eb032b08ae2c422119bbaf01f4a9c201 /dev-vcs/hg-git/hg-git-0.8.6.ebuild
parentaa0f625532afe47519e4a71989966863f0136901 (diff)
downloadgentoo-4880e6317031fb143c9ce57e4eb6e7e1fb4d4a91.tar.gz
gentoo-4880e6317031fb143c9ce57e4eb6e7e1fb4d4a91.tar.xz
dev-vcs/hg-git: version bump to 0.8.6, bug #619546
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'dev-vcs/hg-git/hg-git-0.8.6.ebuild')
-rw-r--r--dev-vcs/hg-git/hg-git-0.8.6.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-vcs/hg-git/hg-git-0.8.6.ebuild b/dev-vcs/hg-git/hg-git-0.8.6.ebuild
new file mode 100644
index 00000000000..76272d93cfe
--- /dev/null
+++ b/dev-vcs/hg-git/hg-git-0.8.6.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="push to and pull from a Git repository using Mercurial"
+HOMEPAGE="http://hg-git.github.io https://pypi.python.org/pypi/hg-git"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ >=dev-vcs/mercurial-1.9.3[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.9.7[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"