summaryrefslogtreecommitdiff
path: root/dev-vcs/tig
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-12-20 03:20:44 -0500
committerTim Harder <radhermit@gentoo.org>2017-12-20 03:21:43 -0500
commit447fd2930aa93c7e986d91e1add9f8c90fcb0a59 (patch)
treec07007fdce021c4031714509a89cf5b4a1ad7bb2 /dev-vcs/tig
parentfb1b420c6540be5573220ed5ed0a4396e90465b2 (diff)
downloadgentoo-447fd2930aa93c7e986d91e1add9f8c90fcb0a59.tar.gz
gentoo-447fd2930aa93c7e986d91e1add9f8c90fcb0a59.tar.xz
dev-vcs/tig: version bump to 2.3.2
Diffstat (limited to 'dev-vcs/tig')
-rw-r--r--dev-vcs/tig/Manifest1
-rw-r--r--dev-vcs/tig/tig-2.3.2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-vcs/tig/Manifest b/dev-vcs/tig/Manifest
index 502987a6b27..dceb34cf130 100644
--- a/dev-vcs/tig/Manifest
+++ b/dev-vcs/tig/Manifest
@@ -1,2 +1,3 @@
DIST tig-2.2.2.tar.gz 1046910 BLAKE2B b88b48fd24257f32a5892a8a60cf13a51e553c4f0e18918e36fc6afea68befa6d12155f143bcebf37e1beab513cf1a39d50254ac76e406d97b5552389c048222 SHA512 e43cf8b4e7938342b581a1238222d5cbf62e242208cd65fc9b3261c4076b7c60c182f9a80613538fcf8b50187cc2844c22f6d1aeaaa8b23864670667a91dbfcd
DIST tig-2.3.0.tar.gz 1080956 BLAKE2B 48eaa4803a189df8dd8456b58687d4a7cd3b13c003165fba3f705a3e15eb19d4d1e23f9cc1306c5463e21501ee547ce9551c2278d10a6b069cb49e7af93d449f SHA512 d5e8bf04689fdbeab4f2ee60eef1e8e7686827228dc2f87b20c40a3a1c31aa3476d5088423ba8bcb72616a9f0f211a2dbb631a72cc946553e41cb225ea60ab37
+DIST tig-2.3.2.tar.gz 1083036 BLAKE2B 382e17486e79348b72ec67b71db2c09276262b8a9b092e657814f9d3693f2c70c46dc54a7b05ef890497f55fbc41f2232603c936f16d26a0c4d9b73d0d9281fc SHA512 092e1ea876b077a5026ee7b820e908d1d7aaa340805eb4ff975791f88ba1983eab13af669f5e663b28dfdd9e014cb92ef8c164a335705b777be417e3a7d1d5fb
diff --git a/dev-vcs/tig/tig-2.3.2.ebuild b/dev-vcs/tig/tig-2.3.2.ebuild
new file mode 100644
index 00000000000..9f6f0769818
--- /dev/null
+++ b/dev-vcs/tig/tig-2.3.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/jonas/tig.git"
+ inherit git-r3 autotools
+else
+ SRC_URI="https://github.com/jonas/tig/releases/download/${P}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+fi
+
+DESCRIPTION="A text mode interface for git"
+HOMEPAGE="https://jonas.github.io/tig/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="unicode"
+
+DEPEND="
+ sys-libs/ncurses:0=[unicode?]
+ sys-libs/readline:0="
+RDEPEND="${DEPEND}
+ dev-vcs/git"
+[[ ${PV} == "9999" ]] && DEPEND+=" app-text/asciidoc app-text/xmlto"
+
+src_prepare() {
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
+
+src_configure() {
+ econf $(use_with unicode ncursesw)
+}
+
+src_compile() {
+ emake V=1
+ [[ ${PV} == "9999" ]] && emake V=1 doc-man doc-html
+}
+
+src_test() {
+ # workaround parallel test failures
+ emake -j1 test
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-doc-man
+ dodoc doc/manual.html README.html NEWS.html
+ newbashcomp contrib/tig-completion.bash ${PN}
+
+ docinto examples
+ dodoc contrib/*.tigrc
+}