summaryrefslogtreecommitdiff
path: root/dev-vcs
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-04-02 15:36:26 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-04-02 15:36:39 +0200
commit09358d6ee22a5a53987ec6bb787c66460c1b0142 (patch)
tree7b1cc1304675fca985a5cc8be7c2f1004907df87 /dev-vcs
parent492e4989d3e4c1391862e8ba3ec880ef4a0510bf (diff)
downloadgentoo-09358d6ee22a5a53987ec6bb787c66460c1b0142.tar.gz
gentoo-09358d6ee22a5a53987ec6bb787c66460c1b0142.tar.xz
dev-vcs/cvs2svn: Bump to version 2.5.0
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/cvs2svn/Manifest1
-rw-r--r--dev-vcs/cvs2svn/cvs2svn-2.5.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-vcs/cvs2svn/Manifest b/dev-vcs/cvs2svn/Manifest
index d4739dafa52..aa05662402f 100644
--- a/dev-vcs/cvs2svn/Manifest
+++ b/dev-vcs/cvs2svn/Manifest
@@ -1 +1,2 @@
DIST cvs2svn-2.4.0.tar.gz 514891 BLAKE2B 0dd0d15ab28f96e56854295a789284a00ad8d172dbd849068fb05811a728f854d83b52856b6254ee0ac947425d972fb810b627aab95116040d4370bb98de6e0c SHA512 726fb8a3b3261eeb6d8097973f2741aa7a433f847bcef6701a6c0b7dc3d8fb5da1726e40f008d1dffac71791b953ddb9ade5db5809c98731d78e94da6465506a
+DIST cvs2svn-2.5.0.tar.gz 539332 BLAKE2B 54d70750c601c1d5c701f853686d958e9b8b92c4109d9294ec139d3cc8d4c9e102abed976fe9f845d0d0a1ccb65f504a08ef27f48bdf001254cf6e26087e50e2 SHA512 226972553c9d9cbae81c6e85079f4201944cf77ce68ebd6020ef2cd88bf457241739cef401c4bd3bf656b1992fbf84639b8df72d1921eee9d043fde94fba1c6a
diff --git a/dev-vcs/cvs2svn/cvs2svn-2.5.0.ebuild b/dev-vcs/cvs2svn/cvs2svn-2.5.0.ebuild
new file mode 100644
index 00000000000..ad033bc6bdb
--- /dev/null
+++ b/dev-vcs/cvs2svn/cvs2svn-2.5.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+FILEVER="49543"
+
+DESCRIPTION="Convert a CVS repository to a Subversion repository"
+HOMEPAGE="http://cvs2svn.tigris.org/"
+SRC_URI="http://cvs2svn.tigris.org/files/documents/1462/${FILEVER}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="bazaar git test"
+
+DEPEND=">=dev-vcs/subversion-1.0.9"
+RDEPEND="${DEPEND}
+ bazaar? ( >=dev-vcs/bzr-1.13[${PYTHON_USEDEP}] )
+ git? ( >=dev-vcs/git-1.5.4.4[${PYTHON_USEDEP}] )
+ dev-vcs/rcs"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ distutils-r1_src_prepare
+ python_fix_shebang .
+}
+
+src_compile() {
+ distutils-r1_src_compile
+ emake man
+}
+
+src_install() {
+ distutils-r1_src_install
+ insinto "/usr/share/${PN}"
+ doins -r contrib cvs2{svn,git,bzr}-example.options
+ doman *.1
+}
+
+python_test() {
+ # Need this because subversion is localized, but the tests aren't
+ export LC_ALL=C
+ "${PYTHON}" -W ignore run-tests.py
+}
+
+pkg_postinst() {
+ elog "Additional scripts and examples have been installed to:"
+ elog " /usr/share/${PN}/"
+}