summaryrefslogtreecommitdiff
path: root/dev-vcs
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-02-09 20:43:17 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-02-09 20:43:35 +0100
commit7de82b3cbafda3223ef41a5945ce70cccd184261 (patch)
tree3b63604d93025d522e0f3f0787f1284639292454 /dev-vcs
parentdbc5e9cfe45c9228e22ef2b73fb7a3b916bd7983 (diff)
downloadgentoo-7de82b3cbafda3223ef41a5945ce70cccd184261.tar.gz
gentoo-7de82b3cbafda3223ef41a5945ce70cccd184261.tar.xz
dev-vcs/git: Move patches into PATCHES array and get rid of epatch command.
Package-Manager: portage-2.2.27 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git/git-2.7.1.ebuild34
1 files changed, 19 insertions, 15 deletions
diff --git a/dev-vcs/git/git-2.7.1.ebuild b/dev-vcs/git/git-2.7.1.ebuild
index 71a1fb09676..a5175b98fd4 100644
--- a/dev-vcs/git/git-2.7.1.ebuild
+++ b/dev-vcs/git/git-2.7.1.ebuild
@@ -109,6 +109,20 @@ REQUIRED_USE="
python? ( ${PYTHON_REQUIRED_USE} )
"
+PATCHES=(
+ # bug #350330 - automagic CVS when we don't want it is bad.
+ "${FILESDIR}"/git-2.2.2-optional-cvs.patch
+
+ # install mediawiki perl modules also in vendor_dir
+ # hack, needs better upstream solution
+ "${FILESDIR}"/git-1.8.5-mw-vendor.patch
+
+ "${FILESDIR}"/git-2.2.0-svn-fe-linking.patch
+
+ # Bug #493306, where FreeBSD 10.x merged libiconv into its libc.
+ "${FILESDIR}"/git-2.5.1-freebsd-10.x-no-iconv.patch
+)
+
pkg_setup() {
if use subversion && has_version "dev-vcs/subversion[dso]"; then
ewarn "Per Gentoo bugs #223747, #238586, when subversion is built"
@@ -222,26 +236,16 @@ src_unpack() {
}
src_prepare() {
- # bug #350330 - automagic CVS when we don't want it is bad.
- epatch "${FILESDIR}"/git-2.2.2-optional-cvs.patch
-
- # install mediawiki perl modules also in vendor_dir
- # hack, needs better upstream solution
- epatch "${FILESDIR}"/git-1.8.5-mw-vendor.patch
-
# add experimental patches to improve mediawiki support
# see patches for origin
if use mediawiki-experimental ; then
- epatch "${FILESDIR}"/git-2.7.0-mediawiki-namespaces.patch
- epatch "${FILESDIR}"/git-2.7.0-mediawiki-subpages.patch
- epatch "${FILESDIR}"/git-2.7.0-mediawiki-500pages.patch
+ PATCHES+=(
+ "${FILESDIR}"/git-2.7.0-mediawiki-namespaces.patch
+ "${FILESDIR}"/git-2.7.0-mediawiki-subpages.patch
+ "${FILESDIR}"/git-2.7.0-mediawiki-500pages.patch
+ )
fi
- epatch "${FILESDIR}"/git-2.2.0-svn-fe-linking.patch
-
- # Bug #493306, where FreeBSD 10.x merged libiconv into its libc.
- epatch "${FILESDIR}"/git-2.5.1-freebsd-10.x-no-iconv.patch
-
default
sed -i \