summaryrefslogtreecommitdiff
path: root/eclass/kde5-functions.eclass
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2015-11-30 23:44:41 +0100
committerMichael Palimaka <kensington@gentoo.org>2015-12-03 01:38:14 +1100
commit8bcc8a35c3323c11a068d0ce00eea377b9a6570c (patch)
tree6fad0f23b08f81a0290a24a43424b9206c0c0e8f /eclass/kde5-functions.eclass
parent47d3b0de866b4f303fb5ca73a07f9457606c2b77 (diff)
downloadgentoo-8bcc8a35c3323c11a068d0ce00eea377b9a6570c.tar.gz
gentoo-8bcc8a35c3323c11a068d0ce00eea377b9a6570c.tar.xz
kde5-functions.eclass: Make punt_bogus_dep() case insensitive
Diffstat (limited to 'eclass/kde5-functions.eclass')
-rw-r--r--eclass/kde5-functions.eclass4
1 files changed, 2 insertions, 2 deletions
diff --git a/eclass/kde5-functions.eclass b/eclass/kde5-functions.eclass
index 74f6a02dcd9..8041452af25 100644
--- a/eclass/kde5-functions.eclass
+++ b/eclass/kde5-functions.eclass
@@ -229,7 +229,7 @@ punt_bogus_dep() {
local prefix=${1}
local dep=${2}
- pcregrep -Mn "(?s)find_package\s*\(\s*${prefix}.[^)]*?${dep}.*?\)" CMakeLists.txt > "${T}/bogus${dep}"
+ pcregrep -Mni "(?s)find_package\s*\(\s*${prefix}.[^)]*?${dep}.*?\)" CMakeLists.txt > "${T}/bogus${dep}"
# pcregrep returns non-zero on no matches/error
if [[ $? != 0 ]] ; then
@@ -243,7 +243,7 @@ punt_bogus_dep() {
sed -e "${first},${last}s/${dep}//" -i CMakeLists.txt || die
if [[ ${length} = 1 ]] ; then
- sed -e "/find_package\s*(\s*${prefix}\s*REQUIRED\s*COMPONENTS\s*)/d" -i CMakeLists.txt || die
+ sed -e "/find_package\s*(\s*${prefix}\s*REQUIRED\s*COMPONENTS\s*)/I d" -i CMakeLists.txt || die
fi
}