summaryrefslogtreecommitdiff
path: root/games-action/btanks
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2017-07-24 00:26:42 -0400
committerDavid Seifert <soap@gentoo.org>2017-07-30 11:09:50 +0200
commitddc1a4cfd09f5429575c3eba483995b22907d9ef (patch)
tree355adf6b9d3ccef047d957efcf2b6fe390cf5801 /games-action/btanks
parent3d3a1f91e942cf0860471eb4d3d621612061a1f0 (diff)
downloadgentoo-ddc1a4cfd09f5429575c3eba483995b22907d9ef.tar.gz
gentoo-ddc1a4cfd09f5429575c3eba483995b22907d9ef.tar.xz
games-action/btanks: Fix building with -Werror=terminate in GCC-6
Bug: https://bugs.gentoo.org/show_bug.cgi?id=609692 Package-Manager: Portage-2.3.6, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/5190
Diffstat (limited to 'games-action/btanks')
-rw-r--r--games-action/btanks/btanks-0.9.8083.ebuild5
-rw-r--r--games-action/btanks/files/btanks-0.9.8083-gcc6.patch34
2 files changed, 37 insertions, 2 deletions
diff --git a/games-action/btanks/btanks-0.9.8083.ebuild b/games-action/btanks/btanks-0.9.8083.ebuild
index c080022faa9..9da95ffb8f3 100644
--- a/games-action/btanks/btanks-0.9.8083.ebuild
+++ b/games-action/btanks/btanks-0.9.8083.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -28,7 +28,8 @@ src_prepare() {
rm -rf sdlx/gfx
epatch "${FILESDIR}"/${P}-scons-blows.patch \
"${FILESDIR}"/${P}-gcc46.patch \
- "${FILESDIR}"/${P}-gcc47.patch
+ "${FILESDIR}"/${P}-gcc47.patch \
+ "${FILESDIR}"/${P}-gcc6.patch
}
src_compile() {
diff --git a/games-action/btanks/files/btanks-0.9.8083-gcc6.patch b/games-action/btanks/files/btanks-0.9.8083-gcc6.patch
new file mode 100644
index 00000000000..5f11379d805
--- /dev/null
+++ b/games-action/btanks/files/btanks-0.9.8083-gcc6.patch
@@ -0,0 +1,34 @@
+Bug: https://bugs.gentoo.org/609692
+
+--- a/mrt/timespy.cpp
++++ b/mrt/timespy.cpp
+@@ -43,7 +43,7 @@
+ throw_io(("gettimeofday"));
+ }
+
+-TimeSpy::~TimeSpy() {
++TimeSpy::~TimeSpy() DTOR_NOEXCEPT {
+ struct timeval now;
+ if (gettimeofday(&now, NULL) == -1)
+ throw_io(("gettimeofday"));
+--- a/mrt/timespy.h
++++ b/mrt/timespy.h
+@@ -37,11 +37,17 @@
+ #include "fmt.h"
+ #include "export_mrt.h"
+
++#if __cplusplus >= 201103L
++#define DTOR_NOEXCEPT noexcept(false)
++#else
++#define DTOR_NOEXCEPT
++#endif
++
+ namespace mrt {
+ class MRTAPI TimeSpy {
+ public:
+ TimeSpy(const std::string &message);
+- ~TimeSpy();
++ ~TimeSpy() DTOR_NOEXCEPT;
+ private:
+ TimeSpy(const TimeSpy&);
+ const TimeSpy& operator=(const TimeSpy&);