summaryrefslogtreecommitdiff
path: root/games-action/descent3
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/descent3
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/descent3')
-rw-r--r--games-action/descent3/Manifest2
-rw-r--r--games-action/descent3/descent3-1.4.0b-r2.ebuild102
-rw-r--r--games-action/descent3/metadata.xml8
3 files changed, 112 insertions, 0 deletions
diff --git a/games-action/descent3/Manifest b/games-action/descent3/Manifest
new file mode 100644
index 00000000000..f183613e101
--- /dev/null
+++ b/games-action/descent3/Manifest
@@ -0,0 +1,2 @@
+DIST descent3-1.4.0a-x86.run 2736956 SHA256 fe894b1cbcb16ec813c368f16549c38a3cd65514494f0be0b3095e936c9f67fe
+DIST descent3-1.4.0b-x86.run 4504631 SHA256 4c56ab91c332b0ccdc052fa3dd1c3a72cda204724bc98429cda22379269720e1
diff --git a/games-action/descent3/descent3-1.4.0b-r2.ebuild b/games-action/descent3/descent3-1.4.0b-r2.ebuild
new file mode 100644
index 00000000000..d2221e24a52
--- /dev/null
+++ b/games-action/descent3/descent3-1.4.0b-r2.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils unpacker cdrom multilib games
+
+IUSE="nocd videos"
+DESCRIPTION="Descent 3 - 3-Dimensional indoor/outdoor spaceship combat"
+HOMEPAGE="http://www.lokigames.com/products/descent3/"
+SRC_URI="mirror://lokigames/${PN}/${PN}-1.4.0a-x86.run
+ mirror://lokigames/${PN}/${P}-x86.run"
+
+LICENSE="LOKI-EULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="strip"
+
+RDEPEND="sys-libs/glibc
+ media-libs/libsdl[abi_x86_32(-)]
+ media-libs/smpeg[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]"
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+pkg_setup() {
+ games_pkg_setup
+ if use videos ; then
+ ewarn "The installed game takes about 1.2GB of space!"
+ elif use nocd ; then
+ ewarn "The installed game takes about 510MB of space!"
+ else
+ ewarn "The installed game takes about 220MB of space!"
+ fi
+}
+
+src_unpack() {
+ if use videos ; then
+ cdrom_get_cds missions/d3.mn3 movies/level1.mve
+ else
+ cdrom_get_cds missions/d3.mn3
+ fi
+ mkdir -p "${S}"/{a,b} || die
+ cd "${S}"/a || die
+ unpack_makeself ${PN}-1.4.0a-x86.run
+ cd "${S}"/b || die
+ unpack_makeself ${P}-x86.run
+}
+
+src_install() {
+ einfo "Copying files... this may take a while..."
+ exeinto "${dir}"
+ doexe ${CDROM_ROOT}/bin/x86/glibc-2.1/{${PN},nettest}
+ insinto "${dir}"
+ doins ${CDROM_ROOT}/{FAQ.txt,README{,.mercenary},d3.hog,icon.{bmp,xpm}}
+
+ cd "${Ddir}" || die
+ # TODO: move this to src_unpack where it belongs
+ tar xzf ${CDROM_ROOT}/data.tar.gz || die
+ tar xzf ${CDROM_ROOT}/shared.tar.gz || die
+
+ if use nocd; then
+ doins -r ${CDROM_ROOT}/missions
+ fi
+
+ if use videos ; then
+ cdrom_load_next_cd
+ doins -r ${CDROM_ROOT}/movies
+ fi
+
+ cd "${S}"/a || die
+ bin/Linux/x86/loki_patch --verify patch.dat || die
+ bin/Linux/x86/loki_patch patch.dat "${Ddir}" >& /dev/null || die
+ cd "${S}"/b || die
+ bin/Linux/x86/loki_patch --verify patch.dat || die
+ bin/Linux/x86/loki_patch patch.dat "${Ddir}" >& /dev/null || die
+
+ # now, since these files are coming off a cd, the times/sizes/md5sums wont
+ # be different ... that means portage will try to unmerge some files (!)
+ # we run touch on ${D} so as to make sure portage doesnt do any such thing
+ find "${Ddir}" -exec touch '{}' +
+
+ games_make_wrapper descent3 ./descent3.dynamic "${dir}" "${dir}"
+ newicon ${CDROM_ROOT}/icon.xpm ${PN}.xpm
+
+ # Fix for 2.6 kernel crash
+ cd "${Ddir}" || die
+ ln -sf ppics.hog PPics.Hog
+
+ prepgamesdirs
+ make_desktop_entry ${PN} "Descent 3" ${PN}
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "To play the game run:"
+ elog " descent3"
+ echo
+}
diff --git a/games-action/descent3/metadata.xml b/games-action/descent3/metadata.xml
new file mode 100644
index 00000000000..cefc721b94c
--- /dev/null
+++ b/games-action/descent3/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+Descent 3 is a first-person 3-D action flight-sim which takes place in both indoor and outdoor arenas. The game was ported to Linux by the now defunct Loki Entertainment and is commercial software. You can still pick up a copy from Tuxgames (http://www.tuxgames.com), but supplies are limited, as the publisher is no longer in business.
+</longdescription>
+</pkgmetadata>