summaryrefslogtreecommitdiff
path: root/games-action/luola
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2017-01-25 16:33:05 -0600
committerAustin English <wizardedit@gentoo.org>2017-01-25 17:05:05 -0600
commite4e4dd8051becd49c7e4a6e87924adaf0f21be7c (patch)
treea0fa5b923d02da47c2800361285b18febe89c979 /games-action/luola
parenta27d7123ca199c7bc22b73d2874c0bb60c35d799 (diff)
downloadgentoo-e4e4dd8051becd49c7e4a6e87924adaf0f21be7c.tar.gz
gentoo-e4e4dd8051becd49c7e4a6e87924adaf0f21be7c.tar.xz
games-action/luola: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: Portage-2.3.2, Repoman-2.3.1
Diffstat (limited to 'games-action/luola')
-rw-r--r--games-action/luola/files/luola-1.3.2-underlink.patch4
-rw-r--r--games-action/luola/luola-1.3.2-r1.ebuild60
2 files changed, 62 insertions, 2 deletions
diff --git a/games-action/luola/files/luola-1.3.2-underlink.patch b/games-action/luola/files/luola-1.3.2-underlink.patch
index 5bf998177be..2c862bbc30d 100644
--- a/games-action/luola/files/luola-1.3.2-underlink.patch
+++ b/games-action/luola/files/luola-1.3.2-underlink.patch
@@ -1,5 +1,5 @@
---- src/Makefile.am.old 2011-06-17 08:41:40.882481147 +0200
-+++ src/Makefile.am 2011-06-17 08:41:58.497602372 +0200
+--- a/src/Makefile.am 2011-06-17 08:41:40.882481147 +0200
++++ b/src/Makefile.am 2011-06-17 08:41:58.497602372 +0200
@@ -2,7 +2,7 @@
bin_PROGRAMS = luola
diff --git a/games-action/luola/luola-1.3.2-r1.ebuild b/games-action/luola/luola-1.3.2-r1.ebuild
new file mode 100644
index 00000000000..d80fa6424fd
--- /dev/null
+++ b/games-action/luola/luola-1.3.2-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils autotools gnome2-utils
+
+DESCRIPTION="A 2D multiplayer arcade game resembling V-Wing"
+HOMEPAGE="https://freecode.com/projects/luola"
+SRC_URI="mirror://gentoo/${P}.tar.gz
+ mirror://gentoo/stdlevels-6.0.tar.gz
+ mirror://gentoo/nostalgia-1.2.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl[X,sound,joystick,video]
+ media-libs/sdl-gfx
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-underlink.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --enable-sound
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ insinto /usr/share/${PN}/levels
+ doins "${WORKDIR}"/*.{lev,png}
+ dodoc AUTHORS ChangeLog DATAFILE FAQ LEVELFILE README TODO \
+ RELEASENOTES.txt ../README.Nostalgia
+ newdoc ../README README.stdlevels
+ doicon -s 64 luola.png
+ make_desktop_entry luola Luola
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}