summaryrefslogtreecommitdiff
path: root/games-action/poopmup
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/poopmup
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/poopmup')
-rw-r--r--games-action/poopmup/Manifest1
-rw-r--r--games-action/poopmup/files/poopmup-1.2-freeglut.patch10
-rw-r--r--games-action/poopmup/files/poopmup-1.2-gcc43.patch42
-rw-r--r--games-action/poopmup/files/poopmup-1.2-ldflags.patch11
-rw-r--r--games-action/poopmup/metadata.xml8
-rw-r--r--games-action/poopmup/poopmup-1.2.ebuild61
6 files changed, 133 insertions, 0 deletions
diff --git a/games-action/poopmup/Manifest b/games-action/poopmup/Manifest
new file mode 100644
index 00000000000..4f2ea5a4948
--- /dev/null
+++ b/games-action/poopmup/Manifest
@@ -0,0 +1 @@
+DIST poopmup-1.2.tar.gz 1461794 SHA256 d2f1515c981d49e18fba6f6d7b4ab354d21def62587eab8dcb048c9eb8a7ff3b SHA512 1c9453ec7487b968dacf6b1bc000835fcd39d1b6f8a42c458ff4cce96a6b48881b11d7df1733fca21bfb213c18cb6f793075a59d4f8a856d06d27a9781c84e88 WHIRLPOOL 03caf2e84518121df17378aff3f9995d57e7c63bc25874e1a9ed2a98c9274ef3d85b0a3c930df0868676772225067a309596253feaa536a05bbf657923e37ce3
diff --git a/games-action/poopmup/files/poopmup-1.2-freeglut.patch b/games-action/poopmup/files/poopmup-1.2-freeglut.patch
new file mode 100644
index 00000000000..615558963ef
--- /dev/null
+++ b/games-action/poopmup/files/poopmup-1.2-freeglut.patch
@@ -0,0 +1,10 @@
+--- poopmup.cpp
++++ poopmup.cpp
+@@ -582,6 +582,7 @@
+ getConfiguration();
+ //Will overwrite the conf file params.
+ ParseCommandLine(argc, argv);
++ glutInit(&argc, argv);
+ InitializeGL(argc, argv);
+ InitializeWorld();
+ InitMenu();
diff --git a/games-action/poopmup/files/poopmup-1.2-gcc43.patch b/games-action/poopmup/files/poopmup-1.2-gcc43.patch
new file mode 100644
index 00000000000..da4a455673a
--- /dev/null
+++ b/games-action/poopmup/files/poopmup-1.2-gcc43.patch
@@ -0,0 +1,42 @@
+--- common.h
++++ common.h
+@@ -38,7 +38,7 @@
+ #define STDCALL
+ #endif
+
+-#include <iostream.h>
++#include <iostream>
+ #include "includes/base/myDisplayLists.h"
+ #include "myTimeStats.h"
+
+--- includes/base/myMatrix.h
++++ includes/base/myMatrix.h
+@@ -57,7 +57,7 @@
+ #include "my3dPoint.h"
+ #include "myVector.h"
+
+-#include <iostream.h>
++#include <iostream>
+ #include <math.h>
+
+ /**
+--- includes/osd/menu.h
++++ includes/osd/menu.h
+@@ -21,6 +21,7 @@
+ #define POOPMUP_MENU_H
+
+ #include <stdio.h>
++#include <cstring>
+ #include "../base/myColor.h"
+ #include "formElem/button.h"
+ #include "formElem/intSelector.h"
+--- includes/osd/onScreenDisplay.h
++++ includes/osd/onScreenDisplay.h
+@@ -21,6 +21,7 @@
+ #define ONSCREENDISPLAY_H
+
+ #include <stdio.h>
++#include <cstring>
+ #include "../base/my3dPoint.h"
+ #include "../base/myColor.h"
+
diff --git a/games-action/poopmup/files/poopmup-1.2-ldflags.patch b/games-action/poopmup/files/poopmup-1.2-ldflags.patch
new file mode 100644
index 00000000000..e831a4fc34d
--- /dev/null
+++ b/games-action/poopmup/files/poopmup-1.2-ldflags.patch
@@ -0,0 +1,11 @@
+--- Makefile.old 2010-10-01 00:05:06.000000000 +0200
++++ Makefile 2010-10-01 00:05:30.000000000 +0200
+@@ -7,7 +7,7 @@
+ OBJ =poopmup.o
+
+ all:
+- $(CC) $(SOURCE) -o $(OBJ) -lglut -lGL -lGLU -L/usr/X11R6/lib -lXmu -lXext -lXt -lXi -lX11
++ $(CC) $(LDFLAGS) $(SOURCE) -o $(OBJ) -lglut -lGL -lGLU -L/usr/X11R6/lib -lXmu -lXext -lXt -lXi -lX11
+
+
+ clean:
diff --git a/games-action/poopmup/metadata.xml b/games-action/poopmup/metadata.xml
new file mode 100644
index 00000000000..c06792ddfaa
--- /dev/null
+++ b/games-action/poopmup/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">poopmup</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-action/poopmup/poopmup-1.2.ebuild b/games-action/poopmup/poopmup-1.2.ebuild
new file mode 100644
index 00000000000..480e12749d1
--- /dev/null
+++ b/games-action/poopmup/poopmup-1.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils toolchain-funcs games
+
+DESCRIPTION="You are now free to fly around the city and poop on passers-by"
+HOMEPAGE="http://poopmup.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+RESTRICT="test"
+
+DEPEND="media-libs/freeglut
+ x11-libs/libXi
+ x11-libs/libXmu
+ virtual/opengl"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ sed -i \
+ -e "s:textures/:${GAMES_DATADIR}/${PN}/:" \
+ includes/textureLoader.h || die "sed failed"
+ sed -i \
+ -e "s:config/:${GAMES_SYSCONFDIR}/:" \
+ myConfig.h || die "sed failed"
+ sed -i \
+ -e '/clear/d' \
+ Makefile || die "sed failed" # bug #120907
+
+ epatch \
+ "${FILESDIR}"/${P}-freeglut.patch \
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
+ ecvs_clean
+}
+
+src_compile() {
+ emake CC="$(tc-getCXX) ${CFLAGS}"
+}
+
+src_install() {
+ newgamesbin poopmup.o poopmup
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins textures/*
+
+ insinto "${GAMES_SYSCONFDIR}"
+ doins config/*
+
+ dodoc README docs/*.doc
+ dohtml docs/userman.htm
+
+ prepgamesdirs
+}