summaryrefslogtreecommitdiff
path: root/games-action/spacetripper-demo/spacetripper-demo-1.ebuild
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/spacetripper-demo/spacetripper-demo-1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/spacetripper-demo/spacetripper-demo-1.ebuild')
-rw-r--r--games-action/spacetripper-demo/spacetripper-demo-1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/games-action/spacetripper-demo/spacetripper-demo-1.ebuild b/games-action/spacetripper-demo/spacetripper-demo-1.ebuild
new file mode 100644
index 00000000000..5ca58b39873
--- /dev/null
+++ b/games-action/spacetripper-demo/spacetripper-demo-1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils unpacker games
+
+MY_P="spacetripperdemo"
+DESCRIPTION="hardcore arcade shoot-em-up"
+HOMEPAGE="http://www.pompomgames.com/"
+SRC_URI="http://www.btinternet.com/~bongpig/${MY_P}.sh"
+
+LICENSE="POMPOM"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE=""
+RESTRICT="strip"
+
+RDEPEND="
+ >=virtual/opengl-7.0-r1[abi_x86_32(-)]
+ >=media-libs/libsdl-1.2.15-r4[abi_x86_32(-),X,video,joystick,opengl,sound]"
+
+S=${WORKDIR}
+
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
+
+QA_PREBUILT="${dir}/*"
+
+src_unpack() {
+ unpack_makeself
+}
+
+src_install() {
+ exeinto "${dir}"
+ doexe bin/x86/*
+ # Remove libSDL since we use the system version and our version doesn't
+ # have TEXTRELs in it.
+ rm -f "${Ddir}"/libSDL-1.2.so.0.0.5
+ sed -i -e "s:XYZZY:${dir}:" "${Ddir}/${MY_P}" || die
+
+ insinto "${dir}"
+ doins -r preview run styles README license.txt icon.xpm
+ newicon icon.xpm spacetripper-demo.png
+
+ games_make_wrapper spacetripper-demo ./spacetripperdemo "${dir}" "${dir}"
+ make_desktop_entry spacetripper-demo spacetripper-demo spacetripper-demo
+
+ prepgamesdirs
+}