summaryrefslogtreecommitdiff
path: root/games-action/xbomber
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/xbomber
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/xbomber')
-rw-r--r--games-action/xbomber/Manifest1
-rw-r--r--games-action/xbomber/files/xbomber-101-gcc4.patch11
-rw-r--r--games-action/xbomber/files/xbomber-101-ldflags.patch15
-rw-r--r--games-action/xbomber/files/xbomber-101-va_list.patch48
-rw-r--r--games-action/xbomber/metadata.xml5
-rw-r--r--games-action/xbomber/xbomber-101.ebuild45
6 files changed, 125 insertions, 0 deletions
diff --git a/games-action/xbomber/Manifest b/games-action/xbomber/Manifest
new file mode 100644
index 00000000000..46cde83192e
--- /dev/null
+++ b/games-action/xbomber/Manifest
@@ -0,0 +1 @@
+DIST xbomber-101.tgz 396707 SHA256 d2f127519b779f83e029be4a6dd0299d126505bbe49a9981d913ac10a4b3f640 SHA512 3f7259ad7f4bf3ec15997c187e354a5cb91cd19743003f480b4900caa2a888d977aa3d6f1e96411666bb0a971fcf17593b76fde9804bb6e1e1b0dab9d4b6abb2 WHIRLPOOL 70f5973bc69d20f2bbf7b3190b9eeac75119dc4765944bb668b6241063c237c2d8b1474dcbf049f896d7d8d5a92524c0c02bd3b1719360103a037fb67049e353
diff --git a/games-action/xbomber/files/xbomber-101-gcc4.patch b/games-action/xbomber/files/xbomber-101-gcc4.patch
new file mode 100644
index 00000000000..8a5a063c614
--- /dev/null
+++ b/games-action/xbomber/files/xbomber-101-gcc4.patch
@@ -0,0 +1,11 @@
+--- bomber.c.old 2006-01-28 12:06:34.000000000 -0700
++++ bomber.c 2006-01-28 12:06:46.000000000 -0700
+@@ -1699,7 +1699,7 @@
+ }
+ void addtail(void *header,void *entry)
+ {
+- while(((list *)header)->next) ((list *)header)=((list *)header)->next;
++ while(((list *)header)->next) header=((list *)header)->next;
+ ((list *)header)->next=entry;
+ ((list *)entry)->next=0;
+ }
diff --git a/games-action/xbomber/files/xbomber-101-ldflags.patch b/games-action/xbomber/files/xbomber-101-ldflags.patch
new file mode 100644
index 00000000000..ebde16412b5
--- /dev/null
+++ b/games-action/xbomber/files/xbomber-101-ldflags.patch
@@ -0,0 +1,15 @@
+--- Makefile.old 2010-10-19 09:17:43.000000000 +0200
++++ Makefile 2010-10-19 09:18:12.000000000 +0200
+@@ -1,10 +1,8 @@
+-CFLAGS = -O3
+-
+ bomber: bomber.o x.o sound.o matcher
+- $(CC) -o bomber bomber.o x.o sound.o -lX11 -L/usr/X11R6/lib/
++ $(CC) $(CFLAGS) $(LDFLAGS) -o bomber bomber.o x.o sound.o -lX11 -L/usr/X11R6/lib/
+
+ matcher: matcher.c
+- $(CC) matcher.c -o matcher
++ $(CC) $(CFLAGS) $(LDFLAGS) matcher.c -o matcher
+
+ bomber.o: bomber.c bomber.h
+
diff --git a/games-action/xbomber/files/xbomber-101-va_list.patch b/games-action/xbomber/files/xbomber-101-va_list.patch
new file mode 100644
index 00000000000..cd15b84b00e
--- /dev/null
+++ b/games-action/xbomber/files/xbomber-101-va_list.patch
@@ -0,0 +1,48 @@
+--- bomber.c.orig 2005-11-06 16:50:04.000000000 +0100
++++ bomber.c 2005-11-06 16:47:35.000000000 +0100
+@@ -1,5 +1,6 @@
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <stdarg.h>
+ #include <unistd.h>
+ #include <string.h>
+ #include <sys/uio.h>
+@@ -626,8 +627,11 @@
+ void scrprintf(char *str,...)
+ {
+ char output[256],*p,*p2;
++va_list ap;
+
+- vsprintf(output,str,&str+1);
++ va_start(ap, str);
++ vsprintf(output,str,ap);
++ va_end(ap);
+ p=output;
+ for(;;)
+ {
+@@ -653,8 +657,11 @@
+ void bigscrprintf(char *str,...)
+ {
+ char output[256],*p,*p2;
++va_list ap;
+
+- vsprintf(output,str,&str+1);
++ va_start(ap, str);
++ vsprintf(output,str,ap);
++ va_end(ap);
+ p=output;
+ for(;;)
+ {
+@@ -1873,8 +1880,11 @@
+ additem(char *item,...)
+ {
+ char output[256];
++va_list ap;
+
+- vsprintf(output,item,&item+1);
++ va_start(ap, item);
++ vsprintf(output,item,ap);
++ va_end(ap);
+ if(menunum<0)
+ menutitle=menuput;
+ else
diff --git a/games-action/xbomber/metadata.xml b/games-action/xbomber/metadata.xml
new file mode 100644
index 00000000000..d3c2cc926f0
--- /dev/null
+++ b/games-action/xbomber/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-action/xbomber/xbomber-101.ebuild b/games-action/xbomber/xbomber-101.ebuild
new file mode 100644
index 00000000000..a191da65544
--- /dev/null
+++ b/games-action/xbomber/xbomber-101.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils games
+
+DESCRIPTION="Bomberman clone w/multiplayer support"
+HOMEPAGE="http://www.xdr.com/dash/bomber.html"
+SRC_URI="http://www.xdr.com/dash/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e "/^CC/d" \
+ -e 's/gcc/$(CC)/g' \
+ -e "s:X386:X11R6:" \
+ Makefile \
+ || die "sed failed"
+ sed -i \
+ -e "s:data/%s:${GAMES_DATADIR}/${PN}/%s:" bomber.c \
+ || die "sed failed"
+ sed -i \
+ -e "s:=\"data\":=\"${GAMES_DATADIR}/${PN}\":" sound.c \
+ || die "sed failed"
+ epatch \
+ "${FILESDIR}"/${P}-va_list.patch \
+ "${FILESDIR}"/${P}-gcc4.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
+}
+
+src_install() {
+ dogamesbin matcher bomber
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data/*
+ dodoc README Changelog
+ prepgamesdirs
+}