summaryrefslogtreecommitdiff
path: root/games-arcade/conveysdl
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/conveysdl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/conveysdl')
-rw-r--r--games-arcade/conveysdl/Manifest1
-rw-r--r--games-arcade/conveysdl/conveysdl-1.3.ebuild55
-rw-r--r--games-arcade/conveysdl/files/conveysdl-1.3-arrays.patch29
-rw-r--r--games-arcade/conveysdl/files/conveysdl-1.3-speed.patch56
-rw-r--r--games-arcade/conveysdl/metadata.xml5
5 files changed, 146 insertions, 0 deletions
diff --git a/games-arcade/conveysdl/Manifest b/games-arcade/conveysdl/Manifest
new file mode 100644
index 00000000000..3dc75202c65
--- /dev/null
+++ b/games-arcade/conveysdl/Manifest
@@ -0,0 +1 @@
+DIST conveysdl.1.3.tar 429568 SHA256 d0de3f8435b6189d2f40fbe5a28f903fbd46d94b53daf10efa53b879346c81cf SHA512 fe6f91cdd63ae1019cb99613618e44ceeddb4080ad5e50bd8ce0abf27e057617d3658a29b2faf668cbc3b0887f1a4a05cadadb060f69d850c3d85c9e7190dd8a WHIRLPOOL 3a4de5f5305f44626afd9aef5365b1048fb4972593cf31d3ccff3d9d57acd0fe4304eeaec7b4dd0b005064ef038d87a0a2eb3041fb994df53de534ef997b0f8c
diff --git a/games-arcade/conveysdl/conveysdl-1.3.ebuild b/games-arcade/conveysdl/conveysdl-1.3.ebuild
new file mode 100644
index 00000000000..76e33015e9e
--- /dev/null
+++ b/games-arcade/conveysdl/conveysdl-1.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs games
+
+DESCRIPTION="Guide the blob along the conveyer belt collecting the red blobs"
+HOMEPAGE="http://www.cloudsprinter.com/software/conveysdl/"
+SRC_URI="http://www.cloudsprinter.com/software/conveysdl/${P/-/.}.tar"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,video]
+ media-libs/sdl-mixer"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}
+
+src_prepare() {
+ # Incomplete readme
+ sed -i \
+ -e 's:I k:use -nosound to disable sound\n\nI k:' \
+ readme || die
+
+ sed -i \
+ -e 's:SDL_Mi:SDL_mi:' \
+ main.c || die
+
+ epatch \
+ "${FILESDIR}"/${P}-arrays.patch \
+ "${FILESDIR}"/${P}-speed.patch
+}
+
+src_compile() {
+ emake main \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} $(sdl-config --cflags) \
+ -DDATA_PREFIX=\\\"${GAMES_DATADIR}/${PN}/\\\" \
+ -DENABLE_SOUND" \
+ LDLIBS="-lSDL_mixer $(sdl-config --libs)"
+}
+
+src_install() {
+ newgamesbin main ${PN}
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r gfx sounds levels
+ newicon gfx/jblob.bmp ${PN}.bmp
+ make_desktop_entry ${PN} Convey /usr/share/pixmaps/${PN}.bmp
+ dodoc readme
+ prepgamesdirs
+}
diff --git a/games-arcade/conveysdl/files/conveysdl-1.3-arrays.patch b/games-arcade/conveysdl/files/conveysdl-1.3-arrays.patch
new file mode 100644
index 00000000000..a3894e58d3d
--- /dev/null
+++ b/games-arcade/conveysdl/files/conveysdl-1.3-arrays.patch
@@ -0,0 +1,29 @@
+--- main.c.org 2010-07-28 13:16:20.552161148 +0300
++++ main.c 2010-07-29 20:43:14.714543259 +0300
+@@ -22,7 +22,7 @@
+
+ SDL_Surface *bletters;
+ SDL_Surface *letters[100];
+-SDL_Surface *tiles[9];
++SDL_Surface *tiles[10];
+ SDL_Surface *btiles;
+ SDL_Surface *blob;
+ SDL_Surface *jblob;
+@@ -51,7 +51,7 @@
+ FILE *file_ptr;
+
+
+-int bpointx,bpointy,pointx,pointy,jug,death,goose,jump,jumpf,blibs,spr[1000][8],leveldone,level,lives,totallevels,blobx[7],bloby[7],blobp[7],score,bak,bok,buk,bik,start,blibo,blibs,die,jumpoo=12,speed=4,arse,highscore;
++int bpointx,bpointy,pointx,pointy,jug,death,goose,jump,jumpf,blibs,spr[1000][8],leveldone,level,lives,totallevels,blobx[8],bloby[8],blobp[8],score,bak,bok,buk,bik,start,blibo,blibs,die,jumpoo=12,speed=4,arse,highscore;
+ /* Keys */
+ int quit = 0;
+ int spacebar = 0;
+@@ -452,7 +452,7 @@
+ static void info(void)
+ {
+ int monkey=70,munk;
+- char scoremonkey[10];
++ char scoremonkey[16];
+ if (lives>1) {
+ for (munk=1 ; munk<lives ; munk++ )
+ {
diff --git a/games-arcade/conveysdl/files/conveysdl-1.3-speed.patch b/games-arcade/conveysdl/files/conveysdl-1.3-speed.patch
new file mode 100644
index 00000000000..2b5a6205650
--- /dev/null
+++ b/games-arcade/conveysdl/files/conveysdl-1.3-speed.patch
@@ -0,0 +1,56 @@
+--- org/main.c 2010-07-30 10:41:21.392783010 +0300
++++ main.c 2010-07-30 10:44:35.791690958 +0300
+@@ -52,6 +52,7 @@
+
+
+ int bpointx,bpointy,pointx,pointy,jug,death,goose,jump,jumpf,blibs,spr[1000][8],leveldone,level,lives,totallevels,blobx[8],bloby[8],blobp[8],score,bak,bok,buk,bik,start,blibo,blibs,die,jumpoo=12,speed=4,arse,highscore;
++int realspeed;
+ /* Keys */
+ int quit = 0;
+ int spacebar = 0;
+@@ -140,6 +141,7 @@
+ char path[256],jib[50];
+ int lvspx,lvspy;
+ bpointx=200;bpointy=400;pointx=200;pointy=400;jug=1;death=0;jump=0;jumpf=0;jug=0;blibs=0;blibo=0;die=0;speed=4;
++ realspeed=speed;
+ strcpy(path, DATA_PREFIX);
+ sprintf(jib,"levels/level%d",level);
+ strcat(path, jib);
+@@ -212,15 +214,16 @@
+ if (jumpf==jumpoo) { jump=0; }
+ if (jumpf==jumpoo*2) { jumpf=0; }
+ }
+- score+=speed;
++ score+=realspeed;
+ /*crap*/
+ }
+
+ static void plotfloor(void)
+ {
++ if (bpointy==400) realspeed=speed;
+ int nob,nx,nobx=48,ek,ej,el;
+- bpointx-=speed*2;
+- bpointy+=speed;
++ bpointx-=realspeed*2;
++ bpointy+=realspeed;
+ pointx=bpointx;
+ pointy=bpointy;
+ imageplot(bb, blobx[6], bloby[6] );
+@@ -542,7 +545,7 @@
+ }
+ while ( jump_down==0 );
+ leveldone=3;
+- speed=4;
++ speed=4; realspeed=speed;
+ blankscreen();
+ }
+
+@@ -563,7 +566,7 @@
+ if (quit>0) break;
+ }
+ while ( jump_down==0 );
+- speed=4;
++ speed=4; realspeed=speed;
+ lives+=1;
+ level+=1;
+ getlevel();
diff --git a/games-arcade/conveysdl/metadata.xml b/games-arcade/conveysdl/metadata.xml
new file mode 100644
index 00000000000..d3c2cc926f0
--- /dev/null
+++ b/games-arcade/conveysdl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>