summaryrefslogtreecommitdiff
path: root/games-arcade/grande-KXL
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-16 22:18:36 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-16 22:26:44 +0200
commitb4a70d4715f763e2a3296d28ec7c0367214965e6 (patch)
tree3550f72e18f6f2083b2706cd16daaad0a4aad8eb /games-arcade/grande-KXL
parent8480f8e44558232d10b6890d06796610d7d6d1d6 (diff)
downloadgentoo-b4a70d4715f763e2a3296d28ec7c0367214965e6.tar.gz
gentoo-b4a70d4715f763e2a3296d28ec7c0367214965e6.tar.xz
games-arcade/grande-KXL: Stop using games.eclass
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'games-arcade/grande-KXL')
-rw-r--r--games-arcade/grande-KXL/grande-KXL-0.6-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-arcade/grande-KXL/grande-KXL-0.6-r1.ebuild b/games-arcade/grande-KXL/grande-KXL-0.6-r1.ebuild
new file mode 100644
index 00000000000..b256aa38420
--- /dev/null
+++ b/games-arcade/grande-KXL/grande-KXL-0.6-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools desktop
+
+DESCRIPTION="ZANAC type game"
+HOMEPAGE="http://triring.net/ps2linux/games/kxl/kxlgames.html"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-games/KXL"
+RDEPEND="${DEPEND}
+ media-fonts/font-adobe-100dpi
+"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/${P}-{configure.in,cflags}.patch
+ mv configure.{in,ac}
+ rm aclocal.m4
+ eautoreconf
+}
+
+src_install() {
+ dodir /var/lib
+ default
+ newicon src/bmp/boss1.bmp ${PN}.bmp
+ make_desktop_entry grande Grande /usr/share/pixmaps/${PN}.bmp
+}