summaryrefslogtreecommitdiff
path: root/games-arcade/kajaani-kombat
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/kajaani-kombat
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/kajaani-kombat')
-rw-r--r--games-arcade/kajaani-kombat/Manifest1
-rw-r--r--games-arcade/kajaani-kombat/files/0.7-makefile.patch22
-rw-r--r--games-arcade/kajaani-kombat/files/kajaani-kombat-0.7-ldflags.patch11
-rw-r--r--games-arcade/kajaani-kombat/kajaani-kombat-0.7.ebuild44
-rw-r--r--games-arcade/kajaani-kombat/metadata.xml5
5 files changed, 83 insertions, 0 deletions
diff --git a/games-arcade/kajaani-kombat/Manifest b/games-arcade/kajaani-kombat/Manifest
new file mode 100644
index 00000000000..208de57dc78
--- /dev/null
+++ b/games-arcade/kajaani-kombat/Manifest
@@ -0,0 +1 @@
+DIST kajaani-kombat-0.7.tar.gz 1805504 SHA256 ec67316b8f5823a8b4d2097045be574aae805e40a8d3640e3ad205b073234f83 SHA512 84f6923b73c9529fa600c533b5a3de9ea9411f81060c5ad9fb85346fa17c9cb70bf6ba8222319e123372b01286a11b40bb355e8ef8c9bec95cd98f4d0e0460cb WHIRLPOOL b65ccc6171ab77416c1dd7bc54e89159f84089f38cfb510949e753c27bfbc13653cac3a0910ed48f2822eb0840203ca7a1353f8fe2a5603f3b6ad382994162f1
diff --git a/games-arcade/kajaani-kombat/files/0.7-makefile.patch b/games-arcade/kajaani-kombat/files/0.7-makefile.patch
new file mode 100644
index 00000000000..704bb95c1d1
--- /dev/null
+++ b/games-arcade/kajaani-kombat/files/0.7-makefile.patch
@@ -0,0 +1,22 @@
+--- Makefile.orig 2005-02-28 22:55:55.000000000 -0500
++++ Makefile 2005-02-28 22:58:45.000000000 -0500
+@@ -39,8 +39,8 @@
+ endif
+ ## UNIX RELEASE (default option)
+ ifeq ($(sys), )
+- MEDIA=-D MEDIA_PATH=\"./\"
+- DEBUG= -O $(MEDIA)
++ MEDIA=-D MEDIA_PATH=\"GENTOODIR\"
++ DEBUG= $(CFLAGS) $(MEDIA)
+ endif
+
+
+@@ -55,7 +55,7 @@
+
+ server_objs = game_obj.o terrain.o msg.o game_server.o server_main.o coord.o block.o connects.o player.o config.o
+
+-CXXFLAGS=`sdl-config --cflags` -Wall $(DEBUG)
++CXXFLAGS+=`sdl-config --cflags` $(MEDIA)
+
+ all: client
+
diff --git a/games-arcade/kajaani-kombat/files/kajaani-kombat-0.7-ldflags.patch b/games-arcade/kajaani-kombat/files/kajaani-kombat-0.7-ldflags.patch
new file mode 100644
index 00000000000..c575ff1ef57
--- /dev/null
+++ b/games-arcade/kajaani-kombat/files/kajaani-kombat-0.7-ldflags.patch
@@ -0,0 +1,11 @@
+--- Makefile.old 2010-10-15 15:48:06.000000000 +0200
++++ Makefile 2010-10-15 15:48:18.000000000 +0200
+@@ -85,7 +85,7 @@
+ client_net.o: client_net.h client_net.cpp globals.h monitor_queue.h msg.h
+
+ client: $(client_objs)
+- $(CXX) $(client_objs) -o kajaani-kombat $(client_libs)
++ $(CXX) $(LDFLAGS) $(client_objs) -o kajaani-kombat $(client_libs)
+ server: $(server_objs)
+ $(CXX) $(server_objs) -o kajaani-kombat-server $(server_libs)
+
diff --git a/games-arcade/kajaani-kombat/kajaani-kombat-0.7.ebuild b/games-arcade/kajaani-kombat/kajaani-kombat-0.7.ebuild
new file mode 100644
index 00000000000..64048349485
--- /dev/null
+++ b/games-arcade/kajaani-kombat/kajaani-kombat-0.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="A rampart-like game set in space"
+HOMEPAGE="http://kombat.kajaani.net/"
+SRC_URI="http://kombat.kajaani.net/dl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,video]
+ media-libs/sdl-net
+ media-libs/sdl-image[png]
+ media-libs/sdl-ttf
+ media-libs/sdl-mixer[vorbis]
+ sys-libs/ncurses
+ sys-libs/readline:0"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-makefile.patch" \
+ "${FILESDIR}"/${P}-ldflags.patch
+ sed -i \
+ -e "s:GENTOODIR:${GAMES_DATADIR}/${PN}/:" \
+ Makefile || die
+ sed -i \
+ -e 's/IMG_Load/img_load/' \
+ gui_screens.cpp || die
+}
+
+src_install() {
+ dogamesbin kajaani-kombat
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins *.{png,ttf,ogg}
+ dodoc AUTHORS ChangeLog README
+ doman kajaani-kombat.6
+ prepgamesdirs
+}
diff --git a/games-arcade/kajaani-kombat/metadata.xml b/games-arcade/kajaani-kombat/metadata.xml
new file mode 100644
index 00000000000..d3c2cc926f0
--- /dev/null
+++ b/games-arcade/kajaani-kombat/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>