summaryrefslogtreecommitdiff
path: root/games-arcade/tomatoes
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/tomatoes
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/tomatoes')
-rw-r--r--games-arcade/tomatoes/Manifest2
-rw-r--r--games-arcade/tomatoes/files/tomatoes-1.55-c_str.patch24
-rw-r--r--games-arcade/tomatoes/files/tomatoes-1.55-gcc43.patch14
-rw-r--r--games-arcade/tomatoes/files/tomatoes-1.55-underlink.patch38
-rw-r--r--games-arcade/tomatoes/metadata.xml8
-rw-r--r--games-arcade/tomatoes/tomatoes-1.55-r2.ebuild63
6 files changed, 149 insertions, 0 deletions
diff --git a/games-arcade/tomatoes/Manifest b/games-arcade/tomatoes/Manifest
new file mode 100644
index 00000000000..c3a9ac76332
--- /dev/null
+++ b/games-arcade/tomatoes/Manifest
@@ -0,0 +1,2 @@
+DIST tomatoes-linux-1.5.tar.bz2 8807421 SHA256 69a3af1994cb58409be9b469e1aa4bdb91c405d99071c7431526640ec53d1300 SHA512 517f592bb3c3fb43cb740c58011f06b7a71c96eaff74ce1088db8dbd4aafa3463bba516547cd010e9ef2ca947fd36962c3d13ece6e979cab8adf01ffa991c308 WHIRLPOOL 62fd7eca64cd4ddf41de8a02fb80c3f114ff69f3b322f7f904592dca6109fba3856df1cd6bbb9162a22f78dd98e7c353756f1b5682f2128e5cc4f64e7c239001
+DIST tomatoes-linux-src-1.55.tar.bz2 62947 SHA256 126d001532ee5b81cc95e1a86a274d11669b8c8f65c8235ae2e9b8fbdfab4a60 SHA512 b5a6287659746179f0418630c55d34dc34897b532687007386b0b540ec728cc2492813f0d454314994a26a3629a24c802630085f64b969d1e6ea9ec936f5fe35 WHIRLPOOL 845ad2e84ad035d2f678c8465360439f057a323a020e01cd20f19fc5fb643b7372a963afdbe0b717edd230e3d7eb5f922a7fcc16affe4ec7ccd3d3696a4955ae
diff --git a/games-arcade/tomatoes/files/tomatoes-1.55-c_str.patch b/games-arcade/tomatoes/files/tomatoes-1.55-c_str.patch
new file mode 100644
index 00000000000..dd6927e5415
--- /dev/null
+++ b/games-arcade/tomatoes/files/tomatoes-1.55-c_str.patch
@@ -0,0 +1,24 @@
+--- src/config.cpp.orig 2004-09-27 11:35:48.000000000 +0200
++++ src/config.cpp 2006-02-13 00:00:01.000000000 +0100
+@@ -78,6 +78,7 @@
+ // makefile.
+ char *get_config_location(bool write) {
+ #ifdef LINUX
++ static char *config_path = NULL;
+ // Get the path to the config file
+ string tmp = get_tomatoes_dir() + "config.cfg";
+
+@@ -90,8 +91,11 @@
+ }
+ fclose(ftest);
+ }
+-
+- return (char*)tmp.c_str();
++ if (!config_path) {
++ config_path = new char[tmp.length()+1];
++ strcpy(config_path,tmp.c_str());
++ }
++ return config_path;
+ #endif
+
+ // Return the CONFIG_DIR
diff --git a/games-arcade/tomatoes/files/tomatoes-1.55-gcc43.patch b/games-arcade/tomatoes/files/tomatoes-1.55-gcc43.patch
new file mode 100644
index 00000000000..cd85e31e593
--- /dev/null
+++ b/games-arcade/tomatoes/files/tomatoes-1.55-gcc43.patch
@@ -0,0 +1,14 @@
+--- src/config.cpp
++++ src/config.cpp
+@@ -27,8 +27,9 @@
+
+ *************************************************************************/
+
+-#include <stdio.h>
+-#include <stdlib.h>
++#include <cstring>
++#include <cstdio>
++#include <cstdlib>
+ #include "config.h"
+ #include "init.h"
+
diff --git a/games-arcade/tomatoes/files/tomatoes-1.55-underlink.patch b/games-arcade/tomatoes/files/tomatoes-1.55-underlink.patch
new file mode 100644
index 00000000000..c028c79ba4a
--- /dev/null
+++ b/games-arcade/tomatoes/files/tomatoes-1.55-underlink.patch
@@ -0,0 +1,38 @@
+--- makefile.old 2011-06-18 17:35:38.947020335 +0200
++++ makefile 2011-06-18 17:37:42.337811088 +0200
+@@ -48,7 +47,7 @@
+ LDFLAGS = `sdl-config --libs` -lSDL_image -lSDL_mixer -lGL -lGLU -pg
+ else
+ CFLAGS = -MMD -O3 -march=$(MARCH) -Wall $(SDL_FLAGS)
+-LDFLAGS = `sdl-config --libs` -lSDL_image -lSDL_mixer -lGL -lGLU -s
++LDLIBS = `sdl-config --libs` -lSDL_image -lSDL_mixer -lGL -lGLU -lm
+ endif
+ endif
+
+@@ -58,7 +57,7 @@
+ OBJS := $(subst src/,obj/,$(OBJS))
+
+ # Include directories
+-INCLUDES = -I./include
++INCLUDES = -I./include $(SDL_FLAGS)
+
+
+ # Targets
+@@ -69,7 +68,7 @@
+ -include $(DEPS)
+
+ $(TARGET): $(OBJS)
+- $(CC) -o $(TARGET) $(OBJS) $(LDFLAGS)
++ $(CXX) -o $(TARGET) $(OBJS) $(LDFLAGS) $(LDLIBS)
+
+ clean:
+ rm -f $(OBJS) $(TARGET)
+@@ -80,7 +79,7 @@
+ rebuild: veryclean all
+
+ obj/%.o: src/%.cpp
+- $(CC) $(CFLAGS) $(INCLUDES) $(DIR_DEFINES) -c $< -o $@
++ $(CXX) $(CXXFLAGS) $(INCLUDES) $(DIR_DEFINES) -c $< -o $@
+
+ # Compress the exe with UPX
+ compress: $(TARGET)
diff --git a/games-arcade/tomatoes/metadata.xml b/games-arcade/tomatoes/metadata.xml
new file mode 100644
index 00000000000..50b7cfeb4fb
--- /dev/null
+++ b/games-arcade/tomatoes/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">tomatoes</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-arcade/tomatoes/tomatoes-1.55-r2.ebuild b/games-arcade/tomatoes/tomatoes-1.55-r2.ebuild
new file mode 100644
index 00000000000..bb9334beeac
--- /dev/null
+++ b/games-arcade/tomatoes/tomatoes-1.55-r2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DATA_PV=1.5
+DESCRIPTION="How many tomatoes can you smash in ten short minutes?"
+HOMEPAGE="http://tomatoes.sourceforge.net/about.html"
+SRC_URI="mirror://sourceforge/tomatoes/tomatoes-linux-src-${PV}.tar.bz2
+ mirror://sourceforge/tomatoes/tomatoes-linux-${DATA_PV}.tar.bz2"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="amd64 ia64 ppc ~ppc64 x86"
+IUSE=""
+
+DEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl[sound,video]
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-mixer[mod]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ mv ../tomatoes-1.5/* . || die "mv failed"
+ mv icon.png ${PN}.png
+
+ epatch \
+ "${FILESDIR}"/${P}-c_str.patch \
+ "${FILESDIR}"/${P}-underlink.patch \
+ "${FILESDIR}"/${P}-gcc43.patch
+
+ sed -i \
+ -e "/^MPKDIR = /s:./:${GAMES_DATADIR}/${PN}/:" \
+ -e "/^MUSICDIR = /s:./music/:${GAMES_DATADIR}/${PN}/music/:" \
+ -e "/^HISCOREDIR = /s:./:${GAMES_STATEDIR}/${PN}/:" \
+ -e "/^CONFIGDIR = /s:./:${GAMES_SYSCONFDIR}/${PN}/:" \
+ -e "/^OVERRIDEDIR = /s:./data/:${GAMES_DATADIR}/${PN}/data/:" \
+ makefile \
+ || die "sed failed"
+}
+
+src_install() {
+ dogamesbin tomatoes
+ dodoc README README-src
+
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r tomatoes.mpk music
+
+ doicon ${PN}.png
+ make_desktop_entry tomatoes "I Have No Tomatoes"
+
+ dodir "${GAMES_STATEDIR}"/${PN}
+ touch "${D}${GAMES_STATEDIR}"/${PN}/hiscore.lst || die "touch failed"
+ fperms 660 "${GAMES_STATEDIR}"/${PN}/hiscore.lst
+
+ insinto "${GAMES_SYSCONFDIR}"/${PN}
+ doins config.cfg
+
+ prepgamesdirs
+}