summaryrefslogtreecommitdiff
path: root/games-arcade/vor
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/vor
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/vor')
-rw-r--r--games-arcade/vor/Manifest1
-rw-r--r--games-arcade/vor/files/vor-0.5.5-underlink.patch26
-rw-r--r--games-arcade/vor/metadata.xml5
-rw-r--r--games-arcade/vor/vor-0.5.5.ebuild47
4 files changed, 79 insertions, 0 deletions
diff --git a/games-arcade/vor/Manifest b/games-arcade/vor/Manifest
new file mode 100644
index 00000000000..c17903091bb
--- /dev/null
+++ b/games-arcade/vor/Manifest
@@ -0,0 +1 @@
+DIST vor-0.5.5.tar.bz2 239291 SHA256 ead1b9786741e26d37ff7c5185b7fe1e91f90f76ebed3785225312e323b7c7da SHA512 a4de43699b78adfe28bbd773cd9f9d1e3ee50b51b4e1848ff1baf836f6242d8391a304445994ca669eab13acbd2dd3ae49f0665bdb07d19c7a1674e0dde9bfbd WHIRLPOOL d0a63aa4b0c42e234593ed9ba09017ef3ab1a00de8ba8580dffefcd88ea0d09c8bc4e1d7edf6ef10cee319d1c17db9fef024aa6ffb495462cc97bf90ad8dbc46
diff --git a/games-arcade/vor/files/vor-0.5.5-underlink.patch b/games-arcade/vor/files/vor-0.5.5-underlink.patch
new file mode 100644
index 00000000000..0645c569573
--- /dev/null
+++ b/games-arcade/vor/files/vor-0.5.5-underlink.patch
@@ -0,0 +1,26 @@
+--- Makefile.in
++++ Makefile.in
+@@ -43,7 +43,7 @@
+ SDL_CFLAGS := @SDL_CFLAGS@
+ SDL_LIBS := @SDL_LIBS@
+
+-ldflags := $(SDL_LIBS) -lSDL_image -lSDL_mixer $(LDFLAGS)
++ldflags := $(LIBS) $(SDL_LIBS) $(LDFLAGS)
+ cflags := -I. $(SDL_CFLAGS) $(paths) $(CFLAGS)
+
+ my_objects := args.@OBJEXT@ dust.@OBJEXT@ file.@OBJEXT@ mt.@OBJEXT@ rocks.@OBJEXT@ score.@OBJEXT@ sprite.@OBJEXT@ sound.@OBJEXT@ autopilot.@OBJEXT@
+
+--- configure.ac
++++ configure.ac
+@@ -12,6 +12,11 @@
+ AC_PROG_MAKE_SET
+
+ # Checks for libraries.
++dnl Check for libm for sqrt()
++AC_SEARCH_LIBS([sqrt], [m], [], [
++ AC_MSG_ERROR([unable to find the sqrt() function])
++])
++
+ AC_CHECK_LIB([SDL_image], [IMG_LoadPNG_RW])
+ AC_CHECK_LIB([SDL_mixer], [Mix_OpenAudio])
+
diff --git a/games-arcade/vor/metadata.xml b/games-arcade/vor/metadata.xml
new file mode 100644
index 00000000000..d3c2cc926f0
--- /dev/null
+++ b/games-arcade/vor/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-arcade/vor/vor-0.5.5.ebuild b/games-arcade/vor/vor-0.5.5.ebuild
new file mode 100644
index 00000000000..381a9c5eb49
--- /dev/null
+++ b/games-arcade/vor/vor-0.5.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils gnome2-utils games
+
+DESCRIPTION="Variations on Rockdodger: Dodge the rocks until you die"
+HOMEPAGE="http://jasonwoof.org/vor"
+SRC_URI="http://qualdan.com/vor/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[mod]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-underlink.patch"
+ eautoreconf
+}
+
+src_install() {
+ dodir "${GAMES_BINDIR}"
+ DOCS="README* todo" default
+ newicon -s 48 data/icon.png ${PN}.png
+ make_desktop_entry ${PN} VoR
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}