summaryrefslogtreecommitdiff
path: root/games-arcade/xjump
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/xjump
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/xjump')
-rw-r--r--games-arcade/xjump/Manifest2
-rw-r--r--games-arcade/xjump/files/xjump-2.7.5-ldflags.patch11
-rw-r--r--games-arcade/xjump/metadata.xml5
-rw-r--r--games-arcade/xjump/xjump-2.7.5.ebuild56
4 files changed, 74 insertions, 0 deletions
diff --git a/games-arcade/xjump/Manifest b/games-arcade/xjump/Manifest
new file mode 100644
index 00000000000..c76f49d638d
--- /dev/null
+++ b/games-arcade/xjump/Manifest
@@ -0,0 +1,2 @@
+DIST xjump_2.7.5-6.1.debian.tar.gz 9803 SHA256 f01891ca46a7e73a30080821b9cfc9759be6e5ffaed6e4e4aa4bd1bca5edd57c SHA512 c4962acd25c4cabef37acd3b5d39867a955f2fa769cc203fb00edfe37f37ce25369099b589a282189847e7bffeb874b4eaf8deea9320a9083da7e95425625cf8 WHIRLPOOL 33d4808eeec837a2423851221519135c3eb01608b9c55444496af8e9d36735b483ba4ada9fde00b328bc7056f9b0c77f36d9d656455b191268e8eaed7c6a366b
+DIST xjump_2.7.5.orig.tar.gz 15940 SHA256 d96605e3aa6ca7751161d9bd19d53bb9d11fdcaf3901a14b4e2dce9b129f09b4 SHA512 6ce846d6681bf8b084edc06f8415a57f66d1778ec9af8b9b170f4f37292a8172b3507a08c85032a5b8588b50a7f2eefe205add4c779edd7c7ef8fb6d818d9300 WHIRLPOOL 5744480b08b4263cd84ce251b38cd1d84ba9f1ff4c8182d714eb6d2d433b749840b71056f5babba604aedd5930697e7bb3bdfcfb1c2677d39151492896a91266
diff --git a/games-arcade/xjump/files/xjump-2.7.5-ldflags.patch b/games-arcade/xjump/files/xjump-2.7.5-ldflags.patch
new file mode 100644
index 00000000000..a3073681131
--- /dev/null
+++ b/games-arcade/xjump/files/xjump-2.7.5-ldflags.patch
@@ -0,0 +1,11 @@
+--- Makefile.old 2010-10-01 07:05:03.000000000 +0200
++++ Makefile 2010-10-01 07:05:39.000000000 +0200
+@@ -28,7 +28,7 @@
+ ##########################################################
+
+ xjump : main.o game.o key.o misc.o record.o resource.o
+- $(CC) $(CFLAGS) -o xjump \
++ $(CC) $(LDFLAGS) $(CFLAGS) -o xjump \
+ main.o game.o key.o misc.o record.o resource.o\
+ -lXaw -lXmu -lXt -lXpm -lXext -lX11 $(LDIR)
+
diff --git a/games-arcade/xjump/metadata.xml b/games-arcade/xjump/metadata.xml
new file mode 100644
index 00000000000..d3c2cc926f0
--- /dev/null
+++ b/games-arcade/xjump/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-arcade/xjump/xjump-2.7.5.ebuild b/games-arcade/xjump/xjump-2.7.5.ebuild
new file mode 100644
index 00000000000..3588f67b6d6
--- /dev/null
+++ b/games-arcade/xjump/xjump-2.7.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils games
+
+DEBIAN_PATCH="6.1"
+DESCRIPTION="An X game where one tries to jump up as many levels as possible"
+HOMEPAGE="http://packages.debian.org/stable/games/xjump"
+SRC_URI="mirror://debian/pool/main/x/${PN}/${PN}_${PV}.orig.tar.gz
+ mirror://debian/pool/main/x/${PN}/${PN}_${PV}-${DEBIAN_PATCH}.debian.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXpm
+ x11-libs/libXt"
+
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S=${WORKDIR}/${P}.orig
+
+src_prepare() {
+ # Where we will keep the highscore file:
+ HISCORE_FILENAME=xjump.hiscores
+ HISCORE_FILE="${GAMES_STATEDIR}/${HISCORE_FILENAME}"
+
+ epatch \
+ "${WORKDIR}"/debian/patches/0*.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
+
+ # set up where we will keep the highscores file:
+ sed -i \
+ -e "/^CC/d" \
+ -e "/^CFLAGS/d" \
+ -e "s,/var/games/xjump,${GAMES_STATEDIR}," \
+ -e "s,/record,/${HISCORE_FILENAME}," \
+ Makefile || die
+}
+
+src_install() {
+ dogamesbin xjump
+ dodoc README.euc
+
+ # Set up the hiscores file:
+ dodir "${GAMES_STATEDIR}"
+ touch "${D}/${HISCORE_FILE}"
+ fperms 660 "${HISCORE_FILE}"
+ prepgamesdirs
+}