summaryrefslogtreecommitdiff
path: root/games-arcade
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2017-09-05 13:30:19 -0500
committerAustin English <wizardedit@gentoo.org>2017-09-05 13:32:26 -0500
commit57931659ff17897d8015248fe798e040fd18c905 (patch)
treedf634ed10a52461aade8170afeb60265f1bbec76 /games-arcade
parent31c09bb4c06a4a8fa57038d6059821579af61880 (diff)
downloadgentoo-57931659ff17897d8015248fe798e040fd18c905.tar.gz
gentoo-57931659ff17897d8015248fe798e040fd18c905.tar.xz
games-arcade/opentyrian: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/opentyrian/opentyrian-2.1.20130907-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/games-arcade/opentyrian/opentyrian-2.1.20130907-r1.ebuild b/games-arcade/opentyrian/opentyrian-2.1.20130907-r1.ebuild
new file mode 100644
index 00000000000..5b961968215
--- /dev/null
+++ b/games-arcade/opentyrian/opentyrian-2.1.20130907-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="Open-source port of the DOS game Tyrian, vertical scrolling shooter"
+HOMEPAGE="https://bitbucket.org/opentyrian/opentyrian/wiki/Home"
+SRC_URI="http://darklomax.org/tyrian/tyrian21.zip
+ http://www.camanis.net/${PN}/releases/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl
+ media-libs/sdl-net"
+
+# Yes, mercurial is needed to set the build version stamp.
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-vcs/mercurial"
+
+PATCHES=(
+ "${FILESDIR}/${PV}-datapath.diff"
+ "${FILESDIR}/${PV}-cflag-idiocy.diff"
+)
+
+src_compile() {
+ emake DATA_PATH="/usr/share/${PN}" || die "Compilation failed"
+}
+
+src_install() {
+ dobin opentyrian || die "Failed to install game binary"
+ dosym ../../usr/bin/opentyrian /usr/bin/tyrian || die "Failed to symlink"
+ dodoc CREDITS NEWS README || die "Failed to install documentation"
+ domenu linux/opentyrian.desktop || die "Failed to install desktop file"
+ for i in linux/icons/*.png ; do
+ local size=`echo ${i} | sed -e 's:.*-\([0-9]\+\).png:\1:'`
+ insinto /usr/share/icons/hicolor/${size}x${size}/apps
+ newins ${i} opentyrian.png || die "Failed to install program icon"
+ done
+ insinto "/usr/share/${PN}"
+ cd "${WORKDIR}/tyrian21"
+ rm *.exe dpmi16bi.ovl loudness.awe || die "Failed to remove win32 binaries"
+ doins * || die "Failed to install game data"
+}