summaryrefslogtreecommitdiff
path: root/games-emulation/dboxfe
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-06-29 16:50:16 -0500
committerAustin English <wizardedit@gentoo.org>2016-06-29 16:51:01 -0500
commitce01f45d6cbc194f3088d4e4629d5999cdfcfd49 (patch)
tree8a293f5bc5c3632f385b893fc4bbd9aad5c993ca /games-emulation/dboxfe
parent255abaa802ab8078625e8484f7c01809fd728301 (diff)
downloadgentoo-ce01f45d6cbc194f3088d4e4629d5999cdfcfd49.tar.gz
gentoo-ce01f45d6cbc194f3088d4e4629d5999cdfcfd49.tar.xz
games-emulation/dboxfe: removed deprecated games/qt4-r2 eclasses
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.2.28
Diffstat (limited to 'games-emulation/dboxfe')
-rw-r--r--games-emulation/dboxfe/dboxfe-0.1.3-r1.ebuild30
-rw-r--r--games-emulation/dboxfe/files/dboxfe-0.1.3-ldflags.patch8
2 files changed, 34 insertions, 4 deletions
diff --git a/games-emulation/dboxfe/dboxfe-0.1.3-r1.ebuild b/games-emulation/dboxfe/dboxfe-0.1.3-r1.ebuild
new file mode 100644
index 00000000000..b2526f47795
--- /dev/null
+++ b/games-emulation/dboxfe/dboxfe-0.1.3-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Creates and manages configuration files for DOSBox"
+HOMEPAGE="http://sourceforge.net/projects/dboxfe.berlios/"
+SRC_URI="mirror://sourceforge/dboxfe.berlios/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtgui:4
+ dev-qt/qtcore:4"
+RDEPEND="${DEPEND}
+ >=games-emulation/dosbox-0.65"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-ldflags.patch
+)
+
+src_install() {
+ default
+ dobin bin/dboxfe
+ newicon res/default.png ${PN}.png
+ make_desktop_entry dboxfe "DosBoxFE"
+}
diff --git a/games-emulation/dboxfe/files/dboxfe-0.1.3-ldflags.patch b/games-emulation/dboxfe/files/dboxfe-0.1.3-ldflags.patch
index 6ceb1d2d5c2..b5927823d0c 100644
--- a/games-emulation/dboxfe/files/dboxfe-0.1.3-ldflags.patch
+++ b/games-emulation/dboxfe/files/dboxfe-0.1.3-ldflags.patch
@@ -1,5 +1,5 @@
---- dboxfe.pro.old 2010-09-29 23:53:38.000000000 +0200
-+++ dboxfe.pro 2010-09-29 23:54:11.000000000 +0200
+--- a/dboxfe.pro 2010-09-29 23:53:38.000000000 +0200
++++ b/dboxfe.pro 2010-09-29 23:54:11.000000000 +0200
@@ -83,6 +83,7 @@
# Unix/Linux settings
unix{
@@ -8,8 +8,8 @@
#QMAKE_POST_LINK = strip -s bin/dboxfe
RCC_DIR = .unix/rcc
MOC_DIR += .unix/moc
---- dboxfetray/dboxfetray.pro.old 2010-09-29 23:55:31.000000000 +0200
-+++ dboxfetray/dboxfetray.pro 2010-09-29 23:56:12.000000000 +0200
+--- a/dboxfetray/dboxfetray.pro 2010-09-29 23:55:31.000000000 +0200
++++ b/dboxfetray/dboxfetray.pro 2010-09-29 23:56:12.000000000 +0200
@@ -56,6 +56,7 @@
# Unix/Linux settings
unix{