summaryrefslogtreecommitdiff
path: root/games-emulation/dosbox
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-11-21 22:31:11 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2015-11-21 22:31:11 -0500
commit84cdfc9edf08535a3e2e0dd177f2456b5174a308 (patch)
treeca36114bec26b2f346d04838c6b77d13fccc082c /games-emulation/dosbox
parentf66c895ec0f7001a1bf19a4abd28850a78a14886 (diff)
downloadgentoo-84cdfc9edf08535a3e2e0dd177f2456b5174a308.tar.gz
gentoo-84cdfc9edf08535a3e2e0dd177f2456b5174a308.tar.xz
use epatch to apply patch
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'games-emulation/dosbox')
-rw-r--r--games-emulation/dosbox/dosbox-0.74.ebuild8
-rw-r--r--games-emulation/dosbox/dosbox-9999.ebuild2
2 files changed, 6 insertions, 4 deletions
diff --git a/games-emulation/dosbox/dosbox-0.74.ebuild b/games-emulation/dosbox/dosbox-0.74.ebuild
index 56a0bb8c15d..522a4615f02 100644
--- a/games-emulation/dosbox/dosbox-0.74.ebuild
+++ b/games-emulation/dosbox/dosbox-0.74.ebuild
@@ -16,14 +16,16 @@ IUSE="alsa debug hardened opengl"
DEPEND="alsa? ( media-libs/alsa-lib )
opengl? ( virtual/glu virtual/opengl )
- debug? ( sys-libs/ncurses )
+ debug? ( sys-libs/ncurses:0 )
media-libs/libpng:0
media-libs/libsdl[joystick,video,X]
media-libs/sdl-net
media-libs/sdl-sound"
-RDEPEND="${DEPEND}"
+RDEPEND=${DEPEND}
-PATCHES=( "${FILESDIR}"/${P}-gcc46.patch )
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc46.patch
+}
src_configure() {
egamesconf \
diff --git a/games-emulation/dosbox/dosbox-9999.ebuild b/games-emulation/dosbox/dosbox-9999.ebuild
index f01034ef4e6..f0caa33b0f3 100644
--- a/games-emulation/dosbox/dosbox-9999.ebuild
+++ b/games-emulation/dosbox/dosbox-9999.ebuild
@@ -16,7 +16,7 @@ IUSE="alsa debug hardened opengl"
DEPEND="alsa? ( media-libs/alsa-lib )
opengl? ( virtual/glu virtual/opengl )
- debug? ( sys-libs/ncurses )
+ debug? ( sys-libs/ncurses:0 )
media-libs/libpng:0
media-libs/libsdl[joystick,video,X]
media-libs/sdl-net